## Contents

### Preface
- Documentation Conventions ................................................................. 9
- Related Publications ........................................................................... 10
- Customer Support ............................................................................... 11
- Information You Should Have ............................................................ 12
- User Feedback ................................................................................... 13
- Information Builders Consulting and Training ..................................... 13

### 1. Introducing InfoAssist
- InfoAssist .......................................................................................... 16
- Personal InfoAssist ............................................................................. 16
- InfoAssist Basic ................................................................................ 17
- InfoMini .............................................................................................. 18
- Accessibility Compliance With InfoAssist ......................................... 19

### 2. Getting Started With InfoAssist
- Accessing InfoAssist .......................................................................... 22
- Accessing Personal InfoAssist .............................................................. 22
- Accessing InfoAssist Basic ................................................................. 23
- Accessing InfoMini ............................................................................ 23
- Creating a New Procedure ................................................................. 23
- Accessing InfoAssist Options ............................................................. 24
  - Getting Started ............................................................................... 24
  - Help ................................................................................................. 25
- Changing User Preferences ................................................................. 25
  - Startup Options ............................................................................. 26
  - Layout .............................................................................................. 26
  - View ............................................................................................... 27
  - Format ............................................................................................ 27
  - Environment and Styling ............................................................... 27
3. Navigating the InfoAssist Interface

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>InfoAssist Application Window</td>
<td>30</td>
</tr>
<tr>
<td>Application Main Menu</td>
<td>31</td>
</tr>
<tr>
<td>Quick Access Toolbar</td>
<td>35</td>
</tr>
<tr>
<td>Ribbon</td>
<td>36</td>
</tr>
<tr>
<td>Home Tab</td>
<td>39</td>
</tr>
<tr>
<td>Format Group</td>
<td>39</td>
</tr>
<tr>
<td>Design Group</td>
<td>41</td>
</tr>
<tr>
<td>Filter Group</td>
<td>42</td>
</tr>
<tr>
<td>Report Group</td>
<td>42</td>
</tr>
<tr>
<td>Report Style Dialog Box</td>
<td>45</td>
</tr>
<tr>
<td>Color Dialog Box</td>
<td>46</td>
</tr>
<tr>
<td>Insert Tab</td>
<td>47</td>
</tr>
<tr>
<td>Reports Group</td>
<td>48</td>
</tr>
<tr>
<td>Objects Group</td>
<td>48</td>
</tr>
<tr>
<td>Active Technologies Dashboard Prompts Group</td>
<td>49</td>
</tr>
<tr>
<td>Format Tab</td>
<td>50</td>
</tr>
<tr>
<td>Output Types Group</td>
<td>51</td>
</tr>
<tr>
<td>Destination Group</td>
<td>54</td>
</tr>
<tr>
<td>Navigation Group (Reports Only)</td>
<td>55</td>
</tr>
<tr>
<td>Features Group (Reports)</td>
<td>57</td>
</tr>
<tr>
<td>Features Group (Charts)</td>
<td>58</td>
</tr>
<tr>
<td>Chart Types Group (Charts)</td>
<td>60</td>
</tr>
<tr>
<td>Labels Group (Charts)</td>
<td>61</td>
</tr>
<tr>
<td>Data Tab</td>
<td>62</td>
</tr>
<tr>
<td>Calculation Group</td>
<td>62</td>
</tr>
<tr>
<td>Join Group</td>
<td>64</td>
</tr>
<tr>
<td>Filter Group</td>
<td>67</td>
</tr>
<tr>
<td>Display Group</td>
<td>72</td>
</tr>
<tr>
<td>Data Source Group</td>
<td>72</td>
</tr>
<tr>
<td>Slicers Tab</td>
<td>74</td>
</tr>
<tr>
<td>Options Group</td>
<td>74</td>
</tr>
<tr>
<td>Record Limit Group</td>
<td>74</td>
</tr>
<tr>
<td>Section</td>
<td>Page</td>
</tr>
<tr>
<td>----------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Group Number Group</td>
<td>75</td>
</tr>
<tr>
<td>Layout Tab</td>
<td>76</td>
</tr>
<tr>
<td>Page Setup Group</td>
<td>76</td>
</tr>
<tr>
<td>Size &amp; Arrange Group</td>
<td>77</td>
</tr>
<tr>
<td>Report Group</td>
<td>77</td>
</tr>
<tr>
<td>View Tab</td>
<td>78</td>
</tr>
<tr>
<td>Design Group</td>
<td>78</td>
</tr>
<tr>
<td>Show/Hide Group</td>
<td>78</td>
</tr>
<tr>
<td>Data Panel Group</td>
<td>79</td>
</tr>
<tr>
<td>Query Panel Group</td>
<td>81</td>
</tr>
<tr>
<td>Output Window Group</td>
<td>83</td>
</tr>
<tr>
<td>Report Group (Reports)</td>
<td>84</td>
</tr>
<tr>
<td>Field Tab</td>
<td>85</td>
</tr>
<tr>
<td>Filter Group</td>
<td>86</td>
</tr>
<tr>
<td>Sort Group</td>
<td>89</td>
</tr>
<tr>
<td>Break Group (Reports)</td>
<td>90</td>
</tr>
<tr>
<td>Style Group</td>
<td>91</td>
</tr>
<tr>
<td>Format Group</td>
<td>91</td>
</tr>
<tr>
<td>Display Group</td>
<td>92</td>
</tr>
<tr>
<td>Links Group</td>
<td>93</td>
</tr>
<tr>
<td>Series Tab</td>
<td>95</td>
</tr>
<tr>
<td>Select Group</td>
<td>95</td>
</tr>
<tr>
<td>Properties Group</td>
<td>95</td>
</tr>
<tr>
<td>Line Group</td>
<td>97</td>
</tr>
<tr>
<td>Pie Group</td>
<td>98</td>
</tr>
<tr>
<td>Display Group</td>
<td>99</td>
</tr>
<tr>
<td>Understanding the Resources Panel</td>
<td>99</td>
</tr>
<tr>
<td>Using the Data Pane to Add Fields to a Report</td>
<td>104</td>
</tr>
<tr>
<td>Using the Query Design Pane in the Resources Pane</td>
<td>105</td>
</tr>
<tr>
<td>Using Right-Click Field Options in the Query Design Pane</td>
<td>108</td>
</tr>
<tr>
<td>Understanding the Results Panel</td>
<td>115</td>
</tr>
<tr>
<td>Using the Query Design Pane in the Results Panel</td>
<td>116</td>
</tr>
<tr>
<td>Understanding the Layout Canvas</td>
<td>119</td>
</tr>
<tr>
<td>Understanding Output Options</td>
<td>121</td>
</tr>
</tbody>
</table>
### 4. Creating and Customizing Reports

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Creating a Basic Report</td>
<td>136</td>
</tr>
<tr>
<td>Report Outputs</td>
<td>138</td>
</tr>
<tr>
<td>Styling Reports</td>
<td>139</td>
</tr>
<tr>
<td>Changing a Field Format</td>
<td>154</td>
</tr>
<tr>
<td>Using Custom Reporting Features</td>
<td>157</td>
</tr>
<tr>
<td>Creating Customized Report Outputs</td>
<td>170</td>
</tr>
</tbody>
</table>

### 5. Creating and Customizing Charts

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Visualizing Your Data With Charts</td>
<td>182</td>
</tr>
<tr>
<td>Selecting a Chart</td>
<td>183</td>
</tr>
<tr>
<td>Bar Charts</td>
<td>183</td>
</tr>
<tr>
<td>Pie Charts</td>
<td>186</td>
</tr>
<tr>
<td>Line Charts</td>
<td>188</td>
</tr>
<tr>
<td>Area Charts</td>
<td>189</td>
</tr>
<tr>
<td>Multi-Axis Charts</td>
<td>191</td>
</tr>
<tr>
<td>XY Plot Charts</td>
<td>191</td>
</tr>
<tr>
<td>3D Charts</td>
<td>195</td>
</tr>
<tr>
<td>Stock Charts</td>
<td>196</td>
</tr>
<tr>
<td>Special Charts</td>
<td>197</td>
</tr>
<tr>
<td>Combination Charts</td>
<td>198</td>
</tr>
<tr>
<td>Creating a Chart</td>
<td>199</td>
</tr>
<tr>
<td>Chart Outputs</td>
<td>203</td>
</tr>
<tr>
<td>Accessing Chart Formatting Tools</td>
<td>204</td>
</tr>
<tr>
<td>Identifying Chart Elements</td>
<td>204</td>
</tr>
<tr>
<td>Using Live Preview</td>
<td>205</td>
</tr>
<tr>
<td>Using Right-Click Field Options in the Query Design Pane</td>
<td>207</td>
</tr>
<tr>
<td>Formatting a Series</td>
<td>208</td>
</tr>
<tr>
<td>Associated Dialog Boxes</td>
<td>208</td>
</tr>
<tr>
<td>Series Elements Right-Click Menu</td>
<td>214</td>
</tr>
<tr>
<td>Using Series Properties</td>
<td>217</td>
</tr>
<tr>
<td>Formatting Data Labels</td>
<td>242</td>
</tr>
</tbody>
</table>
6. Creating and Customizing Documents .................................................................355

    6.1 Accessing Document View .................................................................356
    6.2 Building a Document .................................................................361
        6.2.1 Inserting Reports From Multiple Data Sources .................................361
        6.2.2 Inserting a New Report .................................................................363
        6.2.3 Inserting a New Chart .................................................................367
        6.2.4 Inserting an Existing Report ..........................................................371
    6.3 Creating a Document From a Single Report .............................................372
Preface

This documentation describes how to use the WebFOCUS InfoAssist application. It is intended for users that need to create, modify, and run reports.

Contact your local Information Builders account manager to learn how to license and enable this new capability.

**Note:** The WebFOCUS toolset generates the rich FOCUS fourth generation language. While this language is very extensive, the WebFOCUS toolset only supports a subset of the language and only specific syntax constructs. While the user can manually modify the content of these WebFOCUS procedures and files, there is no guarantee that the user will be able to open the modified procedure in the tool.

How This Manual Is Organized

This manual includes the following chapters:

<table>
<thead>
<tr>
<th>Chapter/Appendix</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Introducing InfoAssist</td>
<td>Describes the benefits of the InfoAssist ad hoc reporting tool, how to access it, and how to use its start-up screen.</td>
</tr>
<tr>
<td>2 Getting Started With InfoAssist</td>
<td>Describes how to start working with each version of the InfoAssist application and how to set your user preferences.</td>
</tr>
<tr>
<td>3 Navigating the InfoAssist Interface</td>
<td>Describes how to use the elements that make up the application window.</td>
</tr>
<tr>
<td>4 Creating and Customizing Reports</td>
<td>Describes how to create, customize, and style reports, and provides an overview of output formats.</td>
</tr>
<tr>
<td>5 Creating and Customizing Charts</td>
<td>Describes how to create and customize charts, and provides an overview of the available chart types and output formats.</td>
</tr>
</tbody>
</table>
## Contents

<table>
<thead>
<tr>
<th>Chapter/Appendix</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>6</td>
<td>Creating and Customizing Documents</td>
</tr>
<tr>
<td>7</td>
<td>Creating Active Technologies Reports, Charts, and Dashboards With InfoAssist</td>
</tr>
<tr>
<td>8</td>
<td>Using Slicers</td>
</tr>
<tr>
<td>9</td>
<td>Building InfoMini Applications</td>
</tr>
<tr>
<td>A</td>
<td>Glossary</td>
</tr>
</tbody>
</table>

## Documentation Conventions

The following table describes the documentation conventions that are used in this manual.

<table>
<thead>
<tr>
<th>Convention</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>THIS TYPEFACE or this typeface</td>
<td>Denotes syntax that you must enter exactly as shown.</td>
</tr>
<tr>
<td>this typeface</td>
<td>Represents a placeholder (or variable) in syntax for a value that you or the system must supply.</td>
</tr>
<tr>
<td>underscore</td>
<td>Indicates a default setting.</td>
</tr>
<tr>
<td>this typeface</td>
<td>Represents a placeholder (or variable), a cross-reference, or an important term. It may also indicate a button, menu item, or dialog box option that you can click or select.</td>
</tr>
<tr>
<td>this typeface</td>
<td>Highlights a file name or command.</td>
</tr>
<tr>
<td>Key + Key</td>
<td>Indicates keys that you must press simultaneously.</td>
</tr>
</tbody>
</table>
### Convention

<table>
<thead>
<tr>
<th>Convention</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>{  }</td>
<td>Indicates two or three choices. Type one of them, not the braces.</td>
</tr>
<tr>
<td>[  ]</td>
<td>Indicates a group of optional parameters. None are required, but you may select one of them. Type only the parameter in the brackets, not the brackets.</td>
</tr>
<tr>
<td></td>
<td>Separates mutually exclusive choices in syntax. Type one of them, not the symbol.</td>
</tr>
<tr>
<td>...</td>
<td>Indicates that you can enter a parameter multiple times. Type only the parameter, not the ellipsis (...).</td>
</tr>
<tr>
<td>. . .</td>
<td>Indicates that there are (or could be) intervening or additional commands.</td>
</tr>
</tbody>
</table>

### Related Publications

To view a current listing of our publications and to place an order, visit our Technical Documentation Library, [http://documentation.informationbuilders.com](http://documentation.informationbuilders.com). You can also contact the Publications Order Department at (800) 969-4636.

### Customer Support

Do you have any questions about this product?

Join the Focal Point community. Focal Point is our online developer center and more than a message board. It is an interactive network of more than 3,000 developers from almost every profession and industry, collaborating on solutions and sharing tips and techniques. Access Focal Point at [http://forums.informationbuilders.com/eve/forums](http://forums.informationbuilders.com/eve/forums).

You can also access support services electronically, 24 hours a day, with InfoResponse Online. InfoResponse Online is accessible through our website, [http://www.informationbuilders.com](http://www.informationbuilders.com). It connects you to the tracking system and known-problem database at the Information Builders support center. Registered users can open, update, and view the status of cases in the tracking system and read descriptions of reported software issues. New users can register immediately for this service. The technical support section of [www.informationbuilders.com](http://www.informationbuilders.com) also provides usage techniques, diagnostic tips, and answers to frequently asked questions.
Call Information Builders Customer Support Services (CSS) at (800) 736-6130 or (212) 736-6130. Customer Support Consultants are available Monday through Friday between 8:00 a.m. and 8:00 p.m. EST to address all your questions. Information Builders consultants can also give you general guidance regarding product capabilities and documentation. Please be ready to provide your six-digit site code number (xxxx.xx) when you call.

To learn about the full range of available support services, ask your Information Builders representative about InfoResponse Online, or call (800) 969-INFO.

**Information You Should Have**

To help our consultants answer your questions effectively, be prepared to provide the following information when you call:

- Your six-digit site code (xxxx.xx).
- Your WebFOCUS configuration:
  - The front-end you are using, including vendor and release.
  - The communications protocol (for example, TCP/IP or HLLAPI), including vendor and release.
  - The software release.
  - Your server version and release. You can find this information using the Version option in the Web Console.
- The stored procedure (preferably with line numbers) or SQL statements being used in server access.
- The Master File and Access File.
- The exact nature of the problem:
  - Are the results or the format incorrect? Are the text or calculations missing or misplaced?
  - Provide the error message and return code, if applicable.
  - Is this related to any other problem?
- Has the procedure or query ever worked in its present form? Has it been changed recently? How often does the problem occur?
- What release of the operating system are you using? Has it, your security system, communications protocol, or front-end software changed?
- Is this problem reproducible? If so, how?
Have you tried to reproduce your problem in the simplest form possible? For example, if you are having problems joining two data sources, have you tried executing a query containing just the code to access the data source?

Do you have a trace file?

How is the problem affecting your business? Is it halting development or production? Do you just have questions about functionality or documentation?

**User Feedback**

In an effort to produce effective documentation, the Documentation Services staff welcomes your opinions regarding this manual. Please use the Reader Comments form at the end of this manual to communicate suggestions for improving this publication or to alert us to corrections. You can also use the Documentation Feedback form on our website, [http://documentation.informationbuilders.com/feedback.asp](http://documentation.informationbuilders.com/feedback.asp).

Thank you, in advance, for your comments.

**Information Builders Consulting and Training**

Interested in training? Information Builders Education Department offers a wide variety of training courses for this and other Information Builders products.

For information on course descriptions, locations, and dates, or to register for classes, visit our website ([http://www.informationbuilders.com](http://www.informationbuilders.com)) or call (800) 969-INFO to speak to an Education Representative.
Introducing InfoAssist

InfoAssist provides business users with the most advanced, yet simple to use, ad hoc reporting features needed to create intricate reports and perform insightful analysis.

InfoAssist provides a robust, user-friendly solution that helps companies overcome traditional ad hoc reporting challenges.

InfoAssist is available in the following versions:

- **InfoAssist.** Complete version of this powerful report-generation tool.
- **Personal InfoAssist.** Self-service version of InfoAssist.
- **InfoAssist Basic.** Limited version of InfoAssist provided to existing Report and Graph Assist customers.
- **InfoMini.** Applications built from an InfoAssist report that contain a subset of InfoAssist functionality at run time.

**Topics:**

- InfoAssist
- Personal InfoAssist
- InfoAssist Basic
- InfoMini
- Accessibility Compliance With InfoAssist
InfoAssist

InfoAssist is the web-based ad hoc reporting tool in WebFOCUS.

With InfoAssist, you can quickly and easily:

- Generate highly complex reports, charts, dashboards, and documents from any enterprise information source without IT intervention.
- Complete tasks, such as building a report, with minimal clicks.
- Convert reports to charts, or charts to reports, in a single click.
- Analyze multiple reports and charts simultaneously, using advanced tiling options to view data from multiple perspectives.
- Browse more than 300 enterprise-information sources, including multi-dimensional sources.
- Output report and chart data in a variety of formats, including HTML, HTML5 (charts only), active reports, active Flash®, PDF, active PDF, Excel®, and PowerPoint®.

InfoAssist is a Rich Internet Application (RIA) that uses AJAX (Asynchronous JavaScript and XML) technology. It delivers its cutting-edge functionality using a familiar Microsoft Windows® ribbon interface. This highly intuitive environment shields users from the underlying technical complexities associated with ad hoc reporting features, while providing access to all the functionality needed to address mission-critical information requirements.

This powerful ad hoc reporting tool enables rapid and efficient design and deployment of reports and charts. It uses an interactive and fully-customizable WYSIWYG (What You See Is What You Get) development environment. Users receive instant feedback throughout the development process to ensure that reports and charts are properly built.

Personal InfoAssist

Personal InfoAssist is available outside the BI Portal (Managed Reporting) environment. Any application can call and open Personal InfoAssist. This feature enables you to integrate InfoAssist into your own self-service applications.

With Personal InfoAssist, you can browse for saved reports (procedures) on your local desktop. You can also save reports to the local desktop and restore them from the desktop. You execute reports only within InfoAssist. There is no facility that allows query execution outside the tool.

All functionality of InfoAssist is provided in Personal InfoAssist, except the following:

- Customizing InfoAssist by modifying user preferences.
- Drilling down to a procedure.
Applying custom themes.

Running reports in deferred mode.

InfoMini.

**InfoAssist Basic**

InfoAssist Basic is a modern web-based facility that provides comparable functionality to legacy reporting tools. InfoAssist Basic contains many of the features of InfoAssist, while still allowing you to create and edit reports and charts as you would with a legacy tool.

InfoAssist Basic is an advanced, yet simple to use, ad hoc reporting tool that offers dynamic features for creating intricate reports and performing insightful analysis.

Using InfoAssist Basic, you can create a customized report, organize report output with sorting, change a column heading and format, add a page heading and footing, enhance the appearance of the report, create a matrix report, and validate and test your work.

InfoAssist Basic does not include the following capabilities found in InfoAssist:

- General Features
  - Creating dashboards and documents
  - Live Preview
  - Publishing
  - InfoMini
  - Slicers
  - Cube Browser
  - Chart to Report conversion

- Home tab
  - Format group

- Format tab
  - Destination group
  - Reference Lines
  - Annotations
  - Format Horizontal Grid Lines - Color Bands tab and Frames tab
  - Format Vertical Grid Lines - Color Bands tab and Frames tab
Business analysts can use InfoAssist to build InfoMini applications that enable their non-technical end users to modify reports without having to learn a tool or rely on IT for support.

InfoMini enables business analysts and end users to choose the information they receive from their BI system with the click of a button, displaying only the information specific to their needs for faster, more informed decision-making.

With InfoMini, a business analyst can easily build an application to customize or filter a report into any format an end user needs.
This tailored interactivity feature allows specific conditional styling, formatting, or functionality to be applied to any individual report without manual coding.

Business analysts can also build and publish gadgets (or mini-applications similar to an iGoogle® widget) that connect directly to the BI system to pull customizable information and reports.

**Accessibility Compliance With InfoAssist**

InfoAssist is Section 508 compliant with the following end-user configuration:

- Internet Explorer® Version 7 or 8.
- JAWS® Version 11.0 or later. See the Freedom Scientific® website, [http://www.freedomscientific.com](http://www.freedomscientific.com), for browser requirement information.

For more information on specific accessibility requirements for InfoAssist, see the WebFOCUS Accessibility Guide.
You can quickly access each of the versions of InfoAssist using the information provided in the following sections.

Once you get started with InfoAssist, you can easily change your user preferences to customize the way that InfoAssist behaves when you are creating reports and charts and generating output.

You can customize the InfoAssist interface by selecting a particular theme that styles all menus and dialog boxes. In addition, you can style your reports and charts with a distinctive document theme.
Accessing InfoAssist

To access InfoAssist, type valid credentials in the User Name and Password text fields and click Sign In. The WebFOCUS Sign In page is shown in the following image.

Accessing Personal InfoAssist

To access Personal InfoAssist, type the following URL in a web browser.

http://hostname[:port]/wf_context_root/MyIA[?IBIC_server=server][&IBIAPP_app=app]

where:

hostname[:port]
Is the name of the host where the WebFOCUS application is deployed. Specify the optional port number only if you are not using the default port number.

wf_context_root
Is the site-customized context root for the WebFOCUS application deployed on your application server. The default value is ibi_apps.

server
Is the optional Reporting Server to use.
Is the optional application path name to search.

**Accessing InfoAssist Basic**

To access InfoAssist Basic, type valid credentials in the WebFOCUS Sign In page and click **Sign In**. InfoAssist Basic has a unique license code that distinguishes it from the complete version of InfoAssist.

**Accessing InfoMini**

You have the option to activate InfoMini when you create a report in InfoAssist. When you run a report with InfoMini activated, an InfoMini application is launched. An InfoMini application contains a subset of the functionality available to a full InfoAssist report. You can limit or expand the functionality that is available to the user at run time when you build the report in InfoAssist.

An InfoMini application opens in its own browser window if it is running from InfoAssist. Otherwise, InfoMini opens wherever you have it, such as a container in the Business Intelligence (BI) Portal.

**Creating a New Procedure**

After you have signed in to BI Portal, you can work with an existing folder, or create a new folder in the tree to store your reports, charts, dashboards, and documents. Once you have identified the folder you want to use, right-click it, point to New and then click **Report, Chart, Dashboard, or Document** to open InfoAssist. The Select a data source dialog box opens.

Select the data source that you want and click **OK** to close the dialog box. You can also double-click a data source to open it and close the dialog box in one step. If the data source that you want is not in the default directory, select a different directory using the Look in drop-down list.

Once you select your data source, the InfoAssist application window opens.
Accessing InfoAssist Options

In this section:
- Getting Started
- Help

On the InfoAssist application window, click the Application button to open the InfoAssist application main menu of procedure-related commands. When you click New a splash screen that contains all available options opens. The splash screen is shown in the following image.

The available options are grouped into Getting Started and Help.

![InfoAssist Splash Screen]

Note: When you launch InfoAssist Basic, this splash screen indicates that the application is InfoAssist Basic and displays the available options.

Getting Started

The following Getting Started options are available in InfoAssist:

- **Build a Report.** Opens the Select a data source dialog box, where you can select a data source for your report.
Build a Chart. Opens the Select a data source dialog box, where you can select a data source for your chart.

Build a Document. Opens the Select a data source dialog box, where you can select a data source for your document.

Open Existing Item. Opens the Open dialog box, where you can select an existing item.

Change Default Options. Opens the Options window, where you can change the default settings to reflect your preferences. For more information, see Changing User Preferences on page 25.

Close Application. Closes and exits the application.

Help

The Help options provide help for the new user. The following Help options are available when you open InfoAssist.

InfoAssist Help. Opens the online documentation window for InfoAssist.

Online Forum. Opens the Focal Point website in a new browser window.

Changing User Preferences

In this section:
Startup Options
Layout
View
Format
Environment and Styling

You can change the default user preferences to customize the way that InfoAssist behaves when you create reports and generate output. You can customize the InfoAssist interface, including all menus and dialog boxes, by selecting an application theme that applies the styling that you want.

Additionally, you can style your reports by selecting a document theme independent from the interface. On the InfoAssist application main menu, click Options, or on the InfoAssist Options dialog box, click Change Default Options.
The Options window, as shown in the following image, opens to provide you with a user-friendly interface for customizing the InfoAssist application.

If any of the options are unavailable, contact your administrator for assistance.

You can also select a document styling theme through the ribbon. Go to the Home tab, then in the Report group, click Theme. For more information, see Home Tab on page 39.

**Startup Options**

*Note:* The Startup Options are disabled because in WebFOCUS 8 you can choose the mode of InfoAssist directly from the Resource Tree in the BI Portal.

**Layout**

The Layout area provides settings for printing reports and charts.

- **Page Size.** Values are A4, A3, A5, Letter, Tabloid, and Legal. The default value is Letter.
- **Orientation.** Values are Portrait and Landscape. The default value is Portrait.
View

The View area provides settings for establishing the design view in which you will work, the type of data you will use when you preview your output, the limit you need to set on your record input, how your data and query panels will look, and the output target that you will use.

- **Design View.** Values are Interactive and Query. Select Interactive to activate the Preview Method drop-down menu. The default value is Interactive.

- **Preview Method.** Values are Preview with Source Data and Preview with Sample Data. This menu becomes active when you select Interactive from the Design View drop-down menu. The default value is Preview with Source Data.

- **Record Limit.** Values are All records, 1, 10, 50, 500, or you can type a numeric value directly in the menu. The default value is 500.

- **Data Panel.** Values are Logical, List, and Structured. The default value is Logical.

- **Query Panel.** Values are 2x2 (2 columns by 2 rows), 1x4 (1 column by 4 rows), and Tree. The default value is Tree.

- **Output Target.** Values are Single Tab, New Tab, Single Window, and New Window. The default value is Single Tab.

Format

The Format area provides settings for the output types for reports, charts, and documents.

- **Report output type.** Values are HTML, PDF, PowerPoint, Excel 2007, Excel, active report, active Flash, and active PDF. The default value is HTML.

- **Chart output type.** Values are HTML, HTML5, PDF, PowerPoint, Excel, active report, active Flash, and active PDF. The default value is HTML.

- **Document output type.** Values are HTML, PDF, PowerPoint, Excel, active report, active Flash, and active PDF (for documents containing only reports). The default value is PDF.

Environment and Styling

The Environment and Styling area provides Application Theme settings to apply styling to all InfoAssist interfaces, menus, and dialog boxes. It also provides settings to apply styling to reports and charts.

- **Application Theme.** Select an Application Theme, for example, Graphite or High Contrast, to apply styling to all interfaces, menus, and dialog boxes.

- **Document Theme.** Select a Document Theme to apply styling to reports and charts.
You can use the default style sheet or select from a list of available themes. Click the Browse button to open the Templates - Browse predefined template files dialog box in which you can search for an existing WebFOCUS StyleSheet.
Navigating the InfoAssist Interface

InfoAssist provides an intelligent, flexible layout for creating reports, charts, dashboards, and documents. The application window provides intuitive menus and toolbars, a versatile ribbon that provides access to specialized groups for different functional areas of report design, a taskbar for selecting output, and a status bar for directing output.

The application window also provides a resources area for selecting and sorting data, and a multi-faceted results area that can display report design, a preview of report output, or actual report output.

### Topics:

- InfoAssist Application Window
- Application Main Menu
- Quick Access Toolbar
- Ribbon
- Home Tab
- Insert Tab
- Format Tab
- Data Tab
- Slicers Tab
- Layout Tab
- View Tab
- Field Tab
- Series Tab
- Understanding the Resources Panel
- Understanding the Results Panel
- Using the Navigation Taskbar
- Using the Status Bar
The components of the InfoAssist Application window are shown in the following image.

The InfoAssist main interface components are annotated as follows:

1. **Application button.** Provides access to the application menu of procedure-related commands.

2. **Quick Access Toolbar.** Displays frequently-used commands, such as New, Open, Save, Undo, Redo, View code, Run, and Preview, in a toolbar that remains visible. For more information, see *Quick Access Toolbar* on page 35.

3. **Ribbon.** Displays the commands you need to create reports, charts, and documents. It also displays the Help menu. For details, see *Ribbon* on page 36.

4. **Help.** Provides access to the online documentation window for InfoAssist and the Focal Point website in a new browser window.

5. **Resources panel.** Displays the fields from the selected data source in the Data pane. Also displays the Query Design pane below the Data pane, except in Query Design view. For more information, see *Understanding the Resources Panel* on page 99.

6. **Results panel.** Displays the Query Design pane, Layout canvas, or Output window.
The Query Design pane appears when you select Query Design view.

The Layout canvas appears in Live Preview mode when you create or modify a report. In Live Preview mode, the Results panel displays a preview of the report as you create the report.

The Output window appears when you execute a report.

For more information, see Understanding the Resources Panel on page 99.

7. **Navigation taskbar.** Displays groups and icons that provide different views and quick access to all active reports and report output. For details, see Using the Navigation Taskbar on page 131.

8. **Status bar.** Provides an output format button that you click to see the selected format and an output target button that you click to view the selected option for displaying new output windows or tabs. For more information, see Using the Status Bar on page 133.

**Application Main Menu**

In the upper-left corner of the InfoAssist interface, click the IA button to open the Application main menu, as shown in the following image.

You can run the following commands from the Application main menu:
New. Creates a new report, chart, dashboard, or document. The exact functionality of the New command depends on your current InfoAssist session.

If you open a Reporting Object through InfoAssist, and then click New, a new report is generated from the Reporting Object. You are prompted to choose the type of report you want to create from the Reporting Object.

When you open a new session of InfoAssist and then click New, a new report is created. You are prompted to choose a data source, as shown in the following image.

Open. Opens an existing item.

Save. Saves a report, chart, dashboard, or document.

Save As. Saves a report, chart, dashboard, or document with a new name.

Run. Runs a report, chart, dashboard, or document immediately.

Run Deferred. Submits a report, chart, dashboard, or document for processing in the background while you continue to work on other tasks.

Close. Closes the currently active report, chart, dashboard, or document.
Recent Items. Displays recent reports, charts, dashboards, and documents and those items that have been pinned to the menu. The Recent Items area of the InfoAssist Application main menu is shown in the following image.

Pinned reports, charts, dashboards, and documents are represented by a blue pin icon. Pinned items appear at the top of the list in alphabetical order.

Recent reports, charts, dashboards, and documents are represented by a sideways blue pin icon. Recent items appear below the separator bar in the order in which they were created, with the most recently created item at the top.

You can pin important reports, charts, dashboards, and documents to the top of the Recent Reports section of the Application main menu for quick and easy access. To promote a recent report to pinned report, click the sideways blue pin icon. The icon turns upright and the report is moved to the pinned report area of the Recent Items window, where it stays until it is unpinned.

To demote a pinned report, click the blue pin icon. The icon turns sideways and the report is moved below the separator bar.
Reports also have a context menu that you can access by right-clicking a report in the Recent Items section of the Application main menu. The menu is shown in the following image.

The options in the menu are:

- **Open.** Opens the selected report, chart, dashboard, or document.

- **Pin to list.** Pins a recent report, chart, dashboard, or document to the pinned reports list above the separator bar.

- **Remove from list.** Unpins a pinned report, chart, dashboard, or document from the pinned reports list.

- **Clear unpinned list.** Clears all reports, charts, dashboards, or documents from the Recent Items list.

- **Options.** Opens the Options window to customize your user preferences. For more information, see *Changing User Preferences* on page 25.

- **Exit.** Exits the application.
Quick Access Toolbar

The Quick Access Toolbar, as shown in the following image, provides access to the most commonly used functions. It is located to the right of the Application main menu button and is always visible no matter which options are selected. In addition to the New, Open, Save, and Run commands discussed in Application Main Menu on page 31, you can access the Undo, Redo, and View code commands. The Quick Access Toolbar contains a Run menu of commands. In addition to the Run command, the Run menu contains the Preview, SQL Trace, and SQL Preview Trace commands.

- **Undo and Redo.** The Undo icon undoes your last action. The Redo icon repeats your last action.

  The Undo icon is enabled (blue) when there is an action to undo. Otherwise, the icon is unavailable (gray). The Redo icon is enabled (blue) when there is an action to redo. Otherwise, the icon is unavailable (gray).

  For example, assume that your first action when creating a report is to add a database field to the report. After you add the database field, the Undo icon turns blue. You can now click the Undo icon to remove the database field from the report. The Undo icon turns gray, and the Redo icon turns blue. To restore the field to the report, click the blue Redo icon.

  You can also press Ctrl+Z to undo an action, or Ctrl+Y to redo an action.

  You can undo and redo up to 25 actions per session. InfoAssist maintains the undo and redo list of actions even when you switch between reports.

  When a dialog box is open in the application window, you cannot use the Undo and Redo icons. However, when you click OK and close the dialog box, the icons become available for use. With a single click of Undo, you can undo all the actions that you performed in the dialog box, and you can reinstate them with a single click of Redo.

- **View code.** View the underlying code for the report.

- **Run.** Click the Run button to run a report, chart, dashboard, or document immediately. Click the down arrow to open the Run menu, which contains the following additional options:

  - **Preview.** Runs the report, chart, dashboard, or document in the selected format with the limited number of records as set in the Design group on the Home tab. For more information, see Design Group on page 41.

  - **SQL Trace.** Returns the SQL commands for the request.
Ribbon

SQL Preview Trace. Returns the SQL commands for the Live Preview run.

The ribbon is a rectangular area of distinct groups of buttons that spans the top of the InfoAssist application window. The ribbon, with the Home tab selected, is shown in the following image.

The ribbon is made up of nine tabs. Each tab contains a subset of InfoAssist functionality organized in logically-related groups of controls and commands graphically represented by distinctive icons.

The tabs are:

- Home
- Insert
- Format
- Data
- Slicers
- Layout
- View
- Field
- Series (when creating a chart)

The Home tab is selected by default when you first open InfoAssist.

When you select a tab, the tab opens a particular view of the ribbon by exposing groups of controls and commands related to the task that you are performing.
The ribbon contains two types of arrow-based buttons. The first type of button opens a menu when you click it. The Orientation button on the Layout tab, in the Page Setup group, is an example of this type of button. Clicking the Orientation button opens a menu of options, as shown in the following image.

![Orientation Menu](image1)

The second type of button is a split button. Clicking the left side of the split button performs a default action. Clicking the down arrow on the right side of the button opens a menu of options. The Header & Footer button on the Home tab, in the Report group, is an example of a split button. It is shown in the following image.

![Header & Footer Split Button](image2)

Clicking the Header & Footer button on the left opens the Header & Footer dialog box, shown in the following image.

![Header & Footer Dialog](image3)
Clicking the down arrow on the right opens a menu of options shown in the following image.

Some options open dialog boxes of additional commands and option lists.

The ribbon displays all controls and commands using different sized icons and groups, depending on the size of the monitor and application window. In the following example, the Features group is fully expanded and all its icons are visible.

When you reduce the size of the application window, some groups are collapsed into single icons as determined by the amount of available space. The following image shows the Features group, from the Format tab, collapsed into a single icon.

When a group is collapsed into a single icon, the individual icons are removed from view, but are still available. Clicking a collapsed group icon restores the group to its normal full size and displays all of the individual icons.

When expanding a collapsed group, the ribbon collapses a neighboring group to make enough room to expand the selected group.

When an icon, button, or option in a menu or dialog box appears dimmed, that functionality is not available for that report as it currently exists. Some functionality is available for reports only, charts only, or documents only.

In some situations, selecting one or more options makes other options incompatible with the previously selected ones. As a result, the incompatible options are dimmed and unavailable for selection. InfoAssist automatically makes incompatible options unavailable as you create and modify a report.
The following image shows an example of an option that is unavailable because it is not compatible with the selected output type. In the example, PDF has been selected on the Format tab, in the Feature group, as the output type for the report. You cannot create an Accordion report with a PDF output, therefore, the Accordion button appears dimmed and is unavailable.

![Image of InfoAssist Interface](image)

**Note:** If you do not have access to a particular option, contact your administrator.

**Home Tab**

**In this section:**
- Format Group
- Design Group
- Filter Group
- Report Group
- Report Style Dialog Box
- Color Dialog Box

The Home tab contains the most commonly used commands and options from the Format, Design, Filter, and Report groups. It is shown in the following image.

![Image of Home Tab](image)

**Format Group**

The Format group displays a menu of output formats and buttons to toggle between creating a report (default) or a chart. It also contains a menu from which you can create an image file from a chart.

- **Current Output Format.** Displays a drop-down menu of all supported output formats.
  - HTML (the default for charts and reports)
  - HTML5 (only available for charts)
- active report (default for dashboards)
- active Flash
- PDF (the default for documents)
- active PDF
- Excel 2007 (reports designed in Live Preview and Query Design views only)
- Excel
- Excel Formula (reports designed in Live Preview and Query Design views only)
- Excel Pivot (reports designed in Live Preview and Query Design views only)
- PowerPoint

When you run a report, the output is created in the format that is currently selected. You can also select output format options on the Format tab, in the Output Types group, and on the status bar, from the output format drop-down menu.

**Note:** If you are running InfoAssist Basic, your output format options are limited. PowerPoint and active PDF are not supported for charts and reports. PDF, Excel, active report, and active Flash are not supported for charts.

- **Report** or **Chart.** Determines whether report-specific or chart-specific functionality is available in the InfoAssist tool. The default name ReportX or ChartY is given for each new report or chart created in a given InfoAssist session. X and Y are numbers that start at 1 and increase by 1 for each report or chart created. For more information on switching between multiple reports, see [View Tab](#) on page 78.

When Chart is selected, as shown in the following image, you are able to access the File menu in the Format group. However, if you select Report, the File menu is unavailable.

![File Menu](image)

- **File.** Creates an image file from a chart. In order to create the image file, you need to execute the procedure. When the File menu is selected, or if you click [Select a location and format](#) from the drop-down menu, you are able to name the file and select the output type. The available output types are PNG, GIF, SVG, and JPEG. Once the File menu is selected, output type selection is unavailable. If you do want to disable the File menu, click the File menu again.
Design Group

The Design group contains commands to select the design mode for creating reports, and design preview options for accessing data. The Design group is shown in the following image.

The design preview options are:

- **Query (Design view).** Displays the Query Design pane in the Results panel. The Query Design pane provides a large work area for creating the report.

- **Live Preview (Design view).** Displays the report in the Results panel as you create the report. You can use the Live Preview to add, remove, and arrange fields, as well as style the report.
  
  **Note:** This is not available in InfoAssist Basic.

- **Document (Design view).** Opens the document on the Layout canvas in the Results panel. You use the Layout canvas to add text, images, lines, reports, and charts to create dashboards and documents. For more information about Document view, see Accessing Document View on page 356.
  
  **Note:** This is not available in InfoAssist Basic.

The design options are:

- **Data from Source.** Uses the selected data source to display a live preview of the output in the Results panel.

- **Use Sample Data.** Displays sample data, which reduces processing time by eliminating the need to access the actual data source.

- **Records.** Limits the number of rows retrieved from the data source when Live Preview is selected. This feature is useful in reducing response time if you are working with a large amount of data. Type the number of rows that you want directly in the Records field, or use the drop-down menu to select one of the preset record limits. The preset choices are All rows, 1, 10, 50, 100, 500, 1000, 2000, 5000, and 10000.
**Note:** In Live Preview, an exclamation point is placed next to fields that are too large to be displayed within the space allotted. The allotted space is determined by the page-level styling. Page-level styling includes page size, orientation, margins, and font size.

There is no way to define a limit for the number of characters that will fit on a page. This limit varies by the selected page and font styling. The bigger the page size and smaller the font, the more characters that can fit.

**Filter Group**

The Filter group contains commands for creating filters. It is shown in the following image.

![Filter Group Image]

The commands are:

- **Filter.** Opens the Filter dialog box for creating filters. Filters enable you to select only the data that you want and to exclude unwanted data.

  In the Filter dialog box, you can create simple filters using the Values, Prompt, and Relational Operators menus. For more information, see [Field Tab on page 85](#). For more information on creating advanced filters, see [Data Tab on page 62](#).

- **Exclude.** Turns off a filter.

- **Include.** Turns on a filter.

**Report Group**

The Report group contains commands to enhance a report including Theme, Style, Banded (reports only), Header & Footer, Column Totals (reports only), and Row Totals (reports only), as shown in the following image.

![Report Group Image]

- **Theme.** Opens a dialog box where you can select a theme to style your report or chart. You can use the default stylesheet by clicking the *Use Default Stylesheet* button.
You can also select a document styling theme or an application theme to style all reports created in InfoAssist. Use the Environment and Styling section of the Options window, which is accessible by clicking Options in the Application main menu.

- **Style.** Opens a Report Style dialog box for applying global styling to the entire report. For more information about the Report Style dialog box, see *Report Style Dialog Box* on page 45. For more information about styling reports, see *Styling Reports* on page 139.

- **Banded.** Opens a Color dialog box for choosing a color that provides an alternating color scheme for the report. The report output displays alternating rows of data, using a white background for one row and a background of the selected color for the next row. This pattern continues throughout the report. For more information about the Color dialog box, see *Color Dialog Box* on page 46. For more information about banded styling, see *How to Style Rows of Data With Alternating Colors in a Report* on page 148.

- **Header & Footer.** Opens the Header & Footer dialog box, from which you can add and style headings and footings.
  - For a report, you can add and style report headings, page headings, page footings, and report footings. In the dialog box, the tab for Report Header is active by default.
  - For a chart, you can add and style page headings and page footings. For a chart, Page Header is active by default.
  - You can drag fields from the Data pane into the Header & Footer dialog box.

The following image shows the Header & Footer dialog box with Report Header active.
Another way to access the Header & Footer dialog box is to click the down arrow next to the Header & Footer button. It opens a drop-down menu from which you can select the heading or footing that you want to work with (Report Header, Page Header, Page Footer, Report Footer). After you make your selection, the Header & Footer dialog box opens, and the heading or footing that you selected is active.

From the Header & Footer dialog box, you can add and style the active heading or footing, or choose a different heading and footing to work with by selecting the applicable tab. You can switch among tabs, but InfoAssist does not save changes made on the tabs until you click Apply or OK. If you click Apply, the Header & Footer dialog box remains open. If you click OK, the dialog box closes.

You can style a selected heading or footing using the options on the styling toolbar. From left to right, you can customize the font type, font size, and font style (bold, italic, or underline). You can justify text (left, center, or right), select the font color and background color, and restore styling settings to their default value from the template.

You can also insert quick text into a heading or footing. Quick text is supplied for you. It includes information that is typically useful in identifying a report or chart. From the preformatted text drop-down menu, you can select:

- Draft
- Page X of Y
- Confidential
- Date (multiple formats)
- Time (multiple formats)
- Created by (followed by a name)

For charts, an icon on the far right of the styling ribbon is enabled. This icon provides two options for controlling the way in which the page heading and page footing are rendered. The default option, Create Header and Footer as Text, renders the heading and footing as text elements that are separate from the chart image. The option, Embed Header and Footer in the Chart, renders the heading and footing text as part of the chart image.

Once you have added a heading or footing to a report or chart, you can double-click it on the canvas in design mode to reopen the Header & Footer dialog box. You can also right-click an existing heading or footing in design mode and click Edit from the menu to open the dialog box.

For more information on adding and styling headings and footings, see How to Add Headings and Footings to a Report on page 145 and Formatting Page Headings and Page Footings on page 342.
Column Totals. (Reports only) Adds a grand total row to the bottom of the report to sum numeric data in each column. For more information, see How to Add Column Totals to a Report on page 163.

Row Totals. (Reports only) Adds a grand total column to the right side of the report to sum numeric data in each row. For more information, see How to Add Row Totals to a Report on page 164.

Report Style Dialog Box

The Report Style dialog box, shown in the following image, provides options to style your report.

![Report Style Dialog Box](image)

The Report dialog box options are:

- **Font.** Use the drop-down menu to change the font.
- **Font size.** Use the drop-down menu to change the numeric value for the font size.
- **Font style.** Click the appropriate button (bold, italic, underline) to style the selected text.
- **Text alignment.** Click the appropriate button (left, center, right) to align the selected text.
- **Font color.** Click the button to open the Color dialog box, where you can select the font color. For more information, see Color Dialog Box on page 46.
- **Background.** Click the button to open the Color dialog box, where you can select the background color for the report.
- **Font color.** Click the button to open the Color dialog box, where you can select the font color.
Currency symbol. Click the button to access the following currency symbols US dollar, British Pound, Japanese Yen, Euro, New Israeli Shekel. **Note:** The New Israeli Shekel currency symbol can be displayed with the following settings only:

- Server codepage = 1255, 65001, 424, or 65002.
- Client codepage = 1255 or 65001.
- Application server encoding = Cp1255 or UTF8.
- Font name = Lucida Sans Unicode or Arial Unicode MS.

**Reset to template style.** Click the button to reset all settings to the default settings from the template. **Note:** Reset only works while the Report Style dialog box is open. Once you click OK, all changes are committed. To undo global styling after it has been committed, you must use the Undo command on the Quick Access Toolbar.

**Color Dialog Box**

The Color dialog box, shown in the following image, provides options for working with color in your report.

The Color dialog box options are:

- **Standard Color Swatches.** Provides a set of 48 predefined colors from which to choose on the left side of the dialog box. Your selection appears in the Selected Color field.
Custom Color Palette. Provides a palette on the right side of the dialog box to define a custom color. Your selection appears in the Selected Color field.

Luminosity bar. Drag the slider to change the luminosity (relative lightness or darkness) of a color. The corresponding numerical value appears in Lum.

Hue. Indicates the hue value of your selected color. You can enter a value, or increase or decrease the hue value by using the up and down arrows, respectively.

Sat. Indicates the saturation value of your selected color. You can enter a value, or increase or decrease the saturation value by using the up and down arrows, respectively.

Lum. Indicates the luminosity (lightness or darkness) of your selected color. You can enter a value, or increase or decrease the luminosity value by using the up and down arrows, respectively.

Red. Represents the numeric value of red (0 to 255).

Green. Represents the numeric value of green (0 to 255).

Blue. Represents the numeric value of blue (0 to 255).

Selected Color. Displays the color that you selected.

Transparent. Makes the color transparent.

Insert Tab

The Insert tab contains options to add reports, charts, existing reports, text, images, and active form controls (for active report, active PDF, and active Flash outputs only) to a canvas in Document view. It is shown in the following image.
The Insert tab is only available in Document view. It is not available in Query Design view or in Live Preview, as shown in the following image.

![Insert Tab](image)

**Reports Group**

The Reports Group contains commands to insert reports, charts, and existing reports into your document. You can add multiple reports and charts to a single canvas with these buttons. The Reports group is shown in the following image.

![Reports Group](image)

- **Report.** Inserts a report placeholder on the canvas.
- **Chart.** Inserts a chart placeholder on the canvas.
- **Existing Report.** Opens an Open dialog box where you can browse to the report that you want to insert in the upper-left corner of the canvas.

**Objects Group**

The Objects group contains commands to insert text and images into your document. The Objects group is shown in the following image.

![Objects Group](image)

- **Text.** Inserts an inline text object in the upper-left corner of the canvas.
- **Image.** Opens an Open dialog box where you can browse to the image that you want to insert in the upper-left corner of the canvas.
Active Technologies Dashboard Prompts Group

The active dashboard prompts group contains commands to insert active form controls into your document. You can add multiple controls to a single canvas with these buttons. This group is only visible when the output format of the document is set to active report, active PDF, or active Flash. The active dashboard prompts group is shown in the following image.

- **Drop Down.** Inserts a drop-down control placeholder in the upper-left corner of the canvas.
- **List.** Inserts a list control placeholder in the upper-left corner of the canvas.
- **Checkbox.** Inserts a check box control placeholder in the upper-left corner of the canvas.
- **Radio Button.** Inserts a radio button control placeholder in the upper-left corner of the canvas.
- **Text.** Inserts a text area control placeholder in the upper-left corner of the canvas.

For more information on inserting active form controls, see *Creating an Active Technologies Dashboard* on page 408.
In this section:
Output Types Group
Destination Group
Navigation Group (Reports Only)
Features Group (Reports)
Features Group (Charts)
Chart Types Group (Charts)
Labels Group (Charts)

The Format tab contains different options for selecting output formats and other reporting features, depending on whether you are creating a report or a chart. For reports, the Format tab provides access to the Output Types, Destination, Navigation, and Features groups. It is shown in the following image.

For charts, the Format tab provides access to the Output Types, Destination, Chart Types, Features, and Labels groups, as shown in the following image.
Output Types Group

In this section:

HTML5
Enabling Additional Output Types

The Output Types group contains commands to create output in any of the supported formats listed in the following table. When you run a report, the output is created in the format that is currently selected. You can also set output format options by going to the Home tab, and in the Format group, selecting from the menu of output options. In addition, you can select an output from the output format button in the status bar. For more information on the additional Excel formats available for reports, see Report Outputs on page 138.

<table>
<thead>
<tr>
<th>Format</th>
<th>Reports</th>
<th>Charts</th>
<th>Dashboards and Documents</th>
</tr>
</thead>
<tbody>
<tr>
<td>HTML</td>
<td>Available</td>
<td>Available</td>
<td>Available</td>
</tr>
<tr>
<td>HTML5</td>
<td>Not Available</td>
<td>Available</td>
<td>Not Available</td>
</tr>
<tr>
<td>active Report</td>
<td>Available</td>
<td>Available</td>
<td>Available (dashboard default)</td>
</tr>
<tr>
<td>active Flash</td>
<td>Available</td>
<td>Available</td>
<td>Available</td>
</tr>
<tr>
<td>PDF</td>
<td>Available</td>
<td>Available</td>
<td>Available (document default)</td>
</tr>
<tr>
<td>active PDF (requires Adobe® Reader® 9.0 or later)</td>
<td>Available</td>
<td>Available</td>
<td>Available</td>
</tr>
<tr>
<td>Excel formats</td>
<td>Not Available</td>
<td>Available</td>
<td>Available</td>
</tr>
<tr>
<td>PowerPoint</td>
<td>Available</td>
<td>Available</td>
<td>Available</td>
</tr>
<tr>
<td>PDF/GIF (must be set to display in InfoAssist Properties)</td>
<td>Not Available</td>
<td>Available</td>
<td>Not Available</td>
</tr>
</tbody>
</table>
### Format Tab

<table>
<thead>
<tr>
<th>Format</th>
<th>Reports</th>
<th>Charts</th>
<th>Dashboards and Documents</th>
</tr>
</thead>
<tbody>
<tr>
<td>PNG (must be set to display in InfoAssist Properties)</td>
<td>Not Available</td>
<td>Available</td>
<td>Not Available</td>
</tr>
<tr>
<td>GIF (must be set to display in InfoAssist Properties)</td>
<td>Not Available</td>
<td>Available</td>
<td>Not Available</td>
</tr>
<tr>
<td>JPEG (must be set to display in InfoAssist Properties)</td>
<td>Not Available</td>
<td>Available</td>
<td>Not Available</td>
</tr>
<tr>
<td>SVG (must be set to display in InfoAssist Properties)</td>
<td>Not Available</td>
<td>Available</td>
<td>Not Available</td>
</tr>
</tbody>
</table>

The following image shows the Output Types group for reports.

![Output Types for Reports](image)

The following image shows the Output Types group for charts.

![Output Types for Charts](image)
The following image shows the Output Types group for documents.

![Output Types](image)

**HTML5**

The HTML5 output format allows you to render a chart in the browser using a built-in JavaScript engine. Charts with this output format utilize the very latest capabilities of the HTML5 web standard, including animation, high-quality vector output and attractive alpha-channel and gradient effects.

**Enabling Additional Output Types**

The output types of PNG, GIF, JPEG and SVG do not appear in the Output Types group by default. You can enable them by opening the WebFOCUS Administration Console, selecting Utilities, and then InfoAssist Properties.

If these formats are not enabled and you try to open an existing procedure with PNG, then HTML becomes the output. In addition, the following warning messages could open:

- When opening an existing procedure with JPEG, GIF, or SVG, a warning message opens indicating that the request is not allowed with the current configuration and that the procedure will be converted to HTML output.

- When opening an existing procedure with PDF or GIF, a warning message opens stating that the request is not allowed with the current configuration and that the procedure will be converted to PDF output.

When you run a report, the output is created in the format that is currently selected. You can also set output format options from the output format button in the status bar.
The following image shows the Output Types group with all output formats for charts enabled.

![Output Types group](image)

**Destination Group**

The Destination group contains commands to create a report or a chart, change a chart to an image file, and create an InfoMini application, as shown in the following image.

![Destination group](image)

When a chart is selected, the File button becomes available. Clicking the File button or selecting *Select a location and format* from the File drop-down menu, opens the Request dialog box shown in the following image.

![Request dialog box](image)
In the Request dialog box, you are able to name the file and select the output type. The available output types are PNG, GIF, SVG, and JPEG. In order to create the image file, you need to execute the procedure.

Once the File button is clicked, Chart, Report, and InfoMini are disabled, as shown in the following image. If you want to disable the File button, click the File button again.

![Image of button options]

**Note:** The File button is not available in InfoAssist Basic.

- **InfoMini.** Enables the creation of an InfoMini application. For more information on using InfoMini, see *Building InfoMini Applications* on page 455.
  
  **Note:** InfoMini is not available in InfoAssist Basic.

- **Report.** Makes report-specific functionality available in InfoAssist. If you switch from Report to Chart all selected options specific to each type of report are maintained during the current session until you save the report. When you save a report, chart-specific options are not maintained.
  
  **Note:** The Report to Chart, or Chart to Report conversion options are not available in InfoAssist Basic.

- **Chart.** Makes chart-specific functionality available in InfoAssist. If you switch from Chart to Report all selected options specific to each type of chart are maintained during the current session until you save the chart. When you save a chart, report-specific options are not maintained.
  
  **Note:** The Report to Chart or Chart to Report conversion options are not available in InfoAssist Basic.

**Navigation Group (Reports Only)**

The Navigation group contains commands to customize output display and navigation. They are Table, Table of Contents, Freeze, Pages On Demand, and Auto Drill & Analysis.
**Note:** You can only choose one option from this group. The Navigation group is shown in the following image.

![Navigation Group](image)

Table is selected by default and generates standard WebFOCUS browser output.

- **Table of Contents.** Generates output by displaying a table of contents icon in the upper-left corner where report output typically appears. Clicking Table of Contents opens a menu that enables you to select (view) individual values of the first Sort By (By) field, one value at a time. You can also select options to view the entire report or remove the table of contents. For more information, see *How to Create Table of Contents Reports* on page 173. The Table of Contents option is activated only when HTML, active report, Excel, or PowerPoint output format is selected.

  **Note:** You cannot use the Table of Contents with the Accordion feature. For more information, see *How to Create Accordion Reports* on page 177.

- **Freeze.** Generates output with column titles that freeze (remain in view) when you scroll through pages of the report output. For more information, see *How to Freeze Column Titles in a Report* on page 175.

- **Pages On Demand.** Displays one page of output at a time. This option provides a menu bar at the bottom of the report output where you can choose to view additional pages of output. For more information, see *How to Create Pages On Demand Reports* on page 176. The Pages On Demand option is available only when HTML or active report output format is selected.

- **Auto Drill & Analysis.** Generates output which invokes OLAP processing. For more information, see *How to Create OLAP Reports* on page 171. The OLAP option is activated only when HTML output format is selected.
Features Group (Reports)

The Features group for reports contains commands to select specialized reporting features, including Title Popup, Accordion, Repeat Sort Value, Stack Measures, active report Options, and Accessibility. The Features group is shown in the following image.

![Features Group Image]

- **Title Popup.** Displays pop-up titles when the mouse pointer hovers over a column title in the report output. For more information, see *How to Add Pop-Up Titles to a Report* on page 165.

- **Accordion.** Creates expandable views of data for each vertical sort field. This option displays data values only for the first vertical sort field when you first view the output. You can manually expand your view to expose the data values of lower-level sort fields. For more information, see *How to Create Accordion Reports* on page 177.

  **Note:** You cannot use the Table of Contents with the Accordion feature. For more information, see *Navigation Group (Reports Only)* on page 55.

- **Repeat Sort Value.** Displays all repeated sort values instead of blanks in the output after the first instance of a new sort value, which is the default behavior.

- **Stack Measures.** Displays all numeric measure field names in a column of the report output with the corresponding numeric data values. For more information, see *How to Implement Stack Measures* on page 178.

- **active report options.** Opens the active report options dialog box where you can configure your active report options such as menu items, graph engine, and colors. For more information, see *Creating an Active Technologies Report* on page 392.

- **Accessibility.** Allows a title to be added to a report, chart, or document that is Section 508-compliant.

The following table lists the output for which each feature is available. Yes means the output is available for the feature. No means that the output is not available for the feature.

<table>
<thead>
<tr>
<th>Feature</th>
<th>HTML</th>
<th>HTML5</th>
<th>active report</th>
<th>active Flash</th>
<th>PDF</th>
<th>active PDF</th>
<th>Excel</th>
<th>PowerPoint</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title Popup</td>
<td>yes</td>
<td>no</td>
<td>no</td>
<td>no</td>
<td>no</td>
<td>no</td>
<td>no</td>
<td>no</td>
</tr>
</tbody>
</table>

WebFOCUS InfoAssist User's Manual 57
Features Group (Charts)

The Features group for charts contains commands to select custom chart features, including 3D Effect, Rotate, Reference, Annotate, Grid, Frame & Background, Gauges, active Report Options, and Accessibility. It is shown in the following image.

- **3D Effect.** (Default.) Sets the three-dimensional view to on or off. The 3D Effect feature is disabled for 3D, stock, gauge, gauge thermometer, Pareto, spectral map, and funnel chart types.

- **Rotate.** Toggles between a vertical display or horizontal display of a chart. For more information, see *How to Rotate a Chart* on page 348. The Rotate feature is disabled for pie, scatter, 3D, stock, gauge, gauge thermometer, Pareto, spectral map, and funnel chart types.

- **Reference.** Opens a drop-down menu that provides the Add Reference Line to Y-axis and Add Reference Line to X-axis options. Selecting one of these options opens the appropriate Reference Line dialog box, where you can set the specific X-axis or Y-axis value, type the text that you want, and position the reference line on a chart. For more information, see *How to Display Reference Lines* on page 349. The Reference feature is disabled for pie, 3D, stock, gauge, gauge thermometer, Pareto, spectral map, and funnel chart types.

**Note:** The reference line option is not available in InfoAssist Basic.
Annotate. Opens a drop-down menu that provides the Add an annotation option. Selecting this option opens the Annotation dialog box, where you can type the text that you want and position the annotation on a chart. For more information, see How to Display Annotations on page 352.

Note: The annotation option is not available in HTML5. The annotation option is not available in InfoAssist Basic.

Grid. Opens a drop-down menu allowing you to expand options for Horizontal or Vertical Gridlines. Both selections allow you to enable or disable Major and Minor Gridlines. Clicking More Options opens the Format Grid Lines dialog box. For more information, see Formatting Gridlines on page 267.

Frame & Background. Opens the Frame & Background dialog box where you can edit the background style and frames for charts. The dialog contains different options depending on the chart type selected. For more information, see Formatting a Frame and a Background on page 298.

Gauges. Opens the Gauge dialog box where you can edit your gauge chart. This button is only available when a gauge chart type is selected. For more information, see How to Style a Gauge Needle on page 339.

Note: Gauge options are not available in InfoAssist Basic.

active report Options. Opens the active report options dialog box where you can configure your active report options, such as menu items, graph engine, and colors. This button is available when the output type is set to active report, active Flash, or active PDF.

Note: Annotate is not available in HTML5.

Accessibility. Allows a title to be added to a report, chart, or document that is Section 508 compliant. This option is only available for reports and charts when the output type is HTML or PDF. For documents, the output type must be set to PDF.

Note: The chart features are unavailable when designing a chart that will be output in active report, active Flash, or active PDF formats.
**Chart Types Group (Charts)**

The Chart Types group contains the most commonly used chart types, Bar (default), Pie, Line, Area, and Scatter. You can also click Other to select additional chart types. The Charts Types group is shown in the following image.

Click Other to open the Other Chart Types dialog box, shown in the following image. Across the top of the dialog box are tabs which are depicted by icons. Each tab represents a chart type category. The left-most tab represents the bar chart category, which is selected by default. When a tab is selected, it displays thumbnail images of the bar chart variations that are supported by InfoAssist.
In this example, the Vertical Percent Bar chart type is selected. A description of the selected chart type is provided beneath the images.

For more information on the chart types that you can choose from, see Selecting a Chart on page 183.

**Labels Group (Charts)**

The Labels group for charts contains the Axes and Legend buttons drop-down menus. It is shown in the following image.
Axes. Opens a drop-down menu, where you can enable, stagger, and rotate horizontal and vertical axis labels. You can also edit the axis labels by clicking More Horizontal Axis Options or More Vertical Axis Options. For more information, see Formatting Axis Labels on page 284.

Note: The Axes option to change data labels position is not available in InfoAssist Basic.

Legend. Opens a drop-down menu, where you can select the Show Legend option to display the legend on the chart, or clear your selection to hide the legend, change the default legend position, and change the default legend orientation. For more information, see Format Legend Dialog Box on page 256.

Data Tab

The Data tab contains data manipulation and data display options in the Calculation, Join, Filter, Display, and Data Source groups. It is shown in the following image.

Calculation Group

The Calculation group contains the Detail (Define) and Summary (Compute) commands to define Define and Compute fields, respectively. It is shown in the following image.
DEFINE fields and COMPUTE fields are two different types of temporary fields. A temporary field is a field whose value is not stored in the data source, but can be calculated from the data that is there, or assigned an absolute value. A temporary field takes up no storage space in the data source, and is created only when needed.

When you create a temporary field, you determine its value by writing an expression. You can combine fields, constants, and operators in an expression to produce a single value.

You can specify the expression yourself, or you can use one of the many supplied functions that perform specific calculations or manipulations. In addition, you can use expressions and functions as building blocks for more complex expressions, as well as use one temporary field to evaluate another.

A virtual field (DEFINE) is evaluated as each record that meets the selection criteria is retrieved from the data source. The result of the expression is treated as though it were a real field stored in the data source.

A calculated value (COMPUTE) is evaluated after all the data that meets the selection criteria is retrieved, sorted, and summed. Therefore, the calculation is performed using the aggregated values of the fields.

- **Detail (Define).** Opens the Detail Field (DEFINE) dialog box, where you can create a defined field, type a name for the field, and enter a format. A Define field is added to the actual data. The Detail (DEFINE) dialog box is shown in the following image.

- **Summary (Compute).** Opens the Summary Field (COMPUTE) dialog box, where you can create a computed field, type a name for the field, and enter a format.
The Field dialog boxes, which open when you click Detail or Summary, provide similar functionality, including options to display data source fields in a Tree, Dimension, or List view. You can also view a complete set of functions, instead of data source fields, by clicking the Functions button. The Summary (COMPUTE) dialog box is shown in the following image.

![Summary Field (COMPUTE)](image)

**Join Group**

The Join group contains the Join button to open the Join dialog box, where you can create a new join, edit or delete existing joins, and add data sources to a join. The Join group is shown in the following image.

**Note:** The Join group is not available when working with Reporting Objects or SAP® Business Information Warehouse (SAP BW), Oracle Essbase®, or Microsoft® SQL Server® Analysis Services cubes.
The following image shows the Join dialog box with two data sources joined by the common ID_AGE indexed field.

Using conditional joins, you can establish joins based on conditions other than equality between fields. In addition, the host and cross-referenced join fields do not have to contain matching formats, and the cross-referenced field does not have to be indexed.

**Note:** You can edit the description of a Join by clicking *Edit* in the Join dialog box and typing in the Description section. You can only use letters, numbers, and underscores in your description. No special characters are allowed.

The conditional join is supported for FOCUS and all relational data adapters. Because each data source differs in its ability to handle complex conditional criteria, the optimization of the WHERE syntax differs depending on the specific data sources involved in the join and the complexity of the conditional criteria.
For FOCUS data sources, if the host and cross-referenced join fields do not have common matching formats, the following message appears.

Note: If you click Yes, the Advanced Filter dialog box opens, where you can create a Where-Based Join.

If the cross-referenced join field does not have an index, the following message appears.

Note: If you click Yes, the Advanced Filter dialog box opens, where you can create a Where-Based Join.
To create a Where-Based Join, create a filtering condition, as shown in the following image.

**Filter Group**

The Filter group contains the Advanced Filter button to open the Advanced Filter dialog box to set advanced filtering options. Advanced filter options include Where, Where Total, the And conjunction, and the Or conjunctions in a single expression.

When creating a report, you refer to fields in several parts of the request. For example, in display commands (PRINT, SUM), in sort phrases (BY, ACROSS), and in selection criteria (WHERE, WHERE TOTAL, IF).

The WHERE phrase selects records from the data source to be included in a report. The data is evaluated according to the selection criteria before it is retrieved from the data source. You can use as many WHERE phrases as necessary to define your selection criteria.

In WHERE TOTAL tests, however, data is selected after all the data has been retrieved and processed.
You can group conditions and expressions within Simple Filter criteria. In addition, you can apply functions and calculations within criteria. This option provides more functionality than the Filter dialog box. For more information on the simple filter, see Field Tab on page 85. The Filter group is shown in the following image.

In the Advanced Filter dialog box, you can create Where and Where Total filters, as shown in the following image.

You can change between Where and Where Total by double-clicking WHERE.

Double-clicking the Double-click or press F2 to edit! text opens drop-down menus for Fields, Operators, and Values. You can retrieve fields and values from the Master File and data source.

The Field drop-down menu provides a field list from the Master File.

The Equal to (default) drop-down menu provides the following operators:

- Equal to
- Not equal to
- Greater than
Less than
Greater than or equal to
Less than or equal to
In literal list
Not in literal list
Missing
Not missing
From - To
Not From - To
Includes literal list
Excludes literal list
Contains characters
Omits characters
Like character mask
Not like character mask
The Value drop-down menu opens a dialog box with multiple options, as shown in the following image.

![Create a filtering condition dialog box](image)

The type drop-down menu contains the following options:

- **Constant.** Enables the entry of a literal constant value.
- **Parameter.** Enables you to specify a parameter by entering a name and description in the provided text input areas, as well as selecting the type of parameter (Simple, Static, Dynamic).
- **Field.** Enables the specification of a field name to compare against.

The value area contains a text input box that you can use to manually insert values. It also contains a Get Values drop-down menu, which supplies the following options:

- **All.** Retrieves all the values from the selected field.
- **First.** Retrieves the first value from the selected field.
- **Last.** Retrieves the last value from the selected field.
- **Minimum.** Retrieves the minimum value from the selected field.
- **Maximum.** Retrieves the maximum value from the selected field.
From File. Retrieves a value that you specify. Selecting this option opens a browse dialog box.

**Note:** The Get Values drop-down menu is only accessible if you have already selected a field.

After selecting the values that you want, you can move them into and out of the Multiple Values area with the left and right arrows. You can also change the value order and delete values with the up and down arrows and the Delete icon.

After creating a condition, you can insert additional conditions before and after the selected condition by using the Insert Before and Insert After buttons at the top of the Advanced Filter dialog box. You can use either the And or the Or conjunction to link conditions and the Group and Ungroup buttons to nest and organize conditions.

You can create additional filters by clicking the New Filter button at the top of the Advanced Filter dialog box.

After creating the filters that you want, click OK to save and apply the filters. You can access them from the Filter pane of the Resources panel.
Display Group

The Display group contains the Missing Data menu, which contains options to control the display of missing data values in a chart. The Missing Data menu is shown in the following image.

- **Missing Data.** Displays the following options Gap, Zero, Interpolated Line.
  - **Gap.** Displays missing values as a gap in bar, line, and area charts.
  - **Zero.** Displays a bar on the zero line in a bar chart. Displays a solid line that connects the missing value with the succeeding value in a line chart. Displays an area on the zero line in an area chart.
  - **Interpolated Line.** Displays missing values as an interpolated dotted line that connects the plot points preceding and succeeding the missing value in a line chart. Displays missing values as an interpolated bar in a bar chart. Displays missing values as an area in an area chart.

Data Source Group

The Data Source group contains the Add command and the Switch drop-down menu to add and switch data sources. The Data Source group is only available in Document mode. The Data Source group is shown in the following image.

**Note:** The Data Source group is not available when working with Reporting Objects.
- **Add.** Opens the Select a data source dialog box, where you can add additional data sources to a document, enabling you to insert reports from different data sources into the same document. The Select a data source dialog box is shown in the following image.

- **Switch.** Opens a drop-down list of all the data sources that have been added. You can choose which data source is currently active and being used to create new reports.
  
  You can also switch data sources by selecting a report that is using a data source different from the one that is currently active.
Slicers Tab

The Slicers tab provides the ability to create and edit slicers. Slicers are dynamic filters that you can use with reports, charts, dashboards, and documents. For more information on Slicers, see Using Slicers on page 437. The Slicers tab is shown in the following image.

Note: The slicer capabilities are only available in the full version of InfoAssist. They are not available in InfoAssist Basic.

Options Group

The Options group contains the New Group, Clear Slicers, and Update Preview commands.

- **New Group.** Creates a new group of similar slicers.
- **Clear Slicers.** Resets all slicers so that no filtering is done.
- **Update Preview.** Applies slicers to preview.

Record Limit Group

The Record Limit group contains the Preview and Run Time drop-down menus.

- **Preview.** Sets the number of records retrieved from the data source for preview. The options are:
  - All
  - 1
  - 10
Run Time. Sets the number of records retrieved at run time. The options are:

- All
- 50
- 100
- 500
- 1000
- 2000
- 5000
- 10000
- 50000

Group Number Group

The Group Number group contains a group for each Slicer group that is added. Group 1 is the default slicer group to which you can drag fields to create slicers.
Layout Tab

In this section:
Page Setup Group
Size & Arrange Group
Report Group

The Layout tab provides access to page display and layout options from the Page Setup, Size & Arrange, and Report groups. It is shown in the following image.

Page Setup Group

The Page Setup group contains the Margins, Orientation, Size, Units, and Page Numbers (reports only) commands to customize the page setup for the output of your report.

- **Margins.** Enables you to set margin values by choosing Normal (1 inch all around), Narrow (.5 inch all around), Moderate (.5 inch left or right), Wide (1.5 inch left or right), or Custom. Choosing Custom opens the Margins dialog box, as shown in the following image, where you can set specific margins as needed.

- **Orientation.** Enables you to set the orientation of your report to portrait or landscape.

- **Size.** Enables you to select the size of the paper for printing output. You can choose A3, A4, A5, Letter, Tabloid, Legal, PowerPoint, or Large Size.
- **Units**. Enables you to select the unit of measurement used for customizing the dimensions of your report or chart. You can choose Inches, Centimeters, or Points.

- **Page Numbers**. (Reports only). Enables you to select page numbering options. You can choose one of the following:
  - No Lead (no space for headers)
  - On (page numbers only in headers)
  - Off (space for headers, but no page numbering)

  The Page Numbers value is overridden by header and footer text options.

### Size & Arrange Group

The Size & Arrange group contains commands to size charts and document components. The Size & Arrange group contains the Height and Width, Auto Overflow, Aspect Ratio, Autofit, Align, and Relative Position commands. The Size & Arrange group is available when working with charts and documents.

For more information on using the options available in the Size & Arrange group to lay out components in a document, see *Editing Components in a Document* on page 374.

### Report Group

The Report group contains commands to customize report spacing settings. Cell Padding and Autofit Column are for reports only.

- **Cell Padding**. Opens the Cell Padding dialog box, where you can set specific values to control the amount of space inserted between rows and columns in a report. For more information, see *How to Use Cell Padding in a Report* on page 152.

- **Autofit Column**. Limits the width of columns in a report to be no wider than the largest value in each column. Autofit Column is selected by default.
View Tab

The View tab provides access to report design viewing options in the Design, Show/Hide, Data Panel, Query Panel, Output Window, and Report groups. It is shown in the following image.

Design Group

For more information, please see Design Group on page 41.

Show/Hide Group

The Show/Hide group contains the Resources, Ruler, and Grid commands for choosing different viewing options while working with reports and output. It is shown in the following image.

The default view in InfoAssist shows both the Resources panel and the Results panel at the same time.
Resources. Minimizes the Resources panel and expands the size of the Results panel
to also occupy the area where the Resources panel typically appears. The Results panel
can display a preview of a report, output of a report, or the Query Design pane.

Ruler. Displays a ruler above the canvas and to the left of the canvas for a document.

Grid. Displays a grid as a visual aid for aligning objects in a document.

Relationships. (Document only) Shows the relative positioning relationship among
objects.

Data Panel Group

The Data Panel group contains commands to display data source fields in the Data pane
(Resources panel), using different views that are labeled Logical (default), List, and Structured.
All three views provide options for displaying each data source field as a Title, Description,
Field, or Alias. The List view also includes options to show the Alias, Format, and Reference
of each field. The Data Panel group is shown in the following image.

The following is an example of the default Logical view, displaying the Title of each field.
The following is an example of the List view, displaying the (data source) Field Name of each field.

<table>
<thead>
<tr>
<th>Name</th>
<th>Title</th>
<th>Alias</th>
<th>Format</th>
<th>Segment</th>
<th>Filename</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>REGION</td>
<td>Region</td>
<td>REGION</td>
<td>A15V</td>
<td>DIM_GEOG...</td>
<td>WF_RETAIL</td>
<td>Customer Region</td>
</tr>
<tr>
<td>STATECODE</td>
<td>State,...</td>
<td>STAT...</td>
<td>A2</td>
<td>DIM_GEOG...</td>
<td>WF_RETAIL</td>
<td>Customer State (Code)</td>
</tr>
<tr>
<td>CITY</td>
<td>City</td>
<td>CITY</td>
<td>A50V</td>
<td>DIM_GEOG...</td>
<td>WF_RETAIL</td>
<td>Customer City</td>
</tr>
<tr>
<td>PRODUCTCATEGORY</td>
<td>Product,...</td>
<td>PROD...</td>
<td>A40V</td>
<td>DIM_PROD...</td>
<td>WF_RETAIL</td>
<td>Product,Category</td>
</tr>
<tr>
<td>PRODUCTSUBCAT</td>
<td>Product,...</td>
<td>PROD...</td>
<td>A50V</td>
<td>DIM_PROD...</td>
<td>WF_RETAIL</td>
<td>Product,Subcategory</td>
</tr>
<tr>
<td>MODEL</td>
<td>Model</td>
<td>MODEL</td>
<td>A50V</td>
<td>DIM_PROD...</td>
<td>WF_RETAIL</td>
<td>Model</td>
</tr>
<tr>
<td>TIMEYEAR</td>
<td>Year,</td>
<td>TIME...</td>
<td>I6</td>
<td>DIM_TIME...</td>
<td>WF_RETAIL</td>
<td>Year,(Sales)</td>
</tr>
<tr>
<td>TIMEQTR</td>
<td>Quart...</td>
<td>TIME...</td>
<td>I6</td>
<td>DIM_TIME...</td>
<td>WF_RETAIL</td>
<td>Quarter,(Sales)</td>
</tr>
<tr>
<td>TIMEMTH</td>
<td>Month...</td>
<td>TIME...</td>
<td>I6</td>
<td>DIM_TIME...</td>
<td>WF_RETAIL</td>
<td>Month,(Sales)</td>
</tr>
</tbody>
</table>

The following is an example of the Structured view, displaying the Description of each field.
Query Panel Group

The Query Panel group contains commands to provide three different views of the Query Design pane, Areas 2x2, Areas 1x4, and Tree (default). It is shown in the following image.

You can display the filter and data source field containers in the Query Design pane in one of following three ways:

- **Areas 2x2.** Displays data in two-column by two-row grid.
- **Areas 1x4.** Displays data in one-column by four-row grid.
- **Tree.** (Default.) Displays data in a tree, not a grid.

The following image shows the Query Design pane when Areas 2x2 is selected for a report.
The following image shows the Query Design pane when Areas 1x4 is selected for a report.
The following image shows the Query Design pane when Tree is selected for a report.

Output Window Group

The Output Window group contains the Arrange, Output Location, and Switch Output drop-down menus for setting output display. It is shown in the following image.

- **Arrange.** Opens a drop-down menu for choosing to display multiple output windows as a Cascade, Tile Horizontally, or Tile Vertically.
For example, the following image shows how you can display three output windows when you click *Tile Vertically*.

- **Output Location.** Opens a drop-down menu for choosing to direct new output to a Single Tab (default), New Tab, Single Window, or New Window. For details, see *Understanding Output Options* on page 121.

- **Switch Output.** Opens a drop-down menu for choosing to view any active output window.

**Report Group (Reports)**

The Report Group for reports contains the Switch Report drop-down menu which lists reports that you can switch to. It is shown in the following image.

- **Switch Report.** Opens a drop-down menu for choosing any active report or chart. You can have multiple reports, charts, dashboards, and documents open in the application window, as shown in the following image.
Note: You can also switch reports from the status bar. For more information, see Using the Status Bar on page 133.

Field Tab

In this section:
Filter Group
Sort Group
Break Group (Reports)
Style Group
Format Group
Display Group
Links Group

The Field tab appears in the ribbon when you select a data source field in the Query Design pane or Layout canvas. The options available in the Field tab are specific to the data type that is selected. The options available for numeric fields are different from the options available for non-numeric and date fields. The Field tab provides access to the Filter, Sort, Break, Style, Format, Display, and Links groups. It is shown in the following image.

The Field tab provides the following groups and options.
Filter Group

The Filter group contains filtering options, including Filter, Exclude, Include, and Prompt. The Filter group is shown in the following image.

- **Filter.** Opens the Filter dialog box for creating or modifying WHERE statements.
  
  The Values drop-down menu contains the following options:
  
  - Fetch All Values from Source
  - Fetch Values from Disk File
  - Fetch First Value in Source
  - Fetch Last Value in Source
  - Fetch Minimum
  - Fetch Maximum
  
  The Prompt drop-down menu contains the following options:
  
  - No Value Prompt (default)
  - Prompt using Data Values (Dynamic)
  - Prompt using Selection (Static)
  - Prompt using Text Input (Simple)
Selecting any Prompt option changes the purpose of the dialog box to creating an auto prompting parameter that you can select when you run a report. When you select the Prompt using Data Values (Dynamic) option or the Prompt using Text Input (Simple) option, the Values drop-down menu is unavailable. The Filter dialog box is shown in the following image.

![Filter dialog box](image)

When you select an existing filter in the Filter area of the Query Design pane, choosing Exclude removes, but does not delete, the filter from the report. When you select a filter that was previously excluded from a report in the Filter area of the Query Design pane, choosing Include restores the filter to the report.

- **Prompt.** Opens the Filter dialog box for creating an auto prompting parameter that you can select when you run a report. The Filter dialog box is used to create both filters and auto prompting parameters. The following options are available in the Prompt drop-down menu:
  - Prompt using Data Values (Dynamic). This is the default value.
  - Prompt using Selection (Static)
  - Prompt using Text Input (Simple)
- **Allow Multiple Values for Prompt.** Displays a multi-select menu in the output window when you create a dynamic auto prompting parameter for a field and then run the report. The Filter dialog box, shown in the following image, creates a filter that displays a dynamic auto-prompt, when the report is run for the Product field. The dynamic auto-prompt lists the products that you can select.

![Filter for QUANTITY_SOLD](image)

The following is an example of a dialog box that prompts the user for a parameter value. This dialog box opens when you run a report after creating a dynamic auto prompting parameter for the Product field.

![Report301 Parameters](image)

1. Specify values for all parameters.
2. Select the run button to submit the request.
If you click the *Allow Multiple Values for Prompt* button while creating a dynamic auto prompting parameter, a multi-select menu appears when the report is run. Selecting multiple parameter values displays the output in the same dialog box as the prompt, as shown in the following image.

![Multi-select menu](image)

**Sort Group**

The Sort group contains sort options, including the default **Up** (ascending sort), **Down** (descending sort), **Rank** (reports only), and **Limit** (reports only). It is shown in the following image.

![Sort options](image)

- **Up.** (Default.) Sorts the selected field in ascending order.
- **Down.** Sorts the selected field in descending order.
- **Rank.** Inserts a rank column immediately to the left if a Sort By field is selected. It also adds a rank column to the left of the Sort By field if a Measure is selected. Ranking a Measure results in two copies of the field, the original Measure, and the Sort By field that is created during ranking.
Limit. Opens a drop-down menu that allows you to specify the number of unique values to display for a sort group that has been added.

For more information about these report options, see Using Custom Reporting Features on page 157.

Break Group (Reports)

The Break group for reports contains options for customizing a report by adding a Page Break, Line Break, Subtotal (for numeric fields only), Sub Header, Sub Footer, and Recompute to the report output. The Break group is shown in the following image. The Break Group is used for reports only,

- **Page Break.** Starts a new page when the primary sort field changes. Clicking the drop-down icon enables you to select Reset Page Numbers, which allows you to reset page numbers on a page break to start at 1.

- **Line Break.** Inserts a line in the report output when the primary sort field changes.

- **Sub Header.** Opens a dialog box where you can type text to add a subheading just below the column titles in the report output when the primary sort field changes.

- **Sub Footer.** Opens a dialog box where you can type text to add a subfooting at the end of the data on each page of the report output when the primary sort field changes.

- **Subtotal.** Inserts a line, total text (TOTAL FIELD Value), and subtotals for all numeric fields when the primary sort field changes.

For more information about these report options, see Using Custom Reporting Features on page 157.
Style Group

The Style group contains styling options for reports and charts. For a selected field in a report, you can customize the font type, font size, font color, background color, and restore styling to the default values. You can also style fonts (bold, italic, underline), justify text (left, center, right). You can apply styling to the Data (default), column Title, or both the Data and column Title for the selected field in a report. The Style group is shown in the following image.

For more information about styling reports, see Styling Reports on page 139.

Format Group

The Format group contains formatting options for virtual or column fields including Alphanumeric, Integer, Decimal, Currency, Percentage, Comma, and Decimal Places. The Format group is shown in the following image.

The drop-down menu provides three field-type options for the selected column, which are Alphanumeric, Integer, and Decimal. Selecting the fourth option, More options, opens the Field Format Options dialog box, which provides further formatting options for the selected field. For more information, see Changing a Field Format on page 154.

You can also apply floating and non-floating currency, percent signs, and commas. You can increase and decrease decimal places by clicking the appropriate buttons under the drop-down menu.

The Currency button is a split button that turns the currency symbol on or off. Click the Currency button to turn on the default floating currency option. Click the Currency button a second time to turn off the floating currency option.

To turn on the non-floating currency option, open the drop-down menu and select Non floating currency. To turn off the non-floating currency option, click the Currency button.
Display Group

The Display group contains additional options for a selected field, including Hide Field, Hide Missing, Aggregation, Traffic Lights, and Data Bars (reports only). It is shown in the following image.

- **Hide Field.** Allows you to hide a selected field.
- **Hide Missing.** Allows you to hide fields that have no value.
- **Aggregation.** Opens a drop-down menu of the following options:
  - None (default)
  - Sum
  - Average
  - Count
  - Count Distinct
  - Percent of Count
  - First Value
  - Last Value
  - Maximum
  - Minimum
  - Total
  - Percent
  - Row Percent
  - Average Square
Sum is the default aggregation type value for all numeric fields added to the Measure field container in the Query Design pane. Changing the Measure field container from Sum to Print, Count, or List overrides all assigned aggregation type values. For more information related to reports, see How to Display Measure Data Using Aggregation Options in a Report on page 166. For more information related to charts, see How to Display Aggregations on Measures on page 233.

- **Traffic Lights.** Opens the Traffic Light Condition dialog box. From this dialog box you can do the following:
  - add new conditional styling by applying traffic light (and other) colors to a selected field in the output when the field meets specified criteria
  - modify existing conditional styling
  - enable conditional drill-down

  For more information related to reports, see Styling Reports on page 139. For more information related to charts, see Traffic Light Condition Dialog Box on page 211.

- **Data Bars.** (Reports only.) Adds a data visualization column to the right of a selected numeric field. The column displays values in each row using horizontal bars that extend from left to right in varying lengths, depending on the corresponding data values. For more information, see How to Add Data Visualization Bars to a Report on page 165.

**Links Group**

The Links group contains the Hyperlink command to add a hyperlink or drill-down procedure to a selected field in a report. The Links group is shown in the following image.
**Hyperlink.** Opens the Drill Down dialog box opens. From that dialog box, you can configure a hyperlink or a drill-down procedure for the selected field. Clicking that field in report output takes you to the specified URL or executes the specified procedure. The Drill Down dialog box is shown in the following image.
Series Tab

The Series tab appears in the ribbon only when you are working with charts. It provides access to chart options through the Select, Properties, Line, Pie, and Display groups. The Series tab is shown in the following image.

Select Group

The Select group contains a drop-down menu for selecting a specific measure field to which to apply one or more of the options that are available in the Series tab. The default setting is All Series, which applies the selected options to all the measure fields in the report.

Properties Group

The Properties group contains options for enhancing charts. The options are Style, Data Labels, Type, Trendline, and Equation options. It is shown in the following image.

- **Style.** Opens the Format Series dialog box, where you can edit the styling options for the selected series. You can also open this dialog box by right-clicking a series, and then clicking *More Style Options.* For more information, see *Formatting a Series* on page 208.

- **Data Labels.** Adds data labels to the chart. The drop-down menu contains the following data position options for selecting where to display data values as labels on a chart:
Series Tab

- Above (default)
- On top edge
- Below top edge
- Center
- Base

Clicking More Data Label Options opens the Format Labels dialog box where you can further edit your data labels. For more information, see Formatting Data Labels on page 242.

- **Type.** Opens a drop-down menu with the following options for selecting different chart types:
  - None (default)
  - Bar
  - Line
  - Area

- **Trendline.** Opens a drop-down menu that provides the following options for adding a trendline to a chart:
  - None (default)
  - Linear
  - Quadratic
  - Polynomial
  - Hyperbolic
  - Logarithmic
  - Modified Hyperbolic
  - Rational
  - Exponential
  - Modified Exponential
  - Log Quadratic
  - Geometric

**Note:**
The trendline option is not available in HTML5.

The trendline option is not available in InfoAssist Basic.

For more information, see *How to Add a Trendline* on page 219.

**Equation.** Displays the associated mathematical equation for the selected trendline on the chart.

**Note:**

- The equation is not available in HTML5.
- The equation option is not available in InfoAssist Basic.

**Line Group**

The Line group contains options for formatting chart lines and line markers. The options are Smooth Line, Connect Lines, and Marker. It is shown in the following image.

![Line Group Options](image)

- **Smooth Line.** Draws the chart using smooth lines. For more information, see *How to Apply Smooth Line Effect to a Line Chart* on page 220.

  **Note:** The smooth line option is not available in InfoAssist Basic.

- **Connect Lines.** Controls the display of connecting lines between markers on a line or scatter chart. By default, lines are connected on a line chart and disconnected on a scatter chart.

- **Marker.** Opens a drop-down menu from which you can select options to change the display of the default data and legend markers on line and scatter chart types. The drop-down menu contains the following options:
  - None
  - Square
  - Circle
  - Diamond
  - Plus
  - Triangle Down
Triangle Up
Triangle Right
Triangle Left
Pirate Plus
House
Hexagon
Fat X
Five Star
Six Star
Hourglass
Sideways Hourglass
Horizontal Line
Vertical Line
Area

For more information, see How to Change the Appearance of a Marker on page 222.

**Note:** The marker option is not available in InfoAssist Basic.

### Pie Group

The Pie group contains options to expand or hide pie slices. It is shown in the following image.

![Pie Group Image]

The Pie group is activated only when you click Pie on the Format tab, in the Chart Types group.

**Note:** The pie options are not available in InfoAssist Basic.
Display Group

The Display group contains the Reverse Order command to reverse the order of a series when All Series is selected in the Select group. It is shown in the following image.

The Reverse Order option is available for all chart types.

Understanding the Resources Panel

In this section:

- Using the Data Pane to Add Fields to a Report
- Using the Query Design Pane in the Resources Panel
- Using Right-Click Field Options in the Query Design Pane

Reference:

- Field Image List
- Filter Area of the Query Design Pane

The Resources panel displays the Data pane in the upper half of the panel and the Query Design pane in the lower half of the panel by default. When you select Query Design view, the Resources panel displays the Data pane only. You select Query Design view on the Home tab, in the Design group, clicking Query or on the View tab, in the Design group, clicking Query.
The following image shows the default view of the Resources panel, which displays the Data pane above the Query Design pane when you create a report.
The Data pane, which contains all the fields from the selected data sources, is always displayed.

You can manually adjust the size of the Resources panel and Results panel by clicking and dragging the border between the two panels in either direction. Move the mouse pointer over the border. When the pointer changes to a two-way arrow, click and drag the border.

**Reference: Field Image List**

In the Resources panel, each field has an image associated with it. The following table displays each image and describes what it represents.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Type</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Database" /></td>
<td>Database</td>
</tr>
<tr>
<td><img src="image" alt="Dimension Segment" /></td>
<td>Dimension Segment</td>
</tr>
<tr>
<td><img src="image" alt="Measure Segment" /></td>
<td>Measure Segment</td>
</tr>
<tr>
<td><img src="image" alt="Locked Segment" /></td>
<td>Locked Segment</td>
</tr>
<tr>
<td><img src="image" alt="Unique Segment" /></td>
<td>Unique Segment</td>
</tr>
<tr>
<td><img src="image" alt="Key Field" /></td>
<td>Key Field</td>
</tr>
<tr>
<td><img src="image" alt="Index Field" /></td>
<td>Index Field</td>
</tr>
<tr>
<td><img src="image" alt="Blob" /></td>
<td>Blob</td>
</tr>
<tr>
<td><img src="image" alt="Text or Alpha Field" /></td>
<td>Text or Alpha Field</td>
</tr>
<tr>
<td><img src="image" alt="Date or Date and Time Field" /></td>
<td>Date or Date and Time Field</td>
</tr>
<tr>
<td><img src="image" alt="Numeric Field" /></td>
<td>Numeric Field</td>
</tr>
<tr>
<td><img src="image" alt="Calculated Date Field" /></td>
<td>Calculated Date Field</td>
</tr>
<tr>
<td><img src="image" alt="Calculated Numeric Field" /></td>
<td>Calculated Numeric Field</td>
</tr>
</tbody>
</table>
## Understanding the Resources Panel

<table>
<thead>
<tr>
<th>Icon</th>
<th>Type</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Icon 1" /></td>
<td>Calculated Other Field</td>
</tr>
<tr>
<td><img src="image" alt="Icon 2" /></td>
<td>Calculated Text Field</td>
</tr>
</tbody>
</table>
**Reference:** **Filter Area of the Query Design Pane**

The Filter area of the Query Design pane displays all filters that have been created for the selected report. The Filter area is shown in the following image.

For more information on simple filters, see *Field Tab* on page 85. For more information on advanced filters, see *Data Tab* on page 62.

**Note:** The Filter area displays all created filters, both active (included) and inactive (excluded).
Using the Data Pane to Add Fields to a Report

There are several ways that you can add data source fields to a report. You can drag and drop, double-click, or right-click data source fields in the Data pane to add them to a Query field container or Filter in the Query Design pane.

After you add data source fields to a Query field container, you can change the order of the fields by dragging and dropping one field above or below another field.

**Drag and Drop.** This method provides the most control. You can drag and drop data source fields from the Data pane to the appropriate Query field container or Filter in the Query Design pane.

For a larger work area in which to drop data source fields in the appropriate Query field container, make sure that Query Design view is selected, and then, on the View tab, in the Query Panel group, click Areas 2x2 or Areas 1x4.

You select Query Design view on the Home tab, in the Design group, by clicking Query or on the View tab, in the Design group by clicking Query. That selection expands the Query Design pane so that it is opened in the Results Panel.

**Multi-Select.** You can multi-select data source fields that you want to add to a report in Live Preview, Query Design view, and Document view. To select multiple data source fields to add to a report, click the appropriate fields while holding the Ctrl key on the keyboard.

You can drag and drop fields onto the canvas, or add them to the Query field container.

**Double-Click.** To automatically add a field to the appropriate field container in the Query Design pane, you can double-click a data source field in the Data pane.

- When you double-click a numeric measure field in the Data pane, it is automatically added to the Sum (Measure) Query field container.

- When you double-click a dimension (non-numeric or date) field in the Data pane, it is added to the By (Row Label) Query field container for a report, or to the X-axis Query field container for a chart.

You cannot automatically add a field to the Across (Column Label) Query field container for a report, or to the Legend (Series) and Multi-graph Query field containers for a chart.

**Right-Click.** You can right-click a field in the Data pane to add it to the Filter area or a Query field container in the Query Design pane. For reports, the available right-click options are as follows:

- **Sum.** For measure (numeric) fields.

- **Sort.** For all types of fields.

- **Across.** For dimension (non-numeric or date) fields.

- **Include as Coordinated.** Only available in Document view.
Filter. For all types of fields.

Slicers. For all types of fields.

For charts, the available right-click options are as follows:

- **Sum.** For measure (numeric) fields.
- **Include as Category Axis.** For dimension (non-numeric or date) fields.
- **Include as Legends Series.** For dimension (non-numeric or date) fields.
- **Filter.** For all types of fields.
- **Slicers.** For all types of fields.
- **Include as Coordinated.** Only available in Document view.

Although most measure fields are composed of numeric values, and most dimension fields are composed of non-numeric or date values, there can be exceptions, depending on the selected data source.

### Using the Query Design Pane in the Resources Panel

The Query Design pane, which contains the Filter and Query (field container) areas, appears below the Data pane, except when you select Query Design view, which expands the size of the Query Design pane and displays it in the Results panel. There are different field containers for reports and charts.

**Reports.** For all reports, the Query field containers in the Query Design pane include Sum, By, and Across.

- Use the Sum \( \sum \) field container to aggregate or display numeric measure fields. Its context menu provides options to Sum (default), Print, Count, or List the fields in the report.

- Use the By field container to vertically sort dimension fields to produce row labels in the report output. Dimension fields are normally non-numeric or date fields.

- Use the Across field container to horizontally sort dimension (non-numeric or date) fields to produce column labels in the report output.
The following image shows the Filter and Query (field container) areas of the Query Design pane as it appears in the Resources panel for reports.

---

**Charts.** For most charts, the Query field containers in the Query Design pane include Measure (Sum), X Axis, Legend (Series), Multi-graph and Coordinated. More complex charts that require additional data dimensions have alternative field containers.

- **Measure (Sum).** Use this field container to aggregate or display numeric measure field values.

- **X Axis.** Use this field container to sort dimension (non-numeric or date) fields in the chart output.

- **Legend (Series).** Use this field container to display dimension (non-numeric or date) fields as color-coded values (lines, bars, areas, scatter plots) that match the color-coded dimension values displayed in the legend below the chart. Legend (Series) provides functionality that is similar to an Across field in a report.

- **Multi-graph.** Use this field container to create outermost sort fields and to serve as a page break for working with multiple charts. The sort field added to this Multi-graph container is not plotted on the chart, but each unique sort field value is listed for every chart.

- **Coordinated.** Use this field container to collectively sort and collate by a common sort group (for documents only).
The following image shows the Filter and Query (field container) areas of the Query Design pane as it appears in the Resources panel for most charts in Live Preview and Query Design view.

For pie charts, the Query field containers in the Query Design pane include Measure (Sum), Slices, Category, Multi-graph, and Coordinated.

- **Measure (Sum).** Use this field container to aggregate or display numeric measure field values in the pie.

- **Pie slices.** Use this field container to display dimension (non-numeric or date) fields as color-coded pie slices that match the color-coded dimension values displayed in the legend below the chart. The Pie slices field container is equivalent to the Legend (Series) field container used for other chart types.

- **Multi-graph.** Use this field container to create outermost sort fields and to serve as a page break for working with multiple charts. The sort field added to this Multi-graph bucket is not plotted on the chart, but each unique sort field value is listed for every chart.

- **Category.** Use this field container to sort dimension (non-numeric or date) fields in the chart output. Category is equivalent to the X-axis field container used for other chart types.

- **Coordinated.** Use this field container to collectively sort and collate by a common sort group (for documents only).
The following image shows the Query (field container) area of the Query Design pane as it appears in the Resources panel for pie charts in Live Preview and Query Design view.

Using Right-Click Field Options in the Query Design Pane

Reference:
Right-Click Field Options in Query Design Pane

In the Query Design pane, you can right-click any field and select from a list of available options that are displayed in the menu that appears. The options that you can select vary, depending on the type of Query field container (Sum, By, Across) in which the field is located and the type of report that you are creating (report or chart).

Report. When you create a report, the Query field containers in the Query Design pane include Measure (Sum), By, and Across.
- **Sum.** Right-clicking a Sum field in a report displays the Filter Values, Sort, Visibility, Change Title, Edit Format, More, and Delete options. You can point to More to access the Data Bars, Aggregation Functions, Traffic Light Conditions, Sub Header, Sub Footer, and Missing options. The right-click menu is shown in the following image.
By. Right-clicking a By field in a report displays the Filter Values, Sort, Break, Visibility, Change Title, More, and Delete options. You can point to More to access Traffic Light Conditions, Sub Header, Sub Footer, and Missing options. The right-click menu is shown in the following image.
**Across.** Right-clicking an Across field in a report displays Filter Values, Sort, Break, Visibility, Change Title, More, and Delete options. You can point to More to access Sub Header, Sub Footer, and Missing options. The right-click menu is shown in the following image.

![Right-click menu](image)

**Chart.** When you create a chart, the Query field containers in the Query Design pane include Measure (Sum), X Axis, Legend (Series), Multi-graph, and Coordinated (for documents only).
- **Measure (Sum).** Right-clicking a Measure (Sum) field in a chart displays the Filter Values, Sort, Visibility, Change Title, More, and Delete options. You can point to More to access the Aggregation Functions, Traffic Light Conditions, and Missing options. The right-click menu is shown in the following image.

- **X Axis or Legend (Series).** Right-clicking an X Axis or Legend (Series) field in a chart displays the Filter Values, Sort, Visibility, Change Title, More, and Delete options. You can point to More to access the Missing option. The right-click menu is shown in the following image.
Coordinated or Multi-graph. Right-clicking a Coordinated field or a Multi-graph field in a chart displays only the Delete option. The right-click menu is shown in the following image.

Reference: Right-Click Field Options in Query Design Pane

The following table lists and describes all the right-click field options available in the Query Design pane for a selected field.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Filter Values</td>
<td>Opens the Filter dialog box for creating WHERE statements, which enable you to select only the data that you want and to exclude all unwanted data.</td>
</tr>
<tr>
<td>Prompt for Values</td>
<td>Opens the Filter dialog box for creating an auto prompting parameter that can be selected when a report is run.</td>
</tr>
<tr>
<td>Rank</td>
<td>Inserts a rank column immediately to the left if a Sort By field is selected and adds a rank column to the left of the Sort By field if a Measure is selected. Ranking a Measure results in two copies of the field, the original Measure and the Sort By field that is created during ranking.</td>
</tr>
<tr>
<td>Sort</td>
<td>Provides access to the Sort and Limit menus. The Sort menu allows you to sort your data either in ascending or descending order. The Limit menu allows you to specify the number of unique values displayed for a sort group that has been added.</td>
</tr>
<tr>
<td><strong>Option</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td>---------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Data Bars</td>
<td>Provides a menu for enabling the data bar representation functionality. Selecting <strong>On</strong> adds a data visualization column to the right of a selected numeric field. The column displays values in each row using horizontal bars that extend from left to right in varying lengths, depending on the corresponding data values.</td>
</tr>
<tr>
<td>Aggregation Functions</td>
<td>Provides a menu for selecting options to assign an aggregation type value to a selected numeric field in a report.</td>
</tr>
<tr>
<td>Subtotal</td>
<td>Provides a menu for enabling subtotal functionality. Clicking <strong>On</strong> inserts a line, descriptive text, and subtotal values in the report output for all numeric fields when the primary sort field changes.</td>
</tr>
<tr>
<td>Page Break</td>
<td>Provides a menu for enabling page break functionality. Clicking <strong>On</strong> starts a new page in the report output when the primary sort field changes.</td>
</tr>
<tr>
<td>Reset Page Numbers</td>
<td>Allows you to reset page numbers on a page break to start at 1.</td>
</tr>
<tr>
<td>Traffic Light Conditions</td>
<td>Opens the Traffic Light Condition dialog box, where you can add new conditional styling or modify existing conditional styling by applying traffic light (and other) colors to a selected field in the report output when the field meets specified criteria.</td>
</tr>
<tr>
<td>Visibility</td>
<td>Provides a menu for controlling the visibility of the selected field. Clicking <strong>Hide</strong> removes the selected field from the report output. Clicking <strong>Show</strong> (default) displays the selected field in the report output.</td>
</tr>
<tr>
<td>Sub Header</td>
<td>Opens the Sub Header &amp; Sub Footer dialog box where you can edit and style your headers.</td>
</tr>
<tr>
<td>Sub Footer</td>
<td>Opens the Sub Header &amp; Sub Footer dialog box where you can edit and style your footers.</td>
</tr>
<tr>
<td>Missing</td>
<td>Allows you to show or hide fields with no value.</td>
</tr>
<tr>
<td>Change Title</td>
<td>Opens the Edit Title dialog box, where you can change the title of the selected field by typing the new title in the Enter Title field.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Edit Format</td>
<td>Opens the Field Format Options dialog box, where you can edit the field type and display options.</td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes the selected field.</td>
</tr>
</tbody>
</table>

All the right-click options available in the Query Design pane are also available in the Field tab. For more information, see *Field Tab* on page 85.

**Understanding the Results Panel**

**In this section:**
- Using the Query Design Pane in the Results Panel
- Understanding the Layout Canvas
- Understanding Output Options

As you create or modify a report, the Results panel displays the Layout canvas in the default Live Preview, or in the Query Design pane when you select Query Design view. When you execute a report, the Results panel displays the Output window. If the Output window is closed, or if there is no report to preview, the Results panel is blank. You can select Query Design view or Live Preview from the Design group of the View tab or Home tab.
The following image shows the Results panel, which displays a chart preview when you first launch InfoAssist to create a chart. The Resources panel appears to the left of the Results Panel.

After executing a report to generate output, if you minimize or close the Output window, the Results panel displays empty space.

**Using the Query Design Pane in the Results Panel**

The Query Design pane displays the Filter area, and the Query field containers. The Query Design pane appears in the Resources panel below the Data pane when you select the default Live Preview.

The Results panel provides a larger area for displaying the Query Design pane. This feature is useful when you are designing a report with multiple filters or numerous fields. You can select Query Design view or Live Preview on the Home tab, in the Design group, or on the View tab, in the Design group.
The following image shows the Query Design pane in the Results panel of the InfoAssist application window. It is displaying report field containers that include Filter, Sum, By, and Across.

![Query Design Pane](image)

Depending on whether you are creating a report or a chart, the Query Design pane displays selected data source fields using different types of field containers.

For reports, the Query Design pane displays Column Labels, Row Labels, and Measures field containers.
For charts, the Query Design pane displays Filter, Legend (Series), Categories (Axis), and Measures (Sum) field containers, as shown in the following image.
Understanding the Layout Canvas

The Layout canvas displays a preview of the report being created or modified in the Results panel when you are in the default Live Preview. To select Live Preview, go to Home tab, and in the Design group, click Live Preview, or on the View tab, in the Design group, click Live Preview. The Layout canvas is always fully maximized (within the Results panel) and cannot be minimized, cascaded, or tiled. However, a blank canvas opens when there is no report.

The Layout canvas displays either live data or sample data.

The Layout canvas displays live data if, on the Home tab, in the Design group, you have clicked Data from Source (default).

The Layout canvas displays sample data if, on the Home tab, in the Design group, you have clicked Use Sample Data.

When you select Data from Source, a live preview of the report being built is refreshed in the Layout canvas as you add, remove, and style data source fields in the report.

When you select Use Sample Data, the Layout canvas displays sample data based on the field type, with the same formatting and styling used to display live data.
The following image shows a preview of a report displayed in the Layout canvas in Live Preview.
Understanding Output Options

When you run a report, the output appears, either in a tab in the Results panel, or in a new browser window. You can create and display output in several different ways, depending on the following options. You can select these options on the View tab, in the Output Window group:

- Cascade
- Tile Horizontally
- Tile Vertically
- Single Tab
- New Tab
- Single Window
- New Window
- Switch

Output window and tab options are also available in the status bar, and output window display options are also available in the Navigation taskbar.

**Note:** When you run a report, tab focus is not on the output window and pressing the Tab key does not move the selection. To move the Tab focus out of the output window, press F6.

**Reference: Output Target Options**

The following are output target options that you can select.

- **Single Tab.** When you click *Single Tab* and run a report, a new output window is created in the Results panel, a report instance is created, and an output tab is placed on the Navigation taskbar. As you modify a report, the same output window is refreshed each time the report is run. This option, which is the default, is ideal when you are working with just one report.
Understanding the Results Panel

- **New Tab.** When you click *New Tab*, each time you run a report, a new output window is created in the Results panel. A new report instance is also created and preserved by the addition of a new output tab on the Navigation taskbar. Each output tab maintains the output of the report that generated the corresponding output window. Selecting an output tab on the Navigation taskbar loads the associated output instance into the output window.

- **Single Window.** When you click *Single Window* and run a report, a new browser window is opened and populated with the report output. As you modify the report, the same browser window is refreshed each time the report is run. If the browser window is closed and the report is run, a new browser window is opened again and is refreshed for each subsequent run. The output is not displayed in the Results panel, and an output tab is not added to the Navigation taskbar.

- **New Window.** When you click *New Window*, each time you run a report, a new browser window is opened and populated with the report output. The output is not displayed in the Results panel, and an output tab is not added to the Navigation Taskbar.
**Reference: Output View Options**

The following are output view options (Arrange) that you can select.

- **Cascade.** When you click Cascade, if multiple output windows exist, they are cascaded diagonally across the Results panel, as shown in the following image. This option does not affect open browser windows when you select New Window or Single Window.
- **Tile Horizontally.** When you click *Tile Horizontally*, if multiple output windows exist, they are tiled horizontally, one above another, across the Results panel, as shown in the following image. This option does not affect open browser windows when you select New Window or Single Window.
- **Tile Vertically.** When you click *Tile Vertically*, if multiple output windows exist, they are tiled vertically, side by side, across the Results panel, as shown in the following image. This option does not affect open browser windows when you select New Window or Single Window.

- **Switch Output.** When you click *Switch Output*, a drop-down menu opens, where you can select any active report to view the output. The selected report is loaded into the output window or browser window, depending on the selected output window or tab option.

Reference: **Output Format Options**

The Output window can display report output in the following formats HTML, HTML5, active report, active Flash, PDF, and active PDF. Note: Excel and PowerPoint formats open in their native programs in a window external to InfoAssist.
The following image shows the HTML report output, which is the default output format, as displayed in the Output window. The Resources panel appears on the left.
The following image shows the active report output displayed with an output location of a new window. The drop-down menu for the last column of data exposes the reporting options.
The following image shows the active Flash output displayed with an output location of a new window.
The following image shows a PDF report output displayed with an output location of a new window.

The following image shows an active PDF report output displayed with an output location of a new window.

**Note:** The active PDF output can only be displayed if you have Adobe Reader 9.0 or later.
The following image shows an Excel report output displayed with an output location of a new window.
The following image shows a PowerPoint report output displayed with an output location of a new window.

**Using the Navigation Taskbar**

The Navigation taskbar provides quick access to all active output windows and to the report design that generated the output. You can return to the last report that you edited in the Query Design pane by clicking *Display Design View* on the taskbar. The Navigation taskbar, as shown in the following image, is always visible in InfoAssist. It is located near the bottom of the application window, just above the status bar.

Each of the active output windows displays a tab on the Navigation taskbar. Selecting the tab displays that output window in the Results panel. If you save a report with a unique name each time you modify it, when the report is executed and a new output window is generated, the unique name appears as a tab on the taskbar. If you continue to modify and execute a report without saving it with a unique name, a number in parentheses is appended to the original, saved report name to differentiate it among the multiple output windows.

The ability to select report output from the Navigation taskbar depends on the output window option selected from the status bar or from the Output Window group of the View tab. For more information, see *Using the Status Bar* on page 133, or *Understanding Output Options* on page 121.
Each report tab on the Navigation taskbar has a right-click menu with the following options:

- Restore
- Minimize
- Maximize
- Close
- Load View
- Auto Resize

Restore, Minimize, Maximize, and Close are standard options available in any browser window or software application. Minimize, Maximize (if the window is not maximized), or Restore (if the window is maximized), and Close can also be found in the top-right corner of the output window, as shown in the following image.

You can load the underlying report design for each output window into the Query Design pane by right-clicking any active output window tab on the taskbar and clicking Load View. The Auto Resize option enables automatic resizing of an output window as needed when you add or remove fields.

The Query View Tools menu at the far left of the Navigation taskbar provides options for displaying all active output windows in the Results panel. The display options that you can select are Cascade, Tile Horizontally, Tile Vertically, Restore All, Minimize All, Maximize All, or Close All. The name of each active output window appears at the bottom of the menu.

The Query View Tools menu options are directly linked to the options available in the Output Window group of the View tab.
Using the Status Bar

The status bar displays the status of the last selected action, a reports button that shows the number of open reports, an output format button that shows the selected format, and an output target button that shows the selected option for displaying new output windows or tabs. The status bar is shown in the following image.

![Status Bar Image]

When you click the reports button, a menu opens, with options for selecting any of the open reports. Each report is listed by name and an icon which represents the report type (report, chart, document). The report you select becomes active.

When you click the output format button, a menu opens, with options for selecting a different output format. Output formats include HTML, active report, active Flash, PDF, active PDF, Excel, Excel 2007, Excel Formula, Excel Pivot, and PowerPoint.

When you click the output target button, a menu opens, with options for Single Tab (default), New Tab, Single Window, and New Window. For more information, see Understanding Output Options on page 121.
You can apply styling to specific areas of a report to customize its appearance and functionality. You can also use the many optional reporting features to add custom functionality and output formats to reports.

**Topics:**
- Creating a Basic Report
- Styling Reports
- Changing a Field Format
- Using Custom Reporting Features
- Creating Customized Report Outputs
Creating a Basic Report

**Procedure:**  **How to Create a Report From the BI Portal Tree**

After you have signed in to the BI Portal, you can work with an existing folder, or create a new folder in the tree to store your reports.

1. Right-click the folder that you want to use, point to New, and then click *Report*.

   The Select a data source dialog box opens, as shown in the following image.

2. From the Select a data source dialog box, select the data source that you want to use, and click *OK.*
The data source that you selected appears in the Data pane of the Resources panel.

3. Drag and drop fields onto the canvas or into the Query pane to begin building your report.

A basic report is shown in the following image.

![Basic Report](image)

**Procedure: How to Create a Report From the Application Main Menu**

1. In the upper-left corner of the InfoAssist interface, click the IA button to open the Application Menu.

2. From the Application Main Menu, click New.

   The InfoAssist splash screen opens.

3. On the InfoAssist splash screen, select *Build a Report*.

   The Select a data source dialog box opens.

4. From the Select a data source dialog box, select the data source that you want to use, and click *OK*.

   The data source that you selected appears in the Data pane of the Resources panel.

5. Drag and drop fields onto the canvas or into the Query pane to begin building your report.

**Procedure: How to Create a Report From the Quick Access Toolbar**

1. On the Quick Access Toolbar, click the *New* icon.

   The InfoAssist splash screen opens.

2. On the InfoAssist splash screen, select *Build a Report*.

   The Select a data source dialog box opens.
3. From the Select a data source dialog box, select the data source that you want to use, and click OK.

The data source that you selected appears in the Data pane of the Resources panel.

4. Drag and drop fields onto the canvas or into the Query pane to begin building your report.

Procedure: How to Create a Report From an Existing Chart

1. Open the chart that contains the data that you want to present in a report.


The data is presented as a report.

Report Outputs

The following output types are available for reports:

- HTML
- active report
- active Flash
- PDF
- active PDF
- Excel
- PowerPoint

Note: When you create a report in Document view, you have access to Excel only.

When you create a report in Live Preview or Query Design view you have access to the following Excel output types:

- Excel. Outputs the report in Excel format.
- Excel Formula. Outputs the report using native Excel formulas for totals and computed values.
- Excel Pivot. Outputs the report in Excel with pivot table processing.
Styling Reports

**How to:**

Perform Report-Level Styling  
Perform Field-Level Styling in a Report  
Add Headings and Footings to a Report  
Style Headings and Footing in a Report  
Style Rows of Data With Alternating Colors in a Report  
Apply Traffic Light Conditional Styling to a Report (By Constant)  
Apply Traffic Light Conditional Styling to a Report (By Field)  
Use Cell Padding in a Report

You can apply custom styling to specific areas of a report. When creating a report in InfoAssist, you can perform the following styling customization.

- Global styling for the entire report. For more information, see *How to Perform Report-Level Styling* on page 139.

- Style data and column titles. For more information, see *How to Perform Field-Level Styling in a Report* on page 142.

- Style headings and footings. For more information, see *How to Style Headings and Footing in a Report* on page 148.

- Style the rows of data with alternating colors. For more information, see *How to Style Rows of Data With Alternating Colors in a Report* on page 148.

- Apply traffic light conditional styling to data. For more information, see *How to Apply Traffic Light Conditional Styling to a Report (By Constant)* on page 149 and *How to Apply Traffic Light Conditional Styling to a Report (By Field)* on page 151.

- Increase or decrease the amount of space inserted between rows and columns. For more information, see *How to Use Cell Padding in a Report* on page 152.

**Procedure:**  **How to Perform Report-Level Styling**

You can style an entire report.

1. Create a report.

3. Select any of the following styling options that are available in the Style group.

- **Font.** Use the menu to change the font.
- **Font size.** Use the menu to change the numeric value for the font size.
- **Font style.** Click the appropriate button (bold, italic, underline) to style the selected text.
- **Text alignment.** Click the appropriate button (left, center, right) to align the selected text.
- **Font color.** Click the button to open the Color dialog box, where you can select the font color.
- **Background color.** Click the button to open the Color dialog box, where you can select the background color for the report.
- **Currency symbol.** Click the appropriate button (US dollar, British Pound, Japanese Yen, Euro, New Israeli Shekel).
- **Style Reset.** Click the *Reset to Quick Styles from Template* button to reset all settings to the default settings from the template.

**Note:** Reset only works while the Report Style dialog box is open. Once you click *OK*, all changes are committed. To undo global styling after it has been committed, you must use the Undo command on the Quick Access Toolbar.

- **Preview.** Displays the text as you have formatted it.

4. Click *OK*. The report is styled accordingly.
The following image shows a report using the style that had been selected in the Options dialog box (medium blue). In this style, Trebuchet MS 9 pt. black is the default font.

<table>
<thead>
<tr>
<th>Region</th>
<th>Product Category</th>
<th>Quantity Sold</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Central</td>
<td>Stereo Systems</td>
<td>11,143</td>
<td>3,027,276.42</td>
</tr>
<tr>
<td></td>
<td>Televisions</td>
<td>7,428</td>
<td>10,131,328.09</td>
</tr>
<tr>
<td></td>
<td>Video Players</td>
<td>11,647</td>
<td>3,835,578.36</td>
</tr>
<tr>
<td>MidEast</td>
<td>Stereo Systems</td>
<td>4,607</td>
<td>1,254,014.44</td>
</tr>
<tr>
<td></td>
<td>Televisions</td>
<td>3,246</td>
<td>4,256,202.11</td>
</tr>
<tr>
<td></td>
<td>Video Players</td>
<td>5,043</td>
<td>1,653,244.82</td>
</tr>
<tr>
<td>NorthEast</td>
<td>Stereo Systems</td>
<td>8,735</td>
<td>2,381,435.14</td>
</tr>
<tr>
<td></td>
<td>Televisions</td>
<td>5,578</td>
<td>7,452,259.19</td>
</tr>
<tr>
<td></td>
<td>Video Players</td>
<td>9,057</td>
<td>2,980,605.73</td>
</tr>
<tr>
<td>NorthWest</td>
<td>Stereo Systems</td>
<td>7,287</td>
<td>2,043,976.10</td>
</tr>
<tr>
<td></td>
<td>Televisions</td>
<td>5,029</td>
<td>6,713,008.94</td>
</tr>
<tr>
<td></td>
<td>Video Players</td>
<td>7,869</td>
<td>2,602,775.63</td>
</tr>
<tr>
<td>SouthEast</td>
<td>Stereo Systems</td>
<td>7,431</td>
<td>2,034,149.11</td>
</tr>
<tr>
<td></td>
<td>Televisions</td>
<td>5,031</td>
<td>6,793,602.47</td>
</tr>
<tr>
<td></td>
<td>Video Players</td>
<td>7,657</td>
<td>2,500,094.24</td>
</tr>
<tr>
<td>SouthWest</td>
<td>Stereo Systems</td>
<td>1,832</td>
<td>494,200.80</td>
</tr>
<tr>
<td></td>
<td>Televisions</td>
<td>1,296</td>
<td>1,705,461.80</td>
</tr>
<tr>
<td></td>
<td>Video Players</td>
<td>2,038</td>
<td>670,346.72</td>
</tr>
<tr>
<td>West</td>
<td>Stereo Systems</td>
<td>6,638</td>
<td>1,782,370.94</td>
</tr>
<tr>
<td></td>
<td>Televisions</td>
<td>4,340</td>
<td>5,927,165.23</td>
</tr>
<tr>
<td></td>
<td>Video Players</td>
<td>6,870</td>
<td>2,248,798.50</td>
</tr>
</tbody>
</table>
## Procedure: How to Perform Field-Level Styling in a Report

You can style data, column titles, or both, in the report output for the selected data source field.

1. Create a report.
2. In the Query Design pane, select a data source field.
   - The Field tab appears on the ribbon.

---

<table>
<thead>
<tr>
<th>Region</th>
<th>Category</th>
<th>Quantity Sold</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Central</td>
<td>Stereo Systems</td>
<td>11,143</td>
<td>3,027,276.42</td>
</tr>
<tr>
<td></td>
<td>Televisions</td>
<td>7,428</td>
<td>10,131,328.09</td>
</tr>
<tr>
<td></td>
<td>Video Players</td>
<td>11,647</td>
<td>3,836,578.36</td>
</tr>
<tr>
<td>MidEast</td>
<td>Stereo Systems</td>
<td>4,607</td>
<td>1,254,014.44</td>
</tr>
<tr>
<td></td>
<td>Televisions</td>
<td>3,246</td>
<td>4,256,202.11</td>
</tr>
<tr>
<td></td>
<td>Video Players</td>
<td>5,043</td>
<td>1,653,244.82</td>
</tr>
<tr>
<td>NorthEast</td>
<td>Stereo Systems</td>
<td>8,735</td>
<td>2,381,435.14</td>
</tr>
<tr>
<td></td>
<td>Televisions</td>
<td>5,578</td>
<td>7,452,259.19</td>
</tr>
<tr>
<td></td>
<td>Video Players</td>
<td>9,057</td>
<td>2,980,605.73</td>
</tr>
<tr>
<td>NorthWest</td>
<td>Stereo Systems</td>
<td>7,287</td>
<td>2,043,976.10</td>
</tr>
<tr>
<td></td>
<td>Televisions</td>
<td>5,029</td>
<td>6,713,008.94</td>
</tr>
<tr>
<td></td>
<td>Video Players</td>
<td>7,869</td>
<td>2,602,775.63</td>
</tr>
<tr>
<td>SouthEast</td>
<td>Stereo Systems</td>
<td>7,431</td>
<td>2,034,149.11</td>
</tr>
<tr>
<td></td>
<td>Televisions</td>
<td>5,031</td>
<td>6,793,602.47</td>
</tr>
<tr>
<td></td>
<td>Video Players</td>
<td>7,657</td>
<td>2,500,094.24</td>
</tr>
<tr>
<td>SouthWest</td>
<td>Stereo Systems</td>
<td>1,832</td>
<td>494,200.80</td>
</tr>
<tr>
<td></td>
<td>Televisions</td>
<td>1,296</td>
<td>1,705,461.80</td>
</tr>
<tr>
<td></td>
<td>Video Players</td>
<td>2,038</td>
<td>670,346.72</td>
</tr>
<tr>
<td>West</td>
<td>Stereo Systems</td>
<td>6,638</td>
<td>1,782,370.94</td>
</tr>
<tr>
<td></td>
<td>Televisions</td>
<td>4,340</td>
<td>5,927,165.23</td>
</tr>
<tr>
<td></td>
<td>Video Players</td>
<td>6,870</td>
<td>2,248,798.50</td>
</tr>
</tbody>
</table>
3. In the Style group, click one of the following:

- **Data Style.** Styles only the data for the selected data source field.
- **Title Style.** Styles only the column title for the selected data source field.
- **Data + Title.** Styles both the data and the column title for the selected data source field.

4. Select any of the following styling options that are available in the Style group.

- **Font.** Use the menu to change the font.
- **Font size.** Use the menu to change the numeric value for the font size.
- **Font color.** Click the button to open the Color dialog box, where you can select the font color.
- **Style Reset.** Click the *Reset styling to default style* button to reset all settings to the default settings from the template.

  **Note:** Reset only works while the Report Style dialog box is open. Once you click *OK*, all changes are committed. To undo global styling after it has been committed, you must use the Undo command on the Quick Access Toolbar.

- **Font style.** Click the appropriate button (bold, italic, underline) to style the selected text.
- **Text alignment.** Click the appropriate button (left, center, right) to align the text.
- **Background color.** Click the button to open the Color dialog box, where you can select the background color for the report.

5. Click *OK*. The report is styled accordingly.

The following image shows a report with the default formatting and the Revenue data column selected for styling.
The following image shows the Revenue data column styled to display the American dollar sign ($) as the currency symbol.

<table>
<thead>
<tr>
<th>Region</th>
<th>Product Category</th>
<th>Quantity Sold</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Central</td>
<td>Stereo Systems</td>
<td>11,143</td>
<td>$3,027,276.42</td>
</tr>
<tr>
<td></td>
<td>Televisions</td>
<td>7,428</td>
<td>$10,131,328.09</td>
</tr>
<tr>
<td></td>
<td>Video Players</td>
<td>11,647</td>
<td>$3,835,578.36</td>
</tr>
<tr>
<td>MidEast</td>
<td>Stereo Systems</td>
<td>4,607</td>
<td>$1,254,014.44</td>
</tr>
<tr>
<td></td>
<td>Televisions</td>
<td>3,246</td>
<td>$4,256,202.11</td>
</tr>
<tr>
<td></td>
<td>Video Players</td>
<td>5,043</td>
<td>$1,653,244.82</td>
</tr>
<tr>
<td>NorthEast</td>
<td>Stereo Systems</td>
<td>8,735</td>
<td>$2,381,435.14</td>
</tr>
<tr>
<td></td>
<td>Televisions</td>
<td>5,578</td>
<td>$7,452,259.19</td>
</tr>
<tr>
<td></td>
<td>Video Players</td>
<td>9,057</td>
<td>$2,980,605.73</td>
</tr>
<tr>
<td>NorthWest</td>
<td>Stereo Systems</td>
<td>7,287</td>
<td>$2,043,976.10</td>
</tr>
<tr>
<td></td>
<td>Televisions</td>
<td>5,029</td>
<td>$6,713,008.94</td>
</tr>
<tr>
<td></td>
<td>Video Players</td>
<td>7,869</td>
<td>$2,602,775.63</td>
</tr>
<tr>
<td>SouthEast</td>
<td>Stereo Systems</td>
<td>7,431</td>
<td>$2,034,149.11</td>
</tr>
<tr>
<td></td>
<td>Televisions</td>
<td>5,031</td>
<td>$6,793,602.47</td>
</tr>
<tr>
<td></td>
<td>Video Players</td>
<td>7,657</td>
<td>$2,500,094.24</td>
</tr>
<tr>
<td>SouthWest</td>
<td>Stereo Systems</td>
<td>1,832</td>
<td>$494,200.80</td>
</tr>
<tr>
<td></td>
<td>Televisions</td>
<td>1,296</td>
<td>$1,705,461.80</td>
</tr>
<tr>
<td></td>
<td>Video Players</td>
<td>2,038</td>
<td>$670,346.72</td>
</tr>
<tr>
<td>West</td>
<td>Stereo Systems</td>
<td>6,638</td>
<td>$1,782,370.94</td>
</tr>
<tr>
<td></td>
<td>Televisions</td>
<td>4,340</td>
<td>$5,927,165.23</td>
</tr>
<tr>
<td></td>
<td>Video Players</td>
<td>6,870</td>
<td>$2,248,798.50</td>
</tr>
</tbody>
</table>

Procedure: How to Add Headings and Footings to a Report

You can make a report more meaningful by adding headings and footings. Headings and footings supply context and key information about a report, such as its purpose and audience. Headings and footings also provide structure, helping you navigate to the detail sought. They enhance visual appeal.

In this procedure, you will add and style a report heading and page heading. The procedure uses sample values, but you can supply values that apply to your own, reports.

Headings and Footings are available in Query Design view, Live Preview, and Document view.

1. Create a report.
2. On the Home tab, in the Report group, click the *Header & Footer* button. 
   The Header & Footer dialog box opens.

3. Click the tab for the heading or footing element that you want to add. 
   For a report, you can add a report heading, page heading, page footing, or report footing. 
   By default, the Report Header tab is selected. In this procedure, accept the default.

4. Click inside the design area of the dialog box, and type the text for the heading. 
   For example, the text for a sample report heading might be Quantity Sold by Product.

5. Using the styling ribbon, apply styling to the report heading text. 
   For example, click the arrow next to the font field, and click *HELVETICA*. Click 11 for the font size.
   The sample report heading with the selected styling values is shown in the following image.

6. Click *Apply* to save the changes you have made so far, without closing the dialog box.

7. To add a page heading, click the *Page Header* tab. 
   In this procedure, you are going to add one of the supplied quick text options.

8. Click the last button \(\text{(Insert preformatted text content for headers/footers)}\) on the right of the styling ribbon, and click *Confidential* in the list.

9. Change the font and font size. For example, change the font to *HELVETICA* and the size to 10.
You can add your own text before or after the supplied text, for example, For Regional Managers Only.

10. Click OK to save the report heading and page heading and close the Header & Footer dialog box.

The report heading and page heading that you added and styled are shown in Live Preview in the following image.

11. To make changes, to either the report, or page heading, right-click the heading and click Edit in the menu.
Procedure: How to Style Headings and Footing in a Report

You can style headings and footings in the report output for the selected heading or footing field.

1. Create a report.
2. With the report opened in Live Preview, select the heading or footing text that you want to style.
   The Header & Footer dialog box opens.
4. Select any of the following styling options that are available in the Style dialog box.
   - **Font.** Use the menu to change the font.
   - **Font size.** Use the menu to change the numeric value for the font size.
   - **Font style.** Click the appropriate button (bold, italic, underline) to style the selected text.
   - **Text alignment.** Click the appropriate button (left, center, right) to align the selected text.
   - **Font color.** Click this button to open the Color dialog box, where you can select the font color.
   - **Background color.** Click this button to open the Color dialog box, where you can select the background color for the report.
   - **Reset to Quick Styles from Template.** Click this button to reset all settings to the default settings from the template.
     
     **Note:** Reset only works while the Report Style dialog box is open. Once you click OK, all changes are committed. To undo global styling after it has been committed, you must use the Undo command on the Quick Access Toolbar.

5. Click OK. The report is styled accordingly.

Procedure: How to Style Rows of Data With Alternating Colors in a Report

You can style rows of data in a report with alternating colors.

1. Create a report.
2. Open the report in Live Preview.
   The Color dialog box opens.
4. Select a color.

5. Click OK.

The selected color provides an alternating color scheme for the report. The report output displays alternating rows of data, using a white background for one row and a background of the selected color for the next row. This pattern continues throughout the report, as shown in the following image of Banded report output.

![Image of Banded report output]

**Procedure:** How to Apply Traffic Light Conditional Styling to a Report (By Constant)

You can apply traffic light conditional styling to data for a selected measure field. By default, the report displays the values that satisfy the first condition in green, and the values that satisfy the second condition in red.

1. Open a report in Live Preview.

2. Open the Traffic Light Condition dialog box in one of the following ways:
   - **Ribbon:** Select a field on the report, and then on the Field tab, in the Display group, click Traffic Lights.
   - **Right-Click Menu:** Right-click a field on the report, point to More, and then click Traffic Light Conditions.

   The Traffic Light Condition dialog box opens.

3. From the Relational Operators drop-down menu below the field name, click a relational operator.

   The options are:
   - Equal to
   - Not equal to
   - Greater than
   - Less than
   - Greater than or equal to
Less than or equal to

4. In the field to the right of the operator drop-down menu, click the down arrow for the Type drop-down menu.

   The Type dialog box opens.

5. In the Type dialog box, click Constant.

6. Enter a value in the Value field, or
   a. From the Get Values drop-down menu, select one of the following values All, First, Last, Minimum, Maximum, From File. The value that you select appears in the Get Values field.
   b. Select the value in the Get Values field. The value that you selected appears in the Value field.

7. Click OK.

   The value that you selected appears in the field to the right of the operator drop-down menu.

8. Click the Color button.

   The Color dialog box opens.

9. Select a color.

10. Click OK.

    The color appears in the Preview box.

11. Click the Drill Down button.

    The Drill Down dialog box opens.

12. In the Drill Down dialog box, specify each of the following:
    □ Drill down to a report or a web page
    □ URL of the web page
    □ An alternate comment
    □ Target (New Window, Same Window)
    □ Parameters that you want to use (Name, Value)

13. Click OK to close the dialog box.

14. Click the New button to set traffic light conditions for additional fields.
Procedure: How to Apply Traffic Light Conditional Styling to a Report (By Field)

You can apply traffic light conditional styling to data for a selected measure field. By default the report displays the values that satisfy the first condition in green, and the values that satisfy the second condition in red.

1. Open a report in Live Preview.

2. Open the Traffic Light Condition dialog box in one of the following ways:
   - **Ribbon:** Select a field on the report, and then on the Field tab, in the Display group, click Traffic Lights.
   - **Right-Click Menu:** Right-click a field on the report, point to More, and then click Traffic Light Conditions.

   The Traffic Light Condition dialog box opens.

3. From the drop-down menu below the field name, select a relational operator.
   - The options are:
     - Equal to
     - Not equal to
     - Greater than
     - Less than
     - Greater than or equal to
     - Less than or equal to

4. In the field to the right of the operator drop-down menu, click the arrow for the Type drop-down menu.

   The Type dialog box opens.

5. In the Type dialog box, select Field.

   The Type dialog box displays the Dimensions, and Measures and Properties of your data. You can display the data in the following ways:

   - View fields in business order. Select from the following options Title, Description, Name, Alias.
   - View fields in a sortable grid. Select from the following options Name, Title, Alias, Format, Segment, Filename, Description, Reference.
   - View the hierarchical structure of the data. Select from the following options Title, Description, Name, Alias.
6. Select a field.

7. Click OK.

The field that you selected appears in the field to the right of the operator drop-down menu.

8. Click the Color button.

The Color dialog box opens.

9. Select a color.

The color appears in the Preview box.

10. Click OK.

11. Click the Drill Down button.

The Drill Down dialog opens.

12. In the Drill Down dialog, specify each of the following:

- Drill down to a report or a web page
- URL of the web page
- An alternate comment
- Target (New Window, Same Window)
- Parameters that you want to use (Name, Value)

13. Click OK.

14. Click the New button to set traffic light conditions for additional fields.

Procedure: How to Use Cell Padding in a Report

You can customize the amount of space inserted between rows and columns in a report.

1. Open a report in Live Preview.

2. On the Layout tab, in the Report group, open the Cell Padding menu.

3. On the Cell Padding menu, click Custom.
The Cell Padding dialog box opens.

![Cell Padding Dialog Box]

4. Type the cell padding values that you want in the Top, Bottom, Left, and Right fields.

5. Click OK.

The report reflects the cell padding that you set.

The following image shows a report with default cell padding.

![Default Cell Padding]

The following image shows the same report with a cell padding of 0.01 inches added to the top, bottom, left, and right of the cell.

![Cell Padding with 0.01 Inches]
Changing a Field Format

How to:
Assign an Alphanumeric Format
Assign a Numeric Format
Assign a Date Format
Assign a Date-Time Format
Add a Percent Sign to a Numeric Field

You can change the format of any field except a Sort field. You can change the format of measures, as well as any calculated fields. The following image shows the Field Format Options dialog box.

The following procedures show how to change a field format from the Field Format Options dialog box. For more information on how to use the Format group options, see Field Tab on page 85.

Procedure: How to Assign an Alphanumeric Format

1. With a report open in Live Preview, right-click a virtual field or column Measure field, and select Edit Format.
The Field Format Options dialog box opens.

2. From the Field type list, select *Alphanumeric*.

3. To assign a different length, specify a number between 1 and 4095 in the *Total length* field. The default value is 20.

4. Click *OK* to close the Field Format Options dialog box and return to the Results Panel.

The new format appears in the previously selected column.

**Procedure: How to Assign a Numeric Format**

1. With a report open in Live Preview, right-click a virtual or column Measure field, and select *Edit Format*.

   The Field Format Options dialog box opens.

2. From the Field type list, click one of the following options:
   - *Floating Point* (default length 7.2)
   - *Integer* (default length 5)
   - *Decimal* (default length 12.2)
   - *Packed* (default length 12.2)

   If the selected field matches the selected format type, its current length appears in the Field Length field. Otherwise, the default length appears in the Field Length field. The Decimals field shows the numbers of decimal places for Floating Point, Decimal, and Packed.

3. To assign a different length, specify it in the *Field Length* field for format types as follows: 1-9 for Floating Point, 1-11 for Integer, 1-20 for Decimal, and 1-33 for Packed.

4. To assign a different number of decimal places for Floating Point, Decimal, or Packed, specify the number in the *Decimals* field.

5. Click *OK* to close the Field Format Options dialog box and return to the Results Panel.

   The new format appears in the previously selected column.

**Procedure: How to Assign a Date Format**

1. With a report open in Live Preview, right-click a virtual or column Measure field, and select *Edit Format*.

   The Field Format Options dialog box opens.
Changing a Field Format

2. From the Field type list, click Date.

3. To assign a different date display format, select a date format from the Date Format list. The default date display format is MDY.

4. Click OK to close the Field Format Options dialog box and return to the Results Panel. The new format appears in the previously selected column.

**Procedure: How to Assign a Date-Time Format**

1. With a report open in Live Preview, right-click a virtual or column Measure field, and select Edit Format. The Field Format Options dialog box opens.

2. From the Field type list, click Date-Time.

3. To assign a different date-time format, select the date format you want to use from the Date Format list. Expand Year First, Month First, or Day First to see the available options.

4. Select a time format (if applicable) from the Time Format list. Expand Hour First, Minute First, or Seconds First to see the available options.

   If you select the Time Only check box then you can only set a time format.

5. Click OK to close the Field Format Options dialog box and return to the Results Panel. The new format appears in the previously selected column.

**Procedure: How to Add a Percent Sign to a Numeric Field**

You can add a percent sign to the end of a numeric value (Decimal, Integer, and Floating Point formats). This numeric display option includes a percent sign along with the numeric data, but does not calculate the percent.

1. With a report open in Live Preview, right-click a virtual or column Measure field, and select Edit Format. The Field Format Options dialog box opens.

2. From the Field type list, click a numeric value format (Floating point, Integer, Decimal, or Packed), and then select the Percent (%) check box.

3. Click OK to close the Field Format Options dialog box and return to the Results Panel. The new format appears in the previously selected column.
Using Custom Reporting Features

**How to:**

- Rank Fields in a Report
- Limit the Values of a Column in a Report
- Add Page and Line Breaks to a Report
- Add Subtotals to a Report
- Add Column Totals to a Report
- Add Row Totals to a Report
- Add Subheadings and Subfootings to a Report
- Add Pop-Up Titles to a Report
- Add Data Visualization Bars to a Report
- Display Measure Data Using Aggregation Options in a Report
- Display Repeated Sort Values in a Report
- Recalculate the Result of a Compute Command

You can use the following custom features when creating reports in InfoAssist.

- **Rank.** Inserts a ranking column for By and Measure fields in a report. For more information, see *How to Rank Fields in a Report* on page 158.

- **Limit.** Limits the number of unique variables in a column. For more information, see *How to Limit the Values of a Column in a Report* on page 159.

- **Page Breaks.** Starts a new page in the output when the primary sort field changes. For more information, see *How to Add Page and Line Breaks to a Report* on page 159.

- **Line Breaks.** Inserts a line in the report output when the primary sort field changes. For more information, see *How to Add Page and Line Breaks to a Report* on page 159.

- **Subtotal.** Inserts subtotals in the output for all numeric fields when the primary sort field changes. For more information, see *How to Add Subtotals to a Report* on page 160.

- **Column Totals.** Inserts a grand total row at the bottom of the report to sum numeric data in each column. For more information, see *How to Add Column Totals to a Report* on page 163.

- **Row Totals.** Inserts a grand total column to the right side of the report to sum numeric data in each row. For more information, see *How to Add Row Totals to a Report* on page 164.
- **Sub Header.** Adds a subheading just below the column titles in the report output when the primary sort field changes. For more information, see *How to Add Subheadings and Subfootings to a Report* on page 164.

- **Sub Footer.** Adds a subfooting at the end of the data on each page of the report output when the primary sort field changes. For more information, see *How to Add Subheadings and Subfootings to a Report* on page 164.

- **Pop-up Titles.** Adds pop-up titles to report output when the mouse pointer hovers over a column title. For more information, see *How to Add Pop-Up Titles to a Report* on page 165.

- **Data Bars.** Adds data visualization bars to numeric data. For more information, see *How to Add Data Visualization Bars to a Report* on page 165.

- **Aggregation.** Displays numeric measure data using aggregation options other than the default of Sum. For more information, see *How to Display Measure Data Using Aggregation Options in a Report* on page 166.

- **Repeat Sort Values.** Displays all repeated sort values instead of blanks after the first instance of a new sort value appears in the report. The default behavior is to display blanks after the first instance of a new sort value. For more information, see *How to Display Repeated Sort Values in a Report* on page 168.

- **Recompute.** Recalculates the result of a Compute command. Recompute is similar to Subtotal in that it recalculates only at the specified sort break. For more information, see *How to Recalculate the Result of a Compute Command* on page 170.

**Procedure: How to Rank Fields in a Report**

You can add rank columns to the By and Measure fields in a report by clicking the *Rank* button. You access the Rank button, on the Field tab, in the Sort group.

- Adding a rank column to a By field inserts a rank column immediately to the left of the field.

- Adding a rank column to a Measure field creates a copy of the column as a By field and adds a rank column to the left of the new By field.

**Note:** The rank option can also be accessed by right-clicking a By or Measure field and accessing the Rank option through the right-click menu.

1. With a report open, in the Query Design pane, select a By or a Measure field.

   The Field tab appears on the ribbon.

2. In the Sort group, click *Rank.*
A rank column appears, as shown in the following image.

![Rank Column Example]

**Note:** The rank column can now be edited and formatted like any other column, with the following exceptions:

- The only formatting that can be applied is Traffic Light Conditions.
- It cannot be hidden.
- You cannot insert breaks or a filter on the RANK column.
- No column can be moved in between the rank column and the column it is ranking.

**Procedure: How to Limit the Values of a Column in a Report**

You can limit the number of unique values that appear in a column through the Limit menu. First you must select a column, then the Limit menu becomes available on the Field tab, in the Sort group.

**Note:** You can also access the Limit option by right-clicking a column, pointing to Sort, and then selecting *Limit*.

1. With a report open, in the Query Design pane, right-click a By or Measure field.
   
The Field tab appears on the ribbon.

2. In the Sort group, enter a value in the Limit field, or select a value from the list. The number of unique values that appear in the column is now limited to value that you set.

**Procedure: How to Add Page and Line Breaks to a Report**

You can add page breaks and line breaks to report output for the primary sort field.

1. With a report open, in the Query Design pane, select a By (sort) field.
   
The Field tab appears on the ribbon.

2. From the Break group, click *Page Break* or *Line Break*. 
**Procedure: How to Add Subtotals to a Report**

1. With a report open, in the Query Design pane, select a By (sort) field. The Field tab appears on the ribbon.

2. From the Break group, click **Subtotal**.

   If you select Page Break, a new page is created every time the value of the primary sort field changes. Each page includes a new set of column titles, as shown in the following image.

```
<table>
<thead>
<tr>
<th>Region</th>
<th>Product Category</th>
<th>Quantity Sold</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Central</td>
<td>Stereo Systems</td>
<td>11,143</td>
<td>3,027,276.42</td>
</tr>
<tr>
<td></td>
<td>Televisions</td>
<td>7,428</td>
<td>10,131,328.09</td>
</tr>
<tr>
<td>Video Players</td>
<td>11,647</td>
<td>3,835,578.36</td>
<td></td>
</tr>
<tr>
<td>Video Production</td>
<td>2,245</td>
<td>2,166,591.20</td>
<td></td>
</tr>
<tr>
<td>MidEast</td>
<td>Stereo Systems</td>
<td>4,607</td>
<td>1,254,014.44</td>
</tr>
<tr>
<td></td>
<td>Televisions</td>
<td>3,246</td>
<td>4,256,202.11</td>
</tr>
<tr>
<td>Video Players</td>
<td>5,043</td>
<td>1,653,244.82</td>
<td></td>
</tr>
<tr>
<td>Video Production</td>
<td>955</td>
<td>896,178.80</td>
<td></td>
</tr>
<tr>
<td>NorthEast</td>
<td>Stereo Systems</td>
<td>8,735</td>
<td>2,381,435.14</td>
</tr>
<tr>
<td></td>
<td>Televisions</td>
<td>5,578</td>
<td>7,452,259.19</td>
</tr>
<tr>
<td>Video Players</td>
<td>9,057</td>
<td>2,980,605.73</td>
<td></td>
</tr>
<tr>
<td>Video Production</td>
<td>1,738</td>
<td>1,723,425.57</td>
<td></td>
</tr>
</tbody>
</table>
```
If you select Line Break, a new divider line is inserted in the report output every time the value of the primary sort field changes, as shown in the following image.

<table>
<thead>
<tr>
<th>Region</th>
<th>Product Category</th>
<th>Quantity</th>
<th>Sold</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Central</td>
<td>Stereo Systems</td>
<td>14</td>
<td>3,075.02</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Televisions</td>
<td>6</td>
<td>10,341.19</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Video Players</td>
<td>5</td>
<td>1,673.95</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Video Production</td>
<td>3</td>
<td>964.39</td>
<td></td>
</tr>
<tr>
<td>MidEast</td>
<td>Stereo Systems</td>
<td>7</td>
<td>889.93</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Televisions</td>
<td>6</td>
<td>8,821.97</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Video Players</td>
<td>8</td>
<td>2,396.92</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Video Production</td>
<td>2</td>
<td>478.00</td>
<td></td>
</tr>
<tr>
<td>NorthEast</td>
<td>Stereo Systems</td>
<td>10</td>
<td>2,059.90</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Televisions</td>
<td>1</td>
<td>297.49</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Video Players</td>
<td>10</td>
<td>3,344.90</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Video Production</td>
<td>1</td>
<td>269.10</td>
<td></td>
</tr>
</tbody>
</table>
Clicking **Subtotal** turns Subtotal on for all fields as a RECOMPUTE and inserts a line of descriptive text (*Subtotal FIELD Value*). Clicking the down arrow launches a menu of options. From this menu, you can choose between simple and recompute. Selecting **More Options** opens a dialog box from which you can choose which fields to subtotal, as well as what type of aggregation to do for those fields. You can also change the Subtotal text.

<table>
<thead>
<tr>
<th>Region</th>
<th>Product Category</th>
<th>Quantity Sold</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Central</td>
<td>Stereo Systems</td>
<td>11,143</td>
<td>3,027,276.42</td>
</tr>
<tr>
<td></td>
<td>Televisions</td>
<td>7,428</td>
<td>10,131,328.09</td>
</tr>
<tr>
<td></td>
<td>Video Players</td>
<td>11,647</td>
<td>3,835,578.36</td>
</tr>
<tr>
<td></td>
<td>Video Production</td>
<td>2,245</td>
<td>2,166,591.20</td>
</tr>
<tr>
<td>Subtotal:</td>
<td></td>
<td>32,463</td>
<td>19,160,774.07</td>
</tr>
<tr>
<td>MidEast</td>
<td>Stereo Systems</td>
<td>4,607</td>
<td>1,254,014.44</td>
</tr>
<tr>
<td></td>
<td>Televisions</td>
<td>3,246</td>
<td>4,256,202.11</td>
</tr>
<tr>
<td></td>
<td>Video Players</td>
<td>5,043</td>
<td>1,653,244.82</td>
</tr>
<tr>
<td></td>
<td>Video Production</td>
<td>955</td>
<td>896,178.80</td>
</tr>
<tr>
<td>Subtotal:</td>
<td></td>
<td>13,851</td>
<td>8,059,640.17</td>
</tr>
<tr>
<td>NorthEast</td>
<td>Stereo Systems</td>
<td>8,735</td>
<td>2,381,435.14</td>
</tr>
<tr>
<td></td>
<td>Televisions</td>
<td>5,578</td>
<td>7,452,259.19</td>
</tr>
<tr>
<td></td>
<td>Video Players</td>
<td>9,057</td>
<td>2,980,605.73</td>
</tr>
<tr>
<td></td>
<td>Video Production</td>
<td>1,738</td>
<td>1,723,425.57</td>
</tr>
<tr>
<td>Subtotal:</td>
<td></td>
<td>25,108</td>
<td>14,537,725.63</td>
</tr>
</tbody>
</table>
Procedure: How to Add Column Totals to a Report

On the Home tab, in the Report group, click Column Totals.

Clicking Column Totals adds a grand TOTAL row at the bottom of the report that sums numeric data in each column, as shown in the following image.
**Procedure:** How to Add Row Totals to a Report

On the Home tab, in the Report group, click *Row Totals*.

Clicking *Row Totals* adds a grand TOTAL column to the right side of the report that sums numeric data in each row, as shown in the following image.

![Row Totals Example](image)

**Procedure:** How to Add Subheadings and Subfootings to a Report

You can add subheadings and subfootings to report output for the sort field.

1. With a report open, in the Query Design pane, select a By (sort) field.
   
   The Field tab appears on the ribbon.

2. From the Break group, click *Sub Header* or *Sub Footer*.
   
   The Sub Header & Sub Footer dialog box opens.

3. In the Sub Header & Sub Footer dialog box, type and style the text, and click OK.
Subheadings appear just below the column titles in the report output every time the value of the primary sort field changes. Subfootings appear at the end of the data on each page of the report output every time the value of the primary sort field changes. The following image shows how subheadings and subfootings appear in the report output.

![Report Output Example](image)

**Procedure:** How to Add Pop-Up Titles to a Report

On the Format tab, in the Features group, click *Title Popup*.

Clicking *Title Popup* displays a pop-up title when the mouse pointer hovers over any column title in the report, as shown in the following image.

![Example with Pop-Up Title](image)

**Procedure:** How to Add Data Visualization Bars to a Report

You can add data visualization bars to the report output for a selected numeric data source field.

1. With a report open, in the Query Design pane, select the numeric data source field. The Field tab appears on the ribbon.

2. In the Display group, click *Data Bars*. 

A data visualization column appears to the right of the selected numeric data source field to display values in each row. The column uses horizontal bars that extend from left to right and vary in length, depending on the corresponding data values. The following image is an example of report output with data visualization bars.

<table>
<thead>
<tr>
<th>Region</th>
<th>Product Category</th>
<th>Quantity</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Central</td>
<td>Stereo Systems</td>
<td>11,143</td>
<td>3,027,276.42</td>
</tr>
<tr>
<td></td>
<td>Televisions</td>
<td>7,428</td>
<td>10,131,328.09</td>
</tr>
<tr>
<td>Video Players</td>
<td>11,647</td>
<td>3,835,578.36</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Video Production</td>
<td>2,245</td>
<td>2,166,591.20</td>
</tr>
<tr>
<td>MidEast</td>
<td>Stereo Systems</td>
<td>4,607</td>
<td>1,254,014.44</td>
</tr>
<tr>
<td></td>
<td>Televisions</td>
<td>3,246</td>
<td>4,256,202.11</td>
</tr>
<tr>
<td>Video Players</td>
<td>5,043</td>
<td>1,653,244.82</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Video Production</td>
<td>955</td>
<td>896,178.80</td>
</tr>
<tr>
<td>NorthEast</td>
<td>Stereo Systems</td>
<td>8,735</td>
<td>2,381,435.14</td>
</tr>
<tr>
<td></td>
<td>Televisions</td>
<td>5,578</td>
<td>7,452,259.19</td>
</tr>
<tr>
<td>Video Players</td>
<td>9,057</td>
<td>2,980,605.73</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Video Production</td>
<td>1,738</td>
<td>1,723,425.57</td>
</tr>
</tbody>
</table>

**Procedure:** How to Display Measure Data Using Aggregation Options in a Report

You can display numeric measure data using a variety of aggregation type values other than the default of Sum.

1. With a report open, in the Query Design pane, select the numeric measure data source field.

   The Field tab appears on the ribbon.

2. Access the Aggregation Functions menu by doing one of the following:

   - From the Display group, click Aggregation.
   - Right-click the selected measure field and click More Aggregation Functions.

   The Aggregation Functions menu opens. It contains the following options:

   - Sum
   - Average
   - Count
- Count Distinct
- Percent of Count
- First Value
- Last Value
- Maximum
- Minimum
- Total
- Percent
- Row Percent
- Average Square

If you change the Measure field container from Sum to Print, Count, or List, it overrides all assigned aggregation type values.

The following image is an example of the MIN (minimum), MAX (maximum), and AVE (average) aggregation prefix operators added to measure fields in the Query Design pane.
The following image is an example of report output produced by assigning the Minimum and Maximum aggregation options to measure fields in a report.

<table>
<thead>
<tr>
<th>Region</th>
<th>Product Category</th>
<th>MIN Quantity Sold</th>
<th>MAX Quantity Sold</th>
</tr>
</thead>
<tbody>
<tr>
<td>Central</td>
<td>Stereo Systems</td>
<td>1</td>
<td>4</td>
</tr>
<tr>
<td></td>
<td>Televisions</td>
<td>1</td>
<td>4</td>
</tr>
<tr>
<td></td>
<td>Video Players</td>
<td>1</td>
<td>4</td>
</tr>
<tr>
<td></td>
<td>Video Production</td>
<td>1</td>
<td>4</td>
</tr>
<tr>
<td>MidEast</td>
<td>Stereo Systems</td>
<td>1</td>
<td>4</td>
</tr>
<tr>
<td></td>
<td>Televisions</td>
<td>1</td>
<td>4</td>
</tr>
<tr>
<td></td>
<td>Video Players</td>
<td>1</td>
<td>4</td>
</tr>
<tr>
<td></td>
<td>Video Production</td>
<td>1</td>
<td>4</td>
</tr>
<tr>
<td>NorthEast</td>
<td>Stereo Systems</td>
<td>1</td>
<td>4</td>
</tr>
<tr>
<td></td>
<td>Televisions</td>
<td>1</td>
<td>4</td>
</tr>
<tr>
<td></td>
<td>Video Players</td>
<td>1</td>
<td>4</td>
</tr>
<tr>
<td></td>
<td>Video Production</td>
<td>1</td>
<td>4</td>
</tr>
</tbody>
</table>

**Procedure:** How to Display Repeated Sort Values in a Report

Run this procedure when the output format, Excel, for example, does not sort properly.

On the Format tab, in the Features group, click Repeat Sort Value.

When you click Repeat Sort Value, all repeated sort values appear in the report output. This option overrides the default behavior, which displays blanks after the first instance of each new sort value that appears in the report.
The first image shows a report before Repeat Sort Value is applied.

<table>
<thead>
<tr>
<th>Region</th>
<th>Product Category</th>
<th>Quantity Sold</th>
</tr>
</thead>
<tbody>
<tr>
<td>Central</td>
<td>Stereo Systems</td>
<td>11,143</td>
</tr>
<tr>
<td></td>
<td>Televisions</td>
<td>7,428</td>
</tr>
<tr>
<td></td>
<td>Video Players</td>
<td>11,647</td>
</tr>
<tr>
<td></td>
<td>Video Production</td>
<td>2,245</td>
</tr>
<tr>
<td>MidEast</td>
<td>Stereo Systems</td>
<td>4,607</td>
</tr>
<tr>
<td></td>
<td>Televisions</td>
<td>3,246</td>
</tr>
<tr>
<td></td>
<td>Video Players</td>
<td>5,043</td>
</tr>
<tr>
<td></td>
<td>Video Production</td>
<td>955</td>
</tr>
<tr>
<td>NorthEast</td>
<td>Stereo Systems</td>
<td>8,735</td>
</tr>
<tr>
<td></td>
<td>Televisions</td>
<td>5,578</td>
</tr>
<tr>
<td></td>
<td>Video Players</td>
<td>9,057</td>
</tr>
<tr>
<td></td>
<td>Video Production</td>
<td>1,738</td>
</tr>
</tbody>
</table>

The second image shows the same report with Repeat Sort Value applied.
Procedure: How to Recalculate the Result of a Compute Command

For more information on the compute command, see Calculation Group on page 62.

1. With a report open, in the Query Design pane, select a By (sort) field.
   The Field tab appears on the ribbon.

2. You can recalculate the result of a Compute command in one of the following ways:
   - **Ribbon:** On the Field tab, in the Break group, open the Subtotal menu. On the menu, click Recomputed.
   - **Right-Click Menu:** Right-click a sort field, point to Break, then Subtotal, and then click Recomputed.

   **Note:** Recompute is not available for Across fields.

Creating Customized Report Outputs

**How to:**
Create OLAP Reports
Create Table of Contents Reports
Freeze Column Titles in a Report
Create Pages On Demand Reports
Create Accordion Reports
Implement Stack Measures

In addition to HTML, active report, active Flash, PDF, active PDF, Excel, and PowerPoint output formats, you can create the following custom report output formats.

- **OLAP.** To view output with OLAP functionality. For more information, see How to Create OLAP Reports on page 171.

- **Table of Contents.** To view output for individual values of the first sort (By) field, one value at a time. For more information, see How to Create Table of Contents Reports on page 173.

- **Freeze.** To view output with column titles that freeze (remain in view) when you scroll through pages of the report output. For more information, see How to Freeze Column Titles in a Report on page 175.
- **Pages On Demand.** To view output, one page at a time, and use a menu bar at the bottom of the report output, from which you can view any specific page. You can also click an arrow to move forward a page, move backward a page, go to the first page, or go to the last page. For more information, see *How to Create Pages On Demand Reports* on page 176.

- **Accordion.** To view output that is expandable for each vertical sort field. This option displays data values only for the first vertical sort field when you first view the output. You can manually expand your view to expose the data values of lower-level sort fields. For more information, see *How to Create Accordion Reports* on page 177.

**Procedure:**  **How to Create OLAP Reports**

1. On the Format tab, in the Navigation group, click the *Auto Drill & Analysis* down arrow. The Auto Drill & Analysis menu opens. It contains the following options:

   - **OLAP panel not accessible.** (Default) Select this option to only display sorting options in the column titles. The OCP (OLAP ribbon) cannot be accessed from the title options.

   - **OLAP panel accessible.** Select this option to access the OLAP panel using the Auto Drill & Analysis button in the output of the report.

     **Note:** Using this option versus the hidden option allows the user to better distinguish the difference between the first and second options. The hidden option is available by accessing the Navigation dialog box.

   - **Dimension filtering enabled.** Select this option to display dimension filters at the top of the report. You customize the filter placement within the Navigation dialog box. You access the dialog box by clicking *More options*.

   - **Dimensions grouped in tabs.** Select this option to group dimension filters in tabs based on hierarchy within statements in the metadata.

   - **More Options.** Select this option to open the Auto Drill & Analysis dialog box, as shown in the following image.
In addition to the options discussed previously, the Auto Drill & Analysis dialog box allows the following additional configuration and customization options for OLAP output:

- **Hide access to the OLAP panel.** Select this option to hide access to the OLAP panel.

- **Dimension filtering enabled.** This option provides a secondary positioning option allowing placement of the filters on the Top (default) or Bottom of the report.
  
  **Note:** If the Dimension filtering enabled option is cleared at any time, the position option resets to Top.

- **Auto drill options.** The auto drill options are:
  
  - **Dimensions.** Select this option to automatically drill down on dimensions in both reports and graphs.
  
  - **Dimensions and Measures.** (Default). Select this option to automatically drill down on dimensions in both reports and graphs and, on measures in reports.
  
  - **None.** Select this option to disable automatic drill downs.

2. Select an option.
Selecting an option from the OLAP group, such as OLAP panel is accessible, generates output that invokes OLAP processing. The following image is an example of an OLAP report. The OLAP button below the report, when clicked, launches the OLAP ribbon.

![OLAP Report Example](image)

**Procedure: How to Create Table of Contents Reports**

**Note:** You cannot use the Table of Contents with the Accordion feature.

1. Create a report.
2. On the Format tab, in the Navigation group, click Table of Contents.

A table of contents button appears in the top-left corner of the report output, as shown in the following image.

![Table of Contents Example](image)
3. Double-click the button to display the Table of Contents menu, shown in the following image. The Table of Contents menu enables you to select and view individual values of the first sort (By) field, one value at a time.

![Table of Contents](image)

Drag the Table of Contents menu in any direction to view the report output, which appears behind the menu by default.

![Report Output](image)
Select a sort field to view values for that field. In the following example, clicking NorthEast displays the corresponding report output.

![Table of Contents](image)

You can also select options to view the entire report or remove the table of contents.

**Procedure: How to Freeze Column Titles in a Report**

On the Format tab, in the Navigation group, click Freeze.

Column titles freeze (remain in view) when you scroll through pages of the report output.
The following image shows the scroll bar that appears when you freeze column titles.

<table>
<thead>
<tr>
<th>Region</th>
<th>Product Category</th>
<th>Quantity Sold</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Subtotal: Central</td>
<td></td>
<td>32,463</td>
<td>19,160,774.07</td>
</tr>
<tr>
<td>MidWest</td>
<td>Stereo Systems</td>
<td>4,607</td>
<td>1,254,014.44</td>
</tr>
<tr>
<td></td>
<td>Televisions</td>
<td>3,246</td>
<td>4,256,202.11</td>
</tr>
<tr>
<td></td>
<td>Video Players</td>
<td>5,043</td>
<td>1,653,244.82</td>
</tr>
<tr>
<td></td>
<td>Video Production</td>
<td>955</td>
<td>896,178.80</td>
</tr>
<tr>
<td>Subtotal: MidWest</td>
<td></td>
<td>13,851</td>
<td>8,059,640.17</td>
</tr>
<tr>
<td>NorthEast</td>
<td>Stereo Systems</td>
<td>8,735</td>
<td>2,381,435.14</td>
</tr>
<tr>
<td></td>
<td>Televisions</td>
<td>5,578</td>
<td>7,452,259.19</td>
</tr>
<tr>
<td></td>
<td>Video Players</td>
<td>9,057</td>
<td>2,980,605.73</td>
</tr>
<tr>
<td></td>
<td>Video Production</td>
<td>1,738</td>
<td>1,723,425.57</td>
</tr>
<tr>
<td>Subtotal: NorthEast</td>
<td></td>
<td>25,108</td>
<td>14,537,725.63</td>
</tr>
<tr>
<td>NorthWest</td>
<td>Stereo Systems</td>
<td>7,287</td>
<td>2,043,976.10</td>
</tr>
<tr>
<td></td>
<td>Televisions</td>
<td>5,029</td>
<td>6,713,008.94</td>
</tr>
<tr>
<td></td>
<td>Video Players</td>
<td>7,869</td>
<td>2,602,775.63</td>
</tr>
<tr>
<td></td>
<td>Video Production</td>
<td>1,517</td>
<td>1,429,375.13</td>
</tr>
<tr>
<td>Subtotal: NorthWest</td>
<td></td>
<td>21,702</td>
<td>12,789,135.80</td>
</tr>
<tr>
<td>SouthEast</td>
<td>Stereo Systems</td>
<td>7,431</td>
<td>2,034,149.11</td>
</tr>
<tr>
<td></td>
<td>Televisions</td>
<td>5,031</td>
<td>6,793,602.47</td>
</tr>
<tr>
<td></td>
<td>Video Players</td>
<td>7,657</td>
<td>2,500,094.24</td>
</tr>
</tbody>
</table>

**Procedure:** How to Create Pages On Demand Reports

On the Format tab, in the Navigation group, click Pages On Demand.

One page of output appears at a time. This option provides a menu bar at the bottom of the report output that you can use to view additional pages of output. The menu bar is shown in the following image.
Procedure: How to Create Accordion Reports

Note: You cannot use the Table of Contents in conjunction with the Accordion feature.

1. Create a report.

The following image shows a chart before the accordion option is applied.

2. On the Format tab, in the Features group, click Accordion.
Plus signs, shown in the following image, indicate that there are expandable views of data for each vertical sort field.

<table>
<thead>
<tr>
<th></th>
<th>Quantity Sold</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Stereo Systems</strong></td>
<td>47,673</td>
</tr>
<tr>
<td><strong>Televisions</strong></td>
<td>31,948</td>
</tr>
<tr>
<td><strong>Video Players</strong></td>
<td>50,181</td>
</tr>
</tbody>
</table>

You can manually expand your view to expose the data, as shown in the following image.

<table>
<thead>
<tr>
<th></th>
<th>Quantity Sold</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Central</strong></td>
<td>11,647</td>
</tr>
<tr>
<td><strong>MidEast</strong></td>
<td>5,043</td>
</tr>
<tr>
<td><strong>NorthEast</strong></td>
<td>9,057</td>
</tr>
<tr>
<td><strong>NorthWest</strong></td>
<td>7,869</td>
</tr>
<tr>
<td><strong>SouthEast</strong></td>
<td>7,657</td>
</tr>
<tr>
<td><strong>SouthWest</strong></td>
<td>2,038</td>
</tr>
<tr>
<td><strong>West</strong></td>
<td>6,870</td>
</tr>
</tbody>
</table>

**Procedure: How to Implement Stack Measures**

On the Format tab, in the Features group, click Stack Measures.

All measures on the report are stacked.
The following image shows a report in Live Preview before the Stack Measures option is enabled.

<table>
<thead>
<tr>
<th>Product Category</th>
<th>Region</th>
<th>Quantity</th>
<th>Revenue</th>
<th>Region</th>
<th>Quantity</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Central</td>
<td>Sold</td>
<td>Sold</td>
<td>Central</td>
<td>Sold</td>
<td>Sold</td>
</tr>
<tr>
<td>Stereo Systems</td>
<td>11,143</td>
<td>3,027,726.42</td>
<td>4,607</td>
<td>1,254,014.44</td>
<td>8,735</td>
<td>2,381,435.14</td>
</tr>
<tr>
<td>Televisions</td>
<td>7,428</td>
<td>10,131,328.09</td>
<td>3,246</td>
<td>4,256,202.11</td>
<td>5,578</td>
<td>7,452,259.19</td>
</tr>
<tr>
<td>Video Players</td>
<td>11,647</td>
<td>3,835,578.36</td>
<td>5,043</td>
<td>1,653,244.82</td>
<td>9,057</td>
<td>2,980,605.73</td>
</tr>
</tbody>
</table>

The following image shows a report in Live Preview after the Stack Measures option is enabled.

<table>
<thead>
<tr>
<th>Product Category</th>
<th>Region</th>
<th>MidEast</th>
<th>NorthEast</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Central</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Stereo Systems</td>
<td>11,143</td>
<td>4,607</td>
<td>8,735</td>
</tr>
<tr>
<td>Televisions</td>
<td>7,428</td>
<td>3,246</td>
<td>5,578</td>
</tr>
<tr>
<td>Video Players</td>
<td>11,647</td>
<td>5,043</td>
<td>9,057</td>
</tr>
<tr>
<td></td>
<td>Quantity Sold</td>
<td>Revenue</td>
<td>Quantity Sold</td>
</tr>
</tbody>
</table>
Creating and Customizing Charts

InfoAssist enables you to easily create different types of simple and complex charts. You can select from a variety of chart types and output formats, and add custom features to a chart.

You can also create a chart from any existing report in InfoAssist.

**Topics:**

- Visualizing Your Data With Charts
- Selecting a Chart
- Creating a Chart
- Accessing Chart Formatting Tools
- Formatting a Series
- Formatting Data Labels
- Formatting a Legend
- Formatting Gridlines
- Formatting Axis Labels
- Formatting a Frame and a Background
- Formatting a Gauge Chart
- Formatting Page Headings and Page Footings
- Using Additional Formatting Features
Visualizing Your Data With Charts

A chart often conveys meaning more clearly and effectively than data displayed in tabular form. A chart enables you to visually communicate quantitative information. On a chart, you can give data a shape and form, and reveal patterns and relationships among many data values. A chart can highlight anomalies that require further investigation. These are some things to consider when deciding between a report and a chart for your data.

Use a Table to:
- Look up individual values.
- Compare individual values.
- Use values precisely.

Use a Chart to:
- Show overall shape of values.
- Show relationship among multiple values using patterns and trends.

<table>
<thead>
<tr>
<th>Degree Type</th>
<th>Customer Income Range</th>
</tr>
</thead>
<tbody>
<tr>
<td>Associate Degree</td>
<td></td>
</tr>
<tr>
<td>A: $0 TO $24,999</td>
<td></td>
</tr>
<tr>
<td>B: $25,000 TO $49,999</td>
<td></td>
</tr>
<tr>
<td>C: $50,000 TO $74,999</td>
<td></td>
</tr>
<tr>
<td>D: $75,000 TO $99,999</td>
<td></td>
</tr>
<tr>
<td>E: $100,000 OR MORE</td>
<td></td>
</tr>
<tr>
<td>Bachelor's Degree</td>
<td></td>
</tr>
<tr>
<td>B: $25,000 TO $49,999</td>
<td></td>
</tr>
<tr>
<td>C: $50,000 TO $74,999</td>
<td></td>
</tr>
<tr>
<td>D: $75,000 TO $99,999</td>
<td></td>
</tr>
<tr>
<td>E: $100,000 OR MORE</td>
<td></td>
</tr>
<tr>
<td>Master's Degrees</td>
<td></td>
</tr>
<tr>
<td>A: $0 TO $24,999</td>
<td></td>
</tr>
<tr>
<td>B: $25,000 TO $49,999</td>
<td></td>
</tr>
<tr>
<td>C: $50,000 TO $74,999</td>
<td></td>
</tr>
<tr>
<td>D: $75,000 TO $99,999</td>
<td></td>
</tr>
<tr>
<td>E: $100,000 OR MORE</td>
<td></td>
</tr>
</tbody>
</table>
Selecting a Chart

In this section:
- Bar Charts
- Pie Charts
- Line Charts
- Area Charts
- Multi-Axis Charts
- XY Plot Charts
- 3D Charts
- Stock Charts
- Special Charts
- Combination Charts

It is important that you choose a chart that is appropriate for your data. InfoAssist provides a complete chart library of both basic and advanced charts. You can choose from a wide variety of charts to best represent the data that you want to display.

Bar Charts

In this section:
- Bar Chart Types

Bar charts plot numerical data by displaying rectangular blocks against a scale (numbers or variable measures that appear along the axis). The length of a bar corresponds to a value or amount. You can clearly compare data series (fields) by the relative heights of the bars. Use a bar chart to display the distribution of numerical data. You can create horizontal and vertical bar charts.
**When to use:** Use a bar chart when individual values are important. For example, the following image is a basic *vertical bar chart* that compares the individual products sold to the total amount in sales for each product. A retailer would find it important to know which pieces of inventory are selling and how much revenue each item is generating for the company.
A horizontal bar chart becomes useful when you want to emphasize a ranking relationship in descending order, or the X-axis labels are too long to fit legibly side-by-side. For example, the following image is a basic horizontal bar chart that ranks in descending order which products are generating the most revenue for the retailer.

![Horizontal Bar Chart Example](image)

**Bar Chart Types**

The following table lists the available bar chart types.

<table>
<thead>
<tr>
<th>Available Bar Chart Types</th>
<th>Horizontal Bar Chart Types</th>
</tr>
</thead>
<tbody>
<tr>
<td>Vertical Clustered Bar</td>
<td>Horizontal Clustered Bar</td>
</tr>
<tr>
<td>Vertical Stacked Bar</td>
<td>Horizontal Stacked Bar</td>
</tr>
<tr>
<td>Vertical Dual-Axis Clustered Bar</td>
<td>Horizontal Dual-Axis Clustered Bar</td>
</tr>
<tr>
<td>Vertical Dual-Axis Stacked Bar</td>
<td>Horizontal Dual-Axis Stacked Bar</td>
</tr>
<tr>
<td>Vertical Bi-Polar Clustered Bar (Not in HTML5)</td>
<td>Horizontal Bi-Polar Clustered Bar (Not in HTML5)</td>
</tr>
<tr>
<td>Vertical Bi-Polar Stacked Bar (Not in HTML5)</td>
<td>Horizontal Bi-Polar Stacked Bar (Not in HTML5)</td>
</tr>
<tr>
<td>Vertical Percent Bar</td>
<td>Horizontal Percent Bar</td>
</tr>
</tbody>
</table>
### Available Bar Chart Types

<table>
<thead>
<tr>
<th>Vertical Histogram</th>
<th>Horizontal Histogram</th>
</tr>
</thead>
<tbody>
<tr>
<td>Vertical Waterfall</td>
<td>Horizontal Waterfall</td>
</tr>
<tr>
<td>Vertical Multi-3Y Bar (Not in HTML5)</td>
<td>Vertical Multi-5Y Bar (Not in HTML5)</td>
</tr>
<tr>
<td>Vertical Multi-4Y Bar (Not in HTML5)</td>
<td>Error Bar</td>
</tr>
</tbody>
</table>

### Pie Charts

**In this section:**

- Pie Chart Types

A pie chart is a circular chart that represents parts of a whole. A pie chart emphasizes where your data fits, in relation to a larger whole. Pie charts work best when the data consists of several large segments. As a best practice, limit your pie chart to five measures. Too many measures can divide a pie into many thin "slices" that could become difficult to see. Use color on individual segments to create visual contrast.

**Note:** You cannot plot negative data on a pie chart.
**When to use:** Use a pie chart when you have several large segments of data that you want to display as a whole. For example, the following image is a pie chart that shows the educational background of the customers of a retailer.

![Pie Chart Example](image)

**Pie Chart Types**

The following table lists the available pie chart types.

<table>
<thead>
<tr>
<th>Available Pie Chart Types</th>
</tr>
</thead>
<tbody>
<tr>
<td>Multi Pie</td>
</tr>
<tr>
<td>Multi Ring Pie</td>
</tr>
<tr>
<td>Multi Proportional Pie (Not in HTML5)</td>
</tr>
<tr>
<td>Multi Proportional Ring Pie (Not in HTML5)</td>
</tr>
<tr>
<td>Single Pie</td>
</tr>
<tr>
<td>Single Ring Pie</td>
</tr>
<tr>
<td>Pie-Bar (Not in HTML5)</td>
</tr>
<tr>
<td>Ring Pie-Bar (Not in HTML5)</td>
</tr>
</tbody>
</table>
Line Charts

In this section:

Line Chart Types

Line charts are useful for emphasizing the movement or trend of numerical data over time. They allow you to trace the evolution of a data point by working backwards or interpolating. Highs and lows, rapid or slow movement, or a tendency towards stability are all types of trends well suited to a line chart.

You can also plot line charts with two or more scales to present a comparison of the same value, or set of values, in different time periods.

When to use: Use a line chart when you want to trend data over time, for example monthly changes in employment figures, or yearly sales of an item in your inventory. For example, the following image is a line chart that traces gross profit in sales for four products over a four-year period.

Radar charts are essentially analogous to line charts, except that the scale wraps around. Radar charts compare two or more data sets. They work well with data that is cyclical, such as the months of a year. A radar line chart is available in the line chart category, and a radar area chart is available in the area chart category. You can use axes or polygons to represent values in a star or spider configuration.
**Line Chart Types**

The following table lists the available line chart types.

<table>
<thead>
<tr>
<th>Available Line Chart Types</th>
</tr>
</thead>
<tbody>
<tr>
<td>Vertical Absolute Line</td>
</tr>
<tr>
<td>Vertical Stacked Line</td>
</tr>
<tr>
<td>Vertical Dual-Axis Absolute Line</td>
</tr>
<tr>
<td>Vertical Dual-Axis Stacked Line</td>
</tr>
<tr>
<td>Vertical Bi-Polar Absolute Line (Not in HTML5)</td>
</tr>
<tr>
<td>Vertical Bi-Polar Stacked Line (Not in HTML5)</td>
</tr>
<tr>
<td>Vertical Percent Line</td>
</tr>
<tr>
<td>Radar Line</td>
</tr>
</tbody>
</table>

**Area Charts**

**In this section:**

Area Chart Types

Area charts are similar to line charts except that the area between the data line and zero line (or axis) is usually filled with color. Area charts allow you to stack data on top of each other. Stacking allows you to highlight the relationship between data series, showing how some data series approach a second series.
When to Use: Use an area chart when you want to distinguish the data more dramatically by highlighting volume with color. For example, the following image is a basic area chart that depicts the price and product cost for four products. The data is more boldly distinguished on this chart in comparison to the line chart.

Area Chart Types

The following table lists the available area chart types.

<table>
<thead>
<tr>
<th>Available Area Chart Types</th>
<th>Horizontal Absolute Area</th>
</tr>
</thead>
<tbody>
<tr>
<td>Vertical Absolute Area</td>
<td>Horizontal Absolute Area</td>
</tr>
<tr>
<td>Vertical Stacked Area</td>
<td>Horizontal Stacked Area</td>
</tr>
<tr>
<td>Vertical Bi-Polar Absolute Area (Not in HTML5)</td>
<td>Horizontal Bi-Polar Absolute Area (Not in HTML5)</td>
</tr>
<tr>
<td>Vertical Bi-Polar Stacked Area (Not in HTML5)</td>
<td>Horizontal Bi-Polar Stacked Area (Not in HTML5)</td>
</tr>
<tr>
<td>Vertical Percent Area</td>
<td>Horizontal Percent Area</td>
</tr>
<tr>
<td>Radar Area</td>
<td></td>
</tr>
</tbody>
</table>
Multi-Axis Charts

Bar, line, and area chart types have multi-axis options, such as dual-axis charts and multi-Y charts, where you can compare one X-axis value to several Y-axis measures.

InfoAssist allows you to assign each individual series to the Y1 through Y5 axis. For more information, see How to Create a Dual-Axis Chart on page 202.

**When to use:** Use a multi-axis chart when you want to plot values on an additional axis, or multiple axes, to compare multiple sets of data that are on different scales. For example, the following image is a dual-axis chart that shows the quantity of inventory pieces sold and the revenue that their sales generate.

XY Plot Charts

**In this section:**

- XY Plot Chart Types

An XY plot chart depicts the relationships among the numeric values in several data series. It plots two groups of numbers, where for every X value, there is a corresponding Y value. This results in a single point of XY coordinate.

**When to use:** Use XY plot charts when you have two sets of numbers to compare and want to perform trend analysis.

- **Scatter.** Scatter charts show a relationship between X and Y values. They compare two sets of numbers at once, possibly revealing patterns and trends.
You can plot data using variable scales on both axes. When you use a scatter chart, the data is plotted with a basic line pattern so that you can visualize the density of individual data values around particular points, or discern patterns in the data. A numeric X axis, or sort field, always yields a scatter chart by default.

If your chart reveals clouds of points, there is a strong relationship between X and Y values. If data points are scattered, there is a weak or no relationship.

Scatter charts share many of the characteristics of basic line charts. Scatter charts and line charts are distinguishable from one another only by virtue of their X-axis format. Line charts can appear without connecting lines, making them look like scatter charts, and scatter charts can appear with connecting lines, making them look like line charts.
Polar. A polar chart is a circular chart. Data is displayed on a polar chart in terms of values and angles. Polar charts share characteristics with scatter charts. Only one column field is allowed, in the following order: X (degree) for the column field, and Y (distance from the center) for the Across or By field.
Bubble. A bubble chart is a chart in which the data points are represented by bubbles. Bubble charts can have two column fields representing X and Y data values, or have three column fields representing X, Y, and Z data values, in that order. The third variable (Z) represents size. The size of each bubble is used to show the relative importance of the data.

**XY Plot Chart Types**

The following table lists the available XY plot chart types.

<table>
<thead>
<tr>
<th>Available XY Plot Chart Types</th>
</tr>
</thead>
<tbody>
<tr>
<td>XY Scatter</td>
</tr>
<tr>
<td>Bubble</td>
</tr>
</tbody>
</table>
3D Charts

In this section:
3D Chart Types

A 3D chart uses three axes, X, Y, and Z to display data from two or more data sets so that trends are most apparent. For example, the following image is a 3D chart that shows the cost and revenue for four products.

When to use: Use a 3D bar chart when you want to look at the general shape of the data, but add visual depth to a chart presentation. A 3D chart would not be a good choice for presenting exact values, since it is difficult to determine values in a 3D chart.

3D Chart Types

The following table lists the available 3D chart types.

<table>
<thead>
<tr>
<th>Available 3D Chart Types</th>
</tr>
</thead>
<tbody>
<tr>
<td>3D Bar</td>
</tr>
<tr>
<td>3D Octagon (Not in HTML5)</td>
</tr>
<tr>
<td>3D Floating Cubes (Not in HTML5)</td>
</tr>
<tr>
<td>3D Pyramid (Not in HTML5)</td>
</tr>
<tr>
<td>3D Cylinder (Not in HTML5)</td>
</tr>
<tr>
<td>3D Floating Pyramids (Not in HTML5)</td>
</tr>
</tbody>
</table>
### Available 3D Chart Types

<table>
<thead>
<tr>
<th>Chart Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>3D Connected Series Area</td>
<td>3D Connected Series Ribbon</td>
</tr>
<tr>
<td>3D Connected Group Area</td>
<td>3D Connected Group Ribbon</td>
</tr>
<tr>
<td>3D Cone (Not in HTML5)</td>
<td>3D Sphere (Not in HTML5)</td>
</tr>
<tr>
<td>3D Surface</td>
<td>3D Surface with Sides (Not in HTML5)</td>
</tr>
<tr>
<td>3D Smooth Surface (Not in HTML5)</td>
<td>3D Smooth Surface with Sides (Not in HTML5)</td>
</tr>
<tr>
<td>3D Honeycomb Surface (Not in HTML5)</td>
<td></td>
</tr>
</tbody>
</table>

### Stock Charts

#### In this section:

**Stock Chart Types**

Stock charts track the trend of a particular stock. They show the trading volume of the stock, its opening and closing values, and its high and low values over a specific time period. The data is represented by sets of bars or lines.
Stock Chart Types

The following table lists the available stock chart types.

<table>
<thead>
<tr>
<th>Available Stock Chart Types</th>
</tr>
</thead>
<tbody>
<tr>
<td>Stock Hi-Lo (Not in HTML5)</td>
</tr>
<tr>
<td>Stock Hi-Lo with Volume (Not in HTML5)</td>
</tr>
<tr>
<td>Stock Hi-Lo Open-Close (Not in HTML5)</td>
</tr>
<tr>
<td>Stock Hi-Lo Open-Close with Volume (Not in HTML5)</td>
</tr>
<tr>
<td>Open-Hi-Lo-Close Candle Stock</td>
</tr>
<tr>
<td>Open-Hi-Lo-Close Candle Stock with Volume (Not in HTML5)</td>
</tr>
</tbody>
</table>

**Special Charts**

Special charts include a variety of additional chart types.

- **Gauge.** A gauge chart indicates the current position of a single data value within a given spectrum. This chart has a circular shape.

- **Gauge Thermometer.** A gauge thermometer chart indicates the current position of a single data value within a given scale. This chart has the shape of a thermometer. It is not available in HTML5.

- **Pareto.** A Pareto chart uses the X axis to show group members, and the Y axis to show the percent of the total of all groups that each group represents. This chart highlights the differences between groups of data.

- **Vertical Box Plot.** A vertical box plot is oriented vertically, and shows the distribution of data through five-number summaries: Upper limit, Upper Quartile, Median, Lower Quartile, and Lower Limit. This chart can be represented with or without outliers, also known as whiskers.

- **Horizontal Box Plot.** A horizontal box plot is oriented horizontally, and shows the distribution of data through five-number summaries: Upper limit, Upper Quartile, Median, Lower Quartile, and Lower Limit. This chart can be represented with or without outliers, also known as whiskers.

- **Funnel.** A funnel chart is essentially a pie chart, displaying only one group of data at a time, from the first series to the last series at the bottom of the funnel.

- **Pyramid.** A pyramid chart is essentially a pie chart, displaying only one group of data at a time, from the first series to the last series at the top of the pyramid.

- **Spectral Map.** A spectral map contains a row or column matrix of markers that are displayed in different colors, according to the data values.
Combination Charts

A combination chart displays multiple series using two or more different types of data graphics from a bar, line, or an area chart. Combining these charts improves clarity in the presentation of your data, and highlights the relationship between various data sets on one graph. This combination chart is referred to as a mixed, composite, or overlay graph.

**When to use:** For example, a retailer might want to combine a vertical bar chart that shows revenue with a line chart that shows quantity sold.
Creating a Chart

In this section:
Chart Outputs

How to:
Create a Basic Chart
Create an Advanced Chart
Create a Combination Chart
Create a Dual-Axis Chart
Create a Multi-Axis Chart

On the Format tab, the Chart Types group, shown in the following image, provides buttons for each of the five most commonly-used chart types, bar (default), pie, line, area, and scatter. A button labeled Other gives you access to the complete chart library of advanced charts.

Note: For more information on how to invoke the version of InfoAssist that you are using, please see Getting Started With InfoAssist on page 21.

Procedure: How to Create a Basic Chart

You can run this procedure in Query Design view or Live Preview.

1. On the Format tab, in the Chart Types group, click the button of the chart that you want to create. Bar chart is the default.

   The chart appears on the canvas.

2. Populate the chart with your data in one of the following ways:

   - Drag the data dimensions and measures onto the chart.
   - Drag the data dimensions and measures into the appropriate field containers in the Query pane.
Procedure: How to Create an Advanced Chart

You can run this procedure in Query Design view or Live Preview.

1. On the Format tab, in the Chart Types group, click Other.

   The Other Chart Types dialog box opens. Each of the tabs across the top of the dialog box represents a type of chart.

2. To display the name of a chart type, hover over the tab with the mouse.

   From left to right, the chart type categories are Bar, Line, Area, Pie, XY Plots, 3D, Stock, and Special.

3. Click a chart type.

   All supported variations of the chart type appear as thumbnail images in the area underneath.

4. Within the category, click an image to display a detailed description of that chart type.

   If you are not familiar with a chart type, be sure to read the description carefully before finalizing your selection. Some chart types require a certain number of data values, or a certain type of data values. If your data does not satisfy the requirements, the chart will not accurately represent the data.
In the following image, the Pie tab is selected (the fourth tab from the left). Underneath the tab, the pie chart types supported by InfoAssist appear as images. Within the images, the pie chart type is selected, and a description appears underneath.

You can also hover over an image with your mouse to display the chart type name, as shown in the following image.

5. In the Other Chart Types dialog box, click OK to finalize your selection and close the dialog box.

6. Populate the chart with your data in one of the following ways:
Drag the data dimensions and measures onto the chart.

Drag the data dimensions and measures into the appropriate field containers in the Query pane.

Procedure: **How to Create a Combination Chart**

You can run this procedure in Query Design view or Live Preview.

1. On the Format tab, in the Chart Types group, click the button of the chart that you want to create. Bar chart is the default.

   The chart appears on the canvas.

2. Populate the chart with your data in one of the following ways:

   - Drag the data dimensions and measures onto the chart.
   - Drag the data dimensions and measures into the appropriate field containers in the Query pane.

3. Change a series type in one of the following ways:

   - **Ribbon:** On the Series tab, in the Select group, select the series that you want to display in a different chart type. Then, in the Properties group, from the Type drop-down menu, select the chart type.

   - **Right-Click Menu:** Right-click the series that you want to display in a different chart type, point to Series Type, and select the chart type.

   The series appears in the new chart type.

Procedure: **How to Create a Dual-Axis Chart**

When you create a dual-axis chart, you assign one data series to the Y1 axis and another data series to the Y2 axis.

1. Create a chart.

2. On the Format tab, in the Chart Types group, click Other.

   The Other Chart Types dialog box opens.

3. Select a dual-axis chart, such as dual-axis bar, and then click OK.

4. Drag one field onto the Y1 field, and then drag another field onto the Y2 field.
**Procedure:**  **How to Create a Multi-Axis Chart**

When you create a multi-axis chart, you assign one data series to the Y1 axis and another data series to the Y2, Y3, Y4, and Y5 axes (as needed).

1. Create a chart.
2. On the Format tab, in the Chart Types group, click Other.
   - The Other Chart Types dialog box opens.
3. Select a multi-axis chart, and then click OK.
4. Drag fields onto the Y1, Y2, Y3, Y4, and Y5 fields, as needed.

**Chart Outputs**

You can create charts using one of the following output formats:

- HTML
- HTML5
- active report
- active Flash
- PDF
- active PDF
- Excel
- PowerPoint

The HTML5 output format allows you to render a chart in the browser using a built-in JavaScript engine. Charts with this output format utilize the very latest capabilities of the HTML5 Web standard, including animation, high-quality vector output, and attractive alpha-channel and gradient effects.

**Note:** Not every chart type can be output in every format listed here. To make sure that the chart that you are creating can be output in the format that you want, please see the topic for that particular chart type.
Accessing Chart Formatting Tools

In this section:
Identifying Chart Elements
Using Live Preview
Using Right-Click Field Options in the Query Design Pane

Your presentation of data on a chart is successful when it communicates to your audience the message that you intend. InfoAssist helps you meet the needs of your audience and convey your message by providing numerous chart features. For example, you can adjust the appearance of a chart, add layers of information, or customize the labels that identify the data on the chart.

Identifying Chart Elements

The following image identifies the basic elements that you can customize on a chart. The elements that are annotated here are for a vertical bar chart. The available elements and their right-click menu options vary according to the chart that you are creating. **Note:** The 3D effect is not a default setting. It was enabled for the chart in the following image to enhance the appearance of the chart. To access the 3D option, go to the Format tab, and in the Features group, click 3D Effect.

1. Series
2. Data Labels
Using Live Preview

In Live Preview, the canvas on the right of the window provides a preview of the report or chart that you can interact with. The preview is context sensitive, meaning that depending on what portion you select different options become available.

In Live Preview, when you hover the mouse over a graph element (for example, legend, axis label, title), the bounding area is highlighted with a dotted line. In the following image, the legend is highlighted.
In Live Preview, when you select a graph element (for example, legend, axis label, title), the bounding area is highlighted with a solid line. In the following image, the legend is selected.

Once you select a chart element, you can access all available design options on the ribbon, or you can right-click an element to open a right-click menu of frequently-used design options. Once you have selected your design option from the ribbon or the menu, InfoAssist instantly applies it to the chart element, so that you see the result immediately.
This image shows a Live Preview of a bar chart in Live Preview. In this example, the right-click menu for a series (field) element is opened.

Right-click menus are enabled for charts that are generated with either sample data, or live data from your data source.

**Note:** Right-click menus are not available in InfoAssist Basic.

The following sections describe the chart elements, the ribbon options, and the right-click menus that you can work with to design your charts in Live Preview.

### Using Right-Click Field Options in the Query Design Pane

In the Query design pane, you can right-click any field and select from a list of available options that are displayed in the menu that appears. The options that you can select vary, depending on the type of Query field container in which the field is located, and the type of chart that you are creating.

When you create a chart, the Query field containers in the Query Design pane include Measure (Sum), X Axis, Legend (Series), Multi-graph, and Coordinated (for documents only).

Right-clicking a Measure (Sum) field in a chart displays the Filter Values, Sort, Visibility, Change Title, More, and Delete options. You can point to More to access the Aggregation Functions, Traffic Light Conditions, and Missing options.
Right-clicking an X Axis or Legend (Series) field in a chart displays the Filter Values, Sort, Visibility, Change Title, More, and Delete options. You can point to More to access the Missing option.

Right-clicking a Coordinated field or a Multi-graph field in a chart displays only the Delete option.

For more information, see Using Right-Click Field Options in the Query Design Pane on page 108.

**Formatting a Series**

A series is a data source field (measure field) that is included in a chart. You can format a series in a variety of ways. For example, you can change the color of a series, add a trendline to a series, or change the appearance of markers on a series.

You can access the full set of formatting options on the Series tab and Field tab. For more information, see Series Tab on page 95 and Field Tab on page 85.

You can also access a subset of frequently-used options by right-clicking a series element on a chart to open a menu of those options.

**Tip:** The options that you see on the menu depend on the type of chart that you are creating. For example, the Series Type option would not appear on the menu for a pie chart, but it would appear for a bar, line, and area chart.

**Associated Dialog Boxes**

Whether you access series options from the ribbon or the right-click menu, you are presented with a dialog box of options. The following dialog boxes are commonly used for formatting a series:
Format Series
Edit Title
Traffic Light Condition

For Instructions on how to open these dialog boxes, see the procedures in Using Series Properties on page 217.

Format Series Dialog Box

The Format Series dialog box contains options to format the fill and border of each series on a chart.

The Format Series dialog box contains the following tabs:

- Fill
- Border

Use the Fill tab to modify the color of a chart series. The Fill tab is shown in the following image.

The Fill tab contains the following options:

- **No fill.** Select this option to remove the color from the series.
- **Solid fill.** Select this option to display the Color and Transparency options.
- **Color.** Click this icon to open the Color dialog box, where you can select a color for the series.

- **Transparency.** Move the slider to make the bands opaque (0%) or transparent (100%). The default is 0%.

- **Gradient fill.** Select this option to display the direction of the gradient, the color pattern of the gradient, and the degrees of transparency for the two colors that make up the gradient. A gradient is a smooth color transition or blending of one color to another. The number of colors to use in a gradient is defined by the **stop** or **pin** elements.

- **Direction.** Select from this drop-down menu to set the direction of the gradient fill. The options are:
  - Gradient right
  - Gradient left
  - Gradient down
  - Gradient up
  - Gradient down left
  - Gradient up left
  - Gradient down right
  - Gradient up right
  - Radial
  - Radial top left
  - Radial top right
  - Radial bottom left
  - Radial bottom right
  - Radial pie
  - Radial pie inverted
Use the Border tab to specify a border for a chart series. The Border tab is shown in the following image.

![Border tab](image)

The Border tab contains the following options:

- **Show Border Color.** Select this option to show a border color around each series.
- **Border Color.** Click this icon to open the Color dialog box, where you can select a color for the border.

**Edit Title Dialog Box**

The Enter Title dialog box contains a text field in which you can type the title for a series on a chart. Click OK and the title appears on the chart.

![Edit Title dialog box](image)

**Traffic Light Condition Dialog Box**

The Traffic Light Condition dialog box contains fields for adding new conditional styling or modifying existing conditional styling by applying a traffic light color to the selected field.
The Traffic Light Condition dialog box contains the following fields.

- **Relational Operators.** Select from this drop-down menu to set the relational operator. The options are:
  - Equal to
  - Not equal to
  - Greater than
  - Less than
  - Greater than or equal to
  - Less than or equal to

- **Type/Value.** Click this unlabeled field to open a dialog box that contains the following fields:
  - **Type.** Opens a drop-down menu of the following values Constant and Field. Select *Constant* to enter a constant value. Select *Field* to open a visual display of the fields in your data source.
  - **Get Values.** Select from this drop-down menu. The options are:
The visual display of fields is shown in the following image.

The Traffic Light Condition dialog box contains the following buttons:

- **Selected Condition.** Click this icon to select a condition to work on.
- **New.** Creates a new rule.
- **Delete.** Deletes a rule.
- **Color.** Opens the Color dialog box.
Drill Down. Opens the Drill Down dialog box, shown in the following image, where you can drill down to a web page or a URL. Specify the following:

- URL of the web page or location of the report
- An alternate comment
- Target (New Window, Same Window, a value that you enter)
- Parameters that you want to use (Name, Value)

Series Elements Right-Click Menu

When you right-click a series on a chart, a menu of options opens. The menu contains options that are available on the Field and Series tabs.
The menu options are described in the following table. The table provides links to the sections of this document in which those options are also discussed.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Filter Values</td>
<td>Enables you to create or modify a WHERE statement, using the Filter dialog box. With a WHERE statement, you select only the data that you want to display, and exclude unwanted data. For information on filtering your data, see <em>Data Tab</em> on page 62 and <em>Field Tab</em> on page 85.</td>
</tr>
<tr>
<td>Sort</td>
<td>Enables you to sort the series in either ascending or descending order.</td>
</tr>
<tr>
<td>Visibility</td>
<td>Controls the display of the selected series (field) on a chart. The value Hide suppresses the display of the series, and the default value Show displays the series. For instructions, see <em>How to Hide a Field in a Series</em> on page 231.</td>
</tr>
<tr>
<td>Change Title</td>
<td>Enables you to edit the title of the selected series. In the Edit Title dialog box, type the new title in the Enter Title field, and click OK. For instructions, see <em>How to Change the Title of a Series</em> on page 239.</td>
</tr>
<tr>
<td>Series Type</td>
<td>Changes the chart type of the selected series to bar, line, or area. The option None (default) returns the series to the chart type that was in effect before you changed it. This option applies to bar, line, and area chart types only. For instructions, see <em>How to Change the Type of a Series</em> on page 218.</td>
</tr>
<tr>
<td>Series Color</td>
<td>Enables you to specify the color of the selected series, using the Color dialog box. For more information, see <em>Color Dialog Box</em> on page 46.</td>
</tr>
<tr>
<td>More Style Options</td>
<td>Opens the Format Series dialog box. For more information, see <em>Format Series Dialog Box</em> on page 209.</td>
</tr>
</tbody>
</table>
## Formatting a Series

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data Labels</td>
<td>Controls the display of data labels (values) on the selected series. The default value Hide suppresses the display of labels, and the value Show displays labels. This option does not apply to the gauge chart type. For instructions, see <em>How to Show and Hide Data Labels</em> on page 254.</td>
</tr>
<tr>
<td>Color Mode</td>
<td>Controls how color is applied to a series (measure field) on a chart. The possible settings are By Series (default) and By Group. For example, assume that there is only one series on a sample bar chart. The By Series setting applies the same color to all the bars in the series. The By Group setting applies a different color to each bar. For instructions, see <em>How to Control the Color Mode</em> on page 241.</td>
</tr>
<tr>
<td>Add Trendline</td>
<td>Draws a line on a chart to indicate a statistical trend. This option does not apply to the pie, funnel, 3D, gauge, or stock chart type. For an example of a chart with a trendline, see <em>How to Add a Trendline</em> on page 219.</td>
</tr>
</tbody>
</table>
| More          | Contains the Aggregation Functions, Traffic Light Conditions, and Missing options.

Aggregation Functions assigns an aggregation value to a numeric measure field in a report. For instructions, see *How to Display Aggregations on Measures* on page 233.

Traffic Light Conditions enables you to specify the color of numeric measure fields in the output, depending on conditions that you set. You can use the Traffic Light Condition dialog box to specify the conditions and colors.

For instructions, see *How to Apply Traffic Light Conditions With Drill-Down to a Numeric Measure Field (By Constant)* on page 235 and *How to Apply Traffic Light Conditions With Drill-Down to a Numeric Measure Field (By Field)* on page 238.

The Missing option allows you to show or hide fields with no value.
<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Delete</td>
<td>Removes the selected series from the report and updates the Live Preview accordingly.</td>
</tr>
</tbody>
</table>

### Using Series Properties

**In this section:**
- Series Tab Select Group
- Series Tab Style Group
- Series Tab Properties Group
- Series Tab Line Group
- Series Tab Pie Group
- Series Tab Display Group
- Field Tab Filter Group
- Field Tab Sort Group
- Field Tab Display Group

The following sections contain procedures for customizing a series. The procedures are organized by the tab and group in which their associated options appear on the ribbon.

**Series Tab Select Group**

**How to:**
- Select a Series

**Procedure: How to Select a Series**

1. Create a chart.
2. On the Series tab, in the Select group drop-down menu, select the Series that you want to customize.
   
   The Series appears in the drop-down menu field.
Series Tab Style Group

How to: Format the Fill and Border of a Series

Procedure: How to Format the Fill and Border of a Series

1. Create a chart.
2. Open the Format Series dialog box in one of the following ways:
   - **Ribbon**: On the Series tab, in the Style group, click **Style**.
   - **Right-Click Menu**: Right-click a series on the chart, and select **More Style Options**.
     The Format Series dialog box opens.
3. Use the fill and border options to format the series.
   For more information, see *Format Series Dialog Box* on page 209.
4. Click **OK** to close the dialog box.
   The Format Series dialog box closes. The series fill and border are formatted accordingly.
5. Click **Run** to generate the report.

Series Tab Properties Group

How to: Change the Type of a Series

Procedure: How to Change the Type of a Series

1. Create a bar, line, or area chart.
2. Access the list of series types in one of the following ways:
   - **Ribbon**: On the Series tab, in the Properties group, open the **Type** drop-down menu.
   - **Right-Click Menu**: Right-click a series on the chart, and point to **Series Type**.
3. Select the type that you want the series to become.
   The chart contains the new series type.
**Procedure: How to Add a Trendline**

A trendline is a line that is drawn over the plot area of a chart to show the pattern of the data points. The pattern reveals a statistical trend.

**Note:** Linear regression trendlines are not available for bubble charts in HTML5.

1. Create a chart.
2. Access the menu of trendline types in one of the following ways:
   - **Ribbon:** On the Series tab, in the Properties group, open the *Trendline* drop-down menu.
   - **Right-Click Menu:** Right-click a series on the chart, and point to *Add Trendline*.
3. Select the type of trendline that you want to display.
   The trendline appears on the chart.
4. Optionally, to display the mathematical equation for the selected trendline option, on the Series tab, in the Properties group, click *Equation*.
   The following image shows a trendline that appears with the Linear option.
How to: Apply Smooth Line Effect to a Line Chart
Hide a Series Line Between Markers
Change the Appearance of a Marker

Procedure: How to Apply Smooth Line Effect to a Line Chart

1. Create a line chart without a smooth line effect.
   The following image shows a chart without the smooth line effect.

2. Select a series on the line chart.
The Smooth Line effect is applied to the series, as shown in the following image.

![Line Chart Example](image1.png)

**Procedure:** How to Hide a Series Line Between Markers

Lines appear between markers by default, as shown in the following image.

![Line Chart Example](image2.png)

To hide a series line between a marker follow these steps:
1. Create a line chart.

2. Select a series on the line chart.

3. On the Series tab, in the Series Group drop-down menu, select the series that you want to hide.

4. In the Line Group, click Connect Lines.

   The series line between the markers disappears, as shown in the following image.

   ![Line Chart Image]

   To make the series line reappear, click Connect Lines again.

**Procedure: How to Change the Appearance of a Marker**

Markers are used to display points of data on a line chart. They are also used in the legend to identify the data that is on the chart. The different marker shapes distinguish one series from another.

1. Create a line chart.

2. Select a series on the line chart.

3. On the Series tab, in the Line group, open the Marker drop-down menu.

4. From the Marker drop-down menu, select the marker shape. The options are:
   - None
- Square (default)
- Circle
- Diamond
- Plus
- Triangle Down
- Triangle Up
- Triangle Right
- Triangle Left
- Pirate Plus
- House
- Hexagon
- Fat X
- Five Star
- Six Star
- Hourglass
- Sideways Hourglass
- Line

The markers are formatted.
The following image shows a square marker for Dollar Sales and a circle marker for Quantity.
Series Tab Pie Group

How to:
Expand Pie Slices
Hide a Pie Slice

Procedure: How to Expand Pie Slices

The following image shows a basic pie chart before its slices are expanded.

1. Create a pie chart.
2. On the Series tab, in the Select group, from the drop-down menu, select one of the following:
   - All Series expands all slices out from the center of the pie.
   - A specific series expands that particular slice out from the center of the pie.
3. In the Pie group, click Expand.
   The pie expands accordingly.
**Formatting a Series**

The following image shows a pie chart with all slices expanded.

![Pie Chart](image)

---

**Procedure: How to Hide a Pie Slice**

1. Create a pie chart.
2. On the Series tab, in the Select group, from the drop-down menu, select the series that you want to hide. Then, in the Pie group, click *Hide*.

The slice is hidden.
The following image shows a pie chart with a slice hidden.

### Series Tab Display Group

**How to:**
Reverse the Order of a Series

**Procedure:**  **How to Reverse the Order of a Series**

1. Create a chart.
2. On the Series tab, in the Display group, click *Reverse Order*.
   
   The order of the series is reversed.
The following image shows a vertical bar chart.

![Vertical Bar Chart]

The following image shows the same data with the series in reverse order.

![Vertical Bar Chart with Reversed Series]
Field Tab Filter Group

How to: Filter Values in a Series

Procedure: How to Filter Values in a Series
1. Create a chart.
2. Select a series on the chart.
3. Open the Filter dialog box in one of the following ways:
   - Ribbon: On the Field tab, in the Filter group, click Filter.
   - Right-Click Menu: Right-click a series, and select Filter Values.
   The Filter dialog box opens. For more information, see Filter Group on page 42.
4. Select values for values and prompts.
5. Click OK to close the dialog box.
   The series values are filtered.

Field Tab Sort Group

How to: Sort the Fields in a Series

Procedure: How to Sort the Fields in a Series
For more information, see Sort Group on page 89.
1. Create a chart.
2. Select a series.
3. Sort the series in one of the following ways:
   - Ribbon: On the Field tab, in the Sort Group, click Up to sort the series values from smallest to largest, or click Down to sort the series values from largest to smallest.
   - Right-Click Menu: Right-click a series on the chart, and point to Sort, and then Sort again. Click Ascending to sort the series values from smallest to largest, or click Descending to sort the series values from largest to smallest. Select Limit to open a list of values to display for a sort group.
The chart appears with the series sorted accordingly.
The following image shows a vertical bar chart before sorting is applied.

The following image shows the same data sorted in descending (highest to lowest) order.
The following image shows the same data sorted in ascending (lowest to highest) order.

Field Tab Display Group

**How to:**

- Hide a Field in a Series
- Display Aggregations on Measures
- Apply Traffic Light Conditions With Drill-Down to a Numeric Measure Field (By Constant)
- Apply Traffic Light Conditions With Drill-Down to a Numeric Measure Field (By Field)
- Change the Title of a Series
- Control the Color Mode
- Delete a Series

**Procedure: How to Hide a Field in a Series**

1. Create a chart.
2. Hide a field in a series is one of the following ways following ways:
   - Select the field in the Query pane.
   - Right-click the field in the chart.
Ribbon: Select the field in the Query pane or by right-clicking it in the chart. On the Field tab, in the Display group, click *Hide Field*. Click *Hide Field* again to make the series reappear.

Right-Click Menu: Right-click a series in the Query pane, or in the chart, point to Visibility, and then click *Hide*. Right-click the same series, point to Visibility, and then click *Show* to make the series reappear.

The field is hidden.

The following image shows a vertical bar chart with each of the series shown.

The following image shows the same data with the Price field hidden.
Procedure: How to Display Aggregations on Measures

You can display numeric measure data using a variety of aggregation values.

For more information, see Display Group on page 72.

1. Create a chart.

2. Open the list of Aggregation options in one of the following ways:
   - **Ribbon:** On the Field tab, in the Display group, open the Aggregation drop-down menu.
   - **Right-Click Menu:** Right-click a series, point to More, and then Aggregation Functions.

3. Select an aggregation function.

The aggregation function is applied to the series.

**Note:** If you change the Measure (Sum) field container in the Query Design pane from Sum to Print, Count, or List, the change overrides all assigned aggregation values.
The following image shows a vertical bar chart without any aggregation values applied.

The following image shows the same data with the aggregation value of Average (AVE.) applied to Price, and the aggregation value of Maximum (MAX.) applied to revenue.
**Procedure:** How to Apply Traffic Light Conditions With Drill-Down to a Numeric Measure Field (By Constant)

1. Create a chart.
2. Open the Traffic Light Condition dialog box in one of the following ways:
   - **Ribbon:** In the Query pane, select a field, and then on the Field tab, in the Display group, click *Traffic Lights*.
   - **Right-Click Menu:** Right-click a series on the chart, point to More, and then select *Traffic Light Conditions*.

   The Traffic Light Condition dialog box opens. For more information, see *Traffic Light Condition Dialog Box* on page 211.

3. From the Relational Operators drop-down menu below the field name, select a relational operator. The options are:
   - Equal to
   - Not equal to
   - Greater than
   - Less than
   - Greater than or equal to
   - Less than or equal to

4. In the field to the right of the operator drop-down menu, click the down arrow for the Type drop-down menu.

   The Type dialog box opens.

5. In the Type dialog box, select *Constant*.

6. Enter a value in the Value field, or
   - a. From the Get Values drop-down menu, select one of the following values All, First, Last, Minimum, Maximum, From File. The value that you select appears in the Get Values field.
   - b. Select the value in the Get Values field. The value that you selected appears in the Value field.

7. Click OK.

   The value that you selected appears in the field to the right of the operator drop-down menu.
8. Click the Color button.
   The Color dialog box opens.

9. Select a color.

10. Click OK.
    The color appears in the Preview box.

11. Click OK.

12. Click the Drill Down button.
    The Drill Down dialog box opens.

13. In the Drill Down dialog box, specify each of the following:
    - Drill down to a report or a web page
    - URL of the web page
    - An alternate comment
    - Target (New Window, Same Window)
    - Parameters that you want to use (Name, Value)

14. Click OK to close the dialog box.

15. Click the New button to set traffic light conditions for additional fields.
The following image shows a vertical chart without traffic light conditions.

The following image shows the same vertical chart with traffic light conditions applied. In this example, the condition was set to display the revenue series in red when the Revenue series exceeds the value of 14399.46.
**Procedure:** How to Apply Traffic Light Conditions With Drill-Down to a Numeric Measure Field (By Field)

1. Create a chart.

2. Open the Traffic Light Condition dialog box in one of the following ways:
   - **Ribbon:** In the Query pane, select a field, and then on the Field tab, in the Display group, click Traffic Lights.
   - **Right-Click Menu:** Right-click a series on your chart, point to More, and then select Traffic Light Conditions.

   The Traffic Light Condition dialog box opens. For more information, see *Traffic Light Condition Dialog Box* on page 211.

3. From the Relational Operators drop-down menu below the field name, select a relational operators. The options are:
   - Equal to
   - Not equal to
   - Greater than
   - Less than
   - Greater than or equal to
   - Less than or equal to

4. In the field to the right of the operator drop-down menu, click the arrow for the Type drop-down menu.

   The Type dialog box opens.

5. In the Type dialog box, select Field.

   The Type dialog box displays the Dimensions, and Measures and Properties of your data. You can display the data in the following ways:
   - View fields in business order. Select from the following options Title, Description, Name, Alias.
   - View fields in a sortable grid. Select from the following options Name, Title, Alias, Format, Segment, Filename, Description, Reference.
   - View the hierarchical structure of the data. Select from the following options Title, Description, Name, Alias.
6. Select a field.

7. Click OK.
   The field that you selected appears in the field to the right of the operator drop-down menu.

8. Click the Color button.
   The Color dialog box opens.

9. Select a color.
   The color appears in the Preview box.

10. Click OK.

11. Click the Drill Down button.
    The Drill Down dialog box opens.

12. In the Drill Down dialog box, specify each of the following:
    - Drill down to a report or a web page
    - URL of the web page
    - An alternate comment
    - Target (New Window, Same Window)
    - Parameters that you want to use (Name, Value)

13. Click OK to close the dialog box.

14. Click the New button to set traffic light conditions for additional fields.

**Procedure:** How to Change the Title of a Series

1. Create a chart.

2. Open the Edit Title dialog box in one of the following ways:
   - **Right-Click Menu:** Right-click a series on the chart, and select Change Title.
   - **Query Pane:** Right-click a series, and select Change Title.
     The Edit Title dialog box opens.

3. In the Enter Title field, type the new name for the series.

4. Click OK to close the dialog box.
The series has a new title.

The following image shows a vertical bar chart with a Price series and a Revenue series.

In the following image, Annual Revenue has replaced Revenue as the series title.
Procedure: How to Control the Color Mode

When you create a single-series chart, all series groups appear in the same color. To use a different color for each group, set the color mode to By Group.

The following image shows a single-series chart with all series groups in the same color.

1. Create a chart.

2. Right-click a series on the chart, point to Color Mode, and then select By Group.

   A different color is applied to each group in the series. To return to the default display of the series in one color, right-click the series, point to Color Mode, and then select By Series.

3. Click Run to generate the report.
The following image shows a single-series chart with a different color applies to each group in the series.

Procedure: How to Delete a Series

1. Create a chart.
2. Right-click a series on the chart, and select Delete.

   The series is deleted.

Formatting Data Labels

Data labels highlight important data points on a chart. They identify exact numbers. You can customize data labels in a variety of ways to make them stand out more clearly on the chart. For example, you can change the position, angle, color, or size of data labels.
Associated Dialog Boxes

In this section:
- Format Labels Dialog Box
- Style Dialog Box
- Line Style Dialog Box

Whether you access data label options from the ribbon or the right-click menu, you are presented with a dialog box of options. The following dialog boxes are commonly used for formatting data labels:

- Format Labels
- Style
- Line Style

For instructions on how to open these dialog boxes, see the procedures in *Using Data Labels Properties* on page 254.

**Format Labels Dialog Box**

The Format Labels dialog box contains options for editing data labels. Bar, line, and area charts share the same tabs.

The Format Labels dialog box contains the following tabs:

- General Options (options vary by chart type)
- Advanced (options vary by chart type)
Use the General Options tab to add data labels to a chart and set their position, angle, and radius. The General Options tab is shown in the following image.

The General Options contains the following options:

- **Show Data Labels.** Select this option to show data labels on a chart. Clear this option to suppress data labels.

- **Position.** Select an option from this drop-down menu to determine where the data label will be positioned. The options are:
  - Custom
  - Above
  - On top edge
  - Below top edge
  - Center
  - Base
  - Center back
Angle. Set the angle of the data label. When the position is set to Custom, you can define the angle properties to create a custom position for the data label.

Radius. Set the radius of the data label. When the position is set to Custom, you can define the radius properties to create a custom position for the data label.

Format Labels. Select from this drop-down menu of preset formats that can be applied to the labels. The options are:

- Use Pattern / 100
- Use Pattern
- General
- No Decimal
- Percent with no decimal
- Percent with one decimal
- Percent with two decimals
- Currency general
- Currency with no decimal
- General in thousands
- Currency in thousands
- Currency in millions
- General in billions
- General in trillions
- Currency in trillions
- Thousands separator no decimal.
- Thousands separator two decimals.
- Date short
- Date medium
- Date long
- Date full
- Percent with no decimal / 100
Formatting Data Labels

- Percent with one decimal / 100
- Percent with two decimals / 100

- **Custom Format.** Enter a standard number format pattern for the data label. This option is only available when you select the *Use Pattern* option from the Format Labels drop-down menu.

- **Style Labels.** Click this icon to open the Style dialog box, where you can style text. For more information, see *Style Dialog Box* on page 252.

Use the Advanced tab to modify additional data labels properties. The Advanced tab is shown in the following image.

![Advanced Tab](image)

The Advanced tab contains the following options:

- **Show Zero Labels.** Select this option to display zero values in a chart. Clear this option to display all data values except zero.

- **Remove duplicate data labels.** Select this option to remove the display of multiple data labels that share the same value so that only one value is shown.

- **Apply color to negative data labels.** Select this option to style negative data labels separately from positive data labels.
- **Color.** Click this icon to open the Color dialog box, where you can select a color for the negative number.

There are some options in the General Options tab that are specific to stack charts. The General Options tab for a stack chart is shown in the following image.

These options specific to a stack chart are:

- **Show Cumulative Sums.** Select this option to have the data text labels show cumulative sums. Clear this option to have data text labels show individual sums.

- **Show Stacked Total.** Select this option to display stacked totals. Data position should be set to **Center** to display a stacked total.

Bubble and stock charts share the same General Options and Advanced tabs as bar, line, and area charts, except for the Custom Label option.
For pie charts, the General Option and Advanced tabs are replaced by the Pie Labels and Pie Title tabs.

Use the Pie Labels tab to customize your pie data labels. The Pie Labels tab is shown in the following image.

The Pie Labels tab contains the following options:

- **Label Position.** Select from this drop-down menu an option to control the display of feeler lines and labels on a pie chart.

- **Label Display.** Select from this drop-down menu an option to control the format of labels displayed next to feelers on a pie chart.

- **Format Labels.** Select from this drop-down menu of preset formats that can be applied to labels.

- **Custom Format.** Select this option to use a custom format from a list of preset formats. See the following table for a list and description of the characters that you can use in a custom format.

- **Style Labels.** Click this button to open the Style dialog box, where you can style text.
Ring Label. These options appear on the tab for a ring pie chart.

Feeler Line

Show Ring Label. Select this option to control the display of the total label on a pie ring chart.

Format Labels. Select from this drop-down menu of preset formats that can be applied to labels.

Custom Format. Select this option to use a custom format. See the following table.

Style Labels. Click this button to open the Style dialog box, where you can style text.

The Format Labels drop-down menu provides a list of preset formats that you can apply to labels. When you select a custom format, it must be defined using a custom format pattern. The following table describes the characters that you can use in a custom format.

<table>
<thead>
<tr>
<th>Character</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>#</td>
<td>Is a digit.</td>
</tr>
<tr>
<td>0 (zero)</td>
<td>Shows as absent.</td>
</tr>
<tr>
<td>. (period)</td>
<td>Is a placeholder for decimal separator.</td>
</tr>
<tr>
<td>, (comma)</td>
<td>Is a placeholder for grouping separator.</td>
</tr>
<tr>
<td>; (semicolon)</td>
<td>Separates formats.</td>
</tr>
<tr>
<td>- (dash)</td>
<td>Is the default negative prefix.</td>
</tr>
<tr>
<td>% (percent)</td>
<td>Divides by 100 and shows as a percentage.</td>
</tr>
<tr>
<td>x</td>
<td>Determines that any other characters can be used in the prefix or suffix.</td>
</tr>
<tr>
<td>' (apostrophe)</td>
<td>Is used to quote special characters in a prefix or suffix.</td>
</tr>
</tbody>
</table>
Use the Pie Title tab to create and style a pie title. The Pie Title tab is shown in the following image.

![Format Labels](image)

The Pie Title tab contains the following options:

- **Show Pie Title.** (Default). Clear this option to suppress a pie title. Select this option to display a pie title.

- **Style Title.** Click this icon to open the Style dialog box, where you can style pie title text.
Use the Funnel Labels tab to customize the labels on a funnel or a pyramid chart. The Funnel Labels tab is shown in the following image.

The Funnel Labels tab contains the following options:

- **Label Position.** Select from this drop-down menu an option to control the display of feeler lines and labels on a funnel chart.
- **Format Labels.** Select from this drop-down menu of preset formats that can be applied to labels.
- **Custom Format.** Select this option to use a custom format. See the table in the previous section for a list and description of the characters that you can use in a custom format.
- **Style Labels.** Click this button to open the Style dialog box, where you can style text.
- **Style Value.** Opens the Style dialog box, where you can style the value.

**Feeler Line**
Show Feeler Lines. (Default) Clear this option to suppress feeler lines. Select this option to display feeler lines.

Line Style. Click this button to open the Line Style dialog box, where you can edit the color, weight, and style of the feeler line.

Style Dialog Box

The Style dialog box contains options to style the data labels. The Style dialog box is shown in the following image.

The Style dialog box contains the following options:

Font. Use the drop-down menu to change the font.

Font size. Use the drop-down menu to change the numeric value for the font size.

Font style. Click the appropriate button (bold, italic, underline) to style the selected text.

Text alignment. Click the appropriate button (left, center, right) to align the selected text.

Font color. Click the button to open the Color dialog box, where you can select the font color.

Reset to Quick Styles from Template. Click the button to reset all settings to the default settings from the template.

Note: Reset only works while the Style dialog box is open. Once you click OK, all changes are committed. To undo global styling after it has been committed, you must use the Undo command on the Quick Access Toolbar.
Line Style Dialog Box

The Line Style dialog box contains options to style lines on a chart. The Line Style dialog box is shown in the following image.

![Line Style Dialog Box]

The Line Style dialog box contains the following options:

- **Color.** Click this button to open the Color dialog box, where you can select the color for the line.
- **Weight.** Click this button to open a drop-down menu of line weight options.
- **Style.** Click this button to open a drop-down menu of line style options.
- **Reset.** Click this button to reset the line to the default options.

Data Labels Elements Right-Click Menu

When you right-click a data label on a bar, line, or area chart, a menu of the following options opens:

- **Data Labels.** Point to this option to toggle between Show and Hide.
- **More Label Options.** Click this option to open the Format Labels dialog box.

The right-click menu contains options that are available on the Series tab.

When you right-click a data label on a pie chart, a menu of the following options opens:

- **Smart Positioning.** Select this option to use smart positioning of data labels. For example, if a pie chart has so many slices that a data label could become illegible, InfoAssist moves the data label outside of the pie, but connects it to the slice with a feeler line.
- **On Slice.** Select this option to display the data labels on the pie slices.
Outside Slice. Select this option to display the data labels outside the pie slices.

Outside with feeler lines. Select this option to display the data labels outside the pie slices with feeler lines.

Using Data Labels Properties

The following sections contain procedures for customizing data labels. The procedures are organized by the tab and group in which their associated options appear on the ribbon.

Series Tab Properties Group

How to:
Show and Hide Data Labels
Change the Position of Data Labels

Procedure: How to Show and Hide Data Labels

1. Create a chart.
2. You can access the option to show data labels in one of the following ways:

   - **Ribbon:** On the Series tab, in the Properties group, open the Data Labels drop-down menu and select More Data Labels Options to open the Format Labels dialog box. On the General tab, select the Show Data Labels option, and click OK to close the dialog box. You can use this dialog box to format and style the data labels. For more information, see Format Labels Dialog Box on page 243. To hide data labels, clear this option.

   - **Right-Click Menu:** Right-click a series on the chart, point to Data Labels, and then select Show. To hide data labels, right-click a series on the chart, point to Data Labels, and then select Hide.

The data labels appear and are formatted and styled accordingly.
Procedure: How to Change the Position of Data Labels

1. On the Series tab, in the Properties group, open the Data Labels drop-down menu.
2. On the menu, select the position for the data labels.
   The data labels are positioned accordingly.
The following image shows a chart with the data labels centered.

Formatting a Legend

In this section:
Format Legend Dialog Box
Legend Elements Right-Click Menu
Using Legend Properties

A legend contains information that is necessary to accurately interpret the data on a chart. By default, a chart displays either a vertical axis title if there is a single measure field, or a legend if there are multiple measure fields.

Format Legend Dialog Box

Whether you access legend options from the ribbon or the right-click menu, you are presented with the Format Legend dialog box of options. For instructions on how to open this dialog box, see Using Legend Properties on page 262.

The Format Legend dialog box contains options for formatting a legend on a chart. It contains the following tabs:

- Legend Options
Markers & Labels
Fill
Border Styles
Advanced

**Note:** The Fill, Border Style, and Shadows tab are not available in InfoAssist Basic.

For instructions on how to open this dialog box, see the procedures in *Using Legend Properties* on page 262.

Use the Legend Options tab to customize the appearance of a legend on a chart. The Legend Options tab is shown in the following image.

![Legend Options Tab](image)

The Legend Options tab contains the following options.

- **Show Legend.** Select this option to show a legend on a chart. Clear this option to suppress a legend on a chart.

- **Legend Position.** Select an option from this drop-down menu to position a legend on a chart. The options are:
  - Auto
Formatting a Legend

- Bottom
- Right
- Left
- Top
- Right Top
- Right Bottom
- Left Top
- Left Bottom
- Bottom Left
- Bottom Right
- Top Left
- Top Right
- Free Float

- **Legend Orientation.** Select an option from this drop-down menu to control the orientation of legend markers in the legend area. The available options are Auto, Horizontal, Vertical.

- **Reverse Legend Order.** Select this option to specify that the legend be drawn in reverse order. Clear this option to specify that the legend be drawn in normal order.

- **Legend Position**
  - **X.** Controls the point location of the bottom left corner of the legend.
  - **Width.** Controls the width of the legend.
  - **Y.** Controls the point location of the bottom left corner of the legend.
  - **Height.** Controls the height of the legend.
Use the Markers & Labels tab to customize the appearance of markers and labels on legends. The Markers & Labels tab is shown in the following image.

The Markers & Labels tab contains the following options:

- **Style Labels.** Click this button to open the Style dialog box, where you can style text.

- **Marker Style.** Select an option from this drop-down menu to edit the line style in the legend. The options are:
  - Markers Only
  - Line Style Only
  - Markers and Line Style
  - Automatic Line Style

- **Marker Position.** Select an option from this drop-down menu to set the position of text relative to the legend marker. The options are:
  - Left of Text
  - Right of Text
  - Above Text
  - Below Text
  - On Text
Show Beveled Markers. Select this option to show beveled markers. Clear this option to suppress beveled markers.

Use the Fill tab to modify the color of the legend area. For more information, see Format Series Dialog Box on page 209.

Use the Border Styles tab to place a border around a legend. For more information, see Format Series Dialog Box on page 209.

The Border Styles tab contains the following options:

- **Show Border.** Select this option to place a border around a legend.
- **Color.** With the Show Border option selected, you can click this button to open the Color dialog box, where you can select a color for the border.

Use the Advanced tab to use square markers and marker shapes on a legend. The Advanced tab is shown in the following image.

![Format Legend](image)

The Advanced tab contains the following options:

- **Square Markers.** Select this option to display square markers on a legend.
- **Use Marker Shapes.** Select this option to display marker shapes on a legend.
Legend Elements Right-Click Menu

When you right-click a legend on a chart, a menu of options opens. The menu contains options that are available on the Format tab.

If you right-click the background area around the legend, two additional options are available, Legend Area Color, and Legend Border Color. The right-click menu options are described in the following table. The table provides links to the sections of this document in which those options are also discussed.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show Legend</td>
<td>Controls the display of the legend. InfoAssist displays the legend by default. When you clear this option, InfoAssist suppresses the legend. For instructions, see Using Legend Properties on page 262. The background right-click menu has an option to restore the legend after it has been suppressed.</td>
</tr>
<tr>
<td>Legend Position</td>
<td>Controls the placement of the legend on the chart. For instructions see, Using Legend Properties on page 262.</td>
</tr>
<tr>
<td>Legend Orientation</td>
<td>Controls the orientation of the legend on the chart. For instructions see, Using Legend Properties on page 262.</td>
</tr>
<tr>
<td>Legend Area Color</td>
<td>Enables you to specify the color of the legend background area using the Color dialog box. This option is available only when you right-click the area around the legend. For instructions see, Using Legend Properties on page 262.</td>
</tr>
<tr>
<td>Legend Border Color</td>
<td>Enables you to specify the color of the border around the legend background area using the Color dialog box. This option is available only when you right-click the area around the legend. For instructions see, Using Legend Properties on page 262.</td>
</tr>
<tr>
<td>More Legend Options</td>
<td>Opens the Format Legend dialog box.</td>
</tr>
</tbody>
</table>
Using Legend Properties

The following sections contain procedures for customizing legend. The procedures are organized by the tab and group in which their associated options appear on the ribbon.

Format Tab Labels Group

How to:

- Hide a Legend
- Position a Legend
- Control the Orientation of a Legend
- Specify the Color of a Legend Background
- Specify the Color of a Legend Border

Procedure: How to Hide a Legend

1. Create a chart with multiple measure fields.
2. Clear the Show legend option in one of the following ways:
   - **Ribbon:** On the Format tab, in the Layout group, open the Legends drop-down menu, and clear the Show legend option.
   - **Right-Click Menu:** Right-click the legend, and clear the Show Legend option.

   The legend is hidden.

Procedure: How to Position a Legend

1. Create a chart with multiple measure fields.
2. Open the menu of label position options in one of the following ways:
   - **Ribbon:** On the Format tab, in the Layout group, open the Legends drop-down menu, and point to Legend Position.
   - **Right-Click Menu:** Right-click the legend, and point to Legend Position.
3. Select a position for the legend. The options are:
The following image shows a chart with the legend in the default position on the bottom.
The following image shows a chart with the legend moved to the right.

**Procedure:** How to Control the Orientation of a Legend

1. Create a chart with multiple measure fields.
2. Open the menu of label orientation options in one of the following ways:
   - **Ribbon:** On the Format tab, in the Layout group, open the Legends drop-down menu, and point to Legend Orientation.
   - **Right-Click Menu:** Right-click the legend, and point to Legend Orientation.
3. Select an orientation for the legend.
   The options are:
   - Auto
   - Vertical
   - Horizontal
The following image shows a chart with a legend that has a vertical orientation.

Procedure: How to Specify the Color of a Legend Background

1. Create a chart with multiple measure fields.
2. Open the Format Legends dialog box in one of the following ways:
   - Ribbon: On the Format tab, in the Layout group, open the Legends drop-down menu, and select More Legend Options.
   - Right-Click Menu: Right-click the legend, and select More Legend Options.

   The Format Legends dialog box opens. For more information, see Format Legend Dialog Box on page 256.
3. On the Fill tab, set the fill, color, and transparency options for the legend background.
4. Click OK to close the dialog box.

   The legend is formatted accordingly.
The following image shows a chart with a legend with a teal background.

![Chart with Legend](image.png)

**Procedure:**  How to Specify the Color of a Legend Border

1. Create a chart with multiple measure fields.
2. Open the Format Legends dialog box in one of the following ways:
   - **Ribbon:** On the Format tab, in the Layout group, open the Legends drop-down menu, and select *More Legend Options*.
   - **Right-Click Menu:** Right-click the legend, and select *More Legend Options*.

   The Format Legends dialog box opens. For more information, see *Format Legend Dialog Box* on page 256.

3. On the Border Styles tab, select the option to *Show Border*.
4. Click the *Color* icon to open the Color dialog box, where you can specify the color of the legend border.
5. Click *OK* to close the Color dialog box.
6. Click *OK* to close the Format Legend dialog box.

   The legend border is formatted accordingly.
Gridlines are used on a chart as a reference to help you understand the quantities and values of your data and decode information on the axis. There are four types of gridlines that you can display and edit on your chart. They are:

- **Horizontal major gridlines**
- **Horizontal minor gridlines**
- **Vertical major gridlines**
- **Vertical minor gridlines**

Major gridlines enhance the display of values, while minor gridlines supplement major gridlines. If a plot point falls in between major gridlines, you can use minor gridlines for more precise interpretation of the data.

- **Vertical gridlines in a vertical chart run on the X axis.**
- **Horizontal gridlines in a vertical chart run on the Y axis.**

- **Horizontal major gridlines enhance the display of values, compared to the Y-axis scale alone.** They are enabled by default on many charts. They do not apply to the pie, 3D, gauge, spectral map, or funnel chart type.

- **Horizontal minor gridlines are disabled by default.** They do not apply to the pie, 3D, gauge, spectral map, or funnel chart type.

- **Vertical major gridlines enhance the display of values, compared to the X-axis scale alone.** They are enabled by default. They do not apply to the pie, 3D, gauge, spectral map, or funnel chart type.

- **Vertical minor gridlines are disabled by default.** They apply only to scatter and bubble chart types, where the X axis is numeric. They do not apply to the pie, 3D, gauge, spectral map, or funnel chart type.

**Note:** The orientation of a chart determines the available gridline options.
Format Grid Lines Dialog Box

Whether you access gridline options from the ribbon, or the right-click menu, you are presented with the Format Grid Lines dialog box of options to format horizontal and vertical gridlines, color bands, and frames on a chart.

Color bands come in a pair, with each band uniquely colored. They appear in a continually repeating pattern behind a series on a chart. The contrast of colors is designed to make the chart easier to read.

Alternate formatting can be used to apply different colors to sections, called regions, of an axis.

The Format Grid Lines dialog box contains the following tabs:

- **Major Grid Lines**
- **Minor Grid Lines**
- **Color Bands**
- **Frames**

**Note:** The Color Bands and the Frames options are not available in InfoAssist Basic.

Use the Major Grid Lines tab to format the major gridlines on the chart. The Major Grid Lines tab is shown in the following image.
The Major Grid Lines tab contains the following options:

- **Show Grid Lines.** Select this option to display major gridlines on a chart if minor gridlines are the default for the chart.

- **Grid Style.** Select from this drop-down menu to edit the style of the gridlines, such as adding a tick on the inside or the outside of the line.

- **Line Style.** Click this icon to open the Line Style dialog box, where you can edit the color, weight, and style of the gridline.

- **Tick Style.** Select from this drop-down menu of tick styles (Inside, Outside, Spanning, Hidden).

- **Tick Color.** Click this icon to open the Color dialog box, where you can edit the color of the tick.

Use the Minor Grid Lines tab to format the minor gridlines on your chart. The Minor Grid Lines tab is shown in the following image.

![Format Vertical Grid Lines](image)

The Minor Grid Lines tab contains the following options:

- **Show Grid Lines.** Select this option to display minor gridlines on a chart. By default, this option is enabled.
Formatting Gridlines

- **Grid Style.** Select from this drop-down menu to edit the style of the gridlines. The options are:
  - Normal
  - Normal with tick outside
  - Normal with tick inside
  - Tick spanning

- **Line Style.** Click this icon to open the Line Style dialog box, where you can edit the color, weight, and style of the gridline.

- **Grid count.** Set the number of minor gridlines that will appear between major gridlines.

- **Tick Style.** Select from this drop-down menu of tick styles. The options are:
  - Inside
  - Outside
  - Spanning
  - Hidden

- **Tick Color.** Click this icon to open the Color dialog box, where you can edit the color of the tick.
Use the Color Bands tab to format the color bands on your chart. The Color Bands tab is shown in the following image.

The Color Bands tab contains the following options:

- **Band 1.** Select this option to add Band 1 to a chart.
  - **Color.** Click this icon to open the Color dialog box, where you can edit the color of Band 1.
  - **Transparency.** Move the slider to make Band 1 opaque (0%) or transparent (100%). The default is 0%.
  - **%.** Enter or select the percentage of the transparency of Band 1.

- **Band 2.** Select this option to add Band 2 to a chart.
  - **Color.** Click this icon to open the Color dialog box, where you can edit the color of Band 2.
  - **Transparency.** Move the slider to make the Band 2 opaque (0%) or transparent (100%). The default is 0%.
  - **%.** Enter or select the percentage of the transparency of Band 2.
Use the Quadrant Lines tab to control the placement and style of the quadrant lines in your scatter and bubble chart. The Quadrant Lines tab is shown in the following image.

The Quadrant Lines tab contains the following options:

- **Show Quadrant Line.** Select this option to show the quadrant line. Clear this option to suppress the quadrant line.

- **Value.** Enter a value to control where the quadrant line will be placed on the X axis.

- **Line Style.** Click this icon to open the Line Style dialog box, where you can edit the color, weight, and style of the quadrant line.
Use the Frames tab to enable or disable frame regions, and to set the location and style of the frame text. The Frames tab is shown in the following image.

The Frames tab contains the following options:

- **Show Frame Regions.** Select this option to show a frame region. Clear this option to suppress a frame region.
  - **Region.** Select from this drop-down list, the region that you want to format.
  - **Add.** Click this button to add a region.
  - **Remove.** Click this button to remove a region.
- **Location.** Enter the location of the region.
- **Color.** Click this icon to open the Color dialog box, where you can edit the color of the frame.
- **Border Color.** Click this icon to open the Color dialog box, where you can edit the color of the frame border.
- **Text.** Enter the text that you want to appear on the frame.
- **Style Text.** Click this icon to style the frame text.
For instructions on how to open this dialog box, see the procedures in Using Gridline Properties on page 274.

**Gridline Elements Right-Click Menu**

When you right-click a gridline on a chart, a menu of options opens. The options for the gridline elements are described in the following table.

<table>
<thead>
<tr>
<th>Element</th>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Horizontal Major Gridlines</td>
<td>Delete</td>
<td>Removes the gridline from the chart and updates the Live Preview accordingly.</td>
</tr>
<tr>
<td>Horizontal Minor Gridlines</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Vertical Major Gridlines</td>
<td>Set Line Color</td>
<td>Enables you to specify the color of the gridline, using the Color dialog box. For more information, see Color Dialog Box on page 46.</td>
</tr>
<tr>
<td>Vertical Minor Gridlines</td>
<td>More Grid Lines</td>
<td>Opens the Format Gridlines dialog box. For more information, see Format Grid Lines Dialog Box on page 268.</td>
</tr>
<tr>
<td></td>
<td>Options</td>
<td></td>
</tr>
</tbody>
</table>

**Using Gridline Properties**

**In this section:**
Format Tab Features Group

The following sections contain procedures for customizing gridlines. The procedures are organized by the tab and group in which their associated options appear on the ribbon.
How to Display Horizontal Major Gridlines

Procedure: How to Display Horizontal Major Gridlines

If your chart does not display gridlines by default, use this procedure to generate gridlines.

1. Create a chart.
2. On the Format tab, in the Features group, open the Grid drop-down menu, point to Horizontal Gridlines, and then select Major Gridlines.
   The Format Horizontal Grid Lines dialog box opens.
3. On the Major Grid Lines tab, select Show Major Grid Lines.
   Horizontal major gridlines are added to the chart.
The following image shows a chart with the horizontal major gridlines highlighted and the right-click menu open.

**Formatting Gridlines**

**Procedure:** How to Display Horizontal Minor Gridlines

1. Create a chart.
2. Access the option to show gridlines in one of the following ways:
   - **Ribbon:** On the Format tab, in the Features group, open the Grid drop-down menu. On the Grid drop-down menu, point to Horizontal Gridlines, and then select *Minor Gridlines*.
   - **Right-Click Menu:** Right-click the chart, and select *More Grid Line Options*. The Format Horizontal Grid Lines dialog box opens. On the Minor Grid Lines tab, select *Show Minor Grid Lines*.

Horizontal minor gridlines are added to the chart.
The following image shows a chart with the horizontal minor gridlines highlighted.

**Procedure: How to Display Vertical Major Gridlines**

1. Create a chart.
2. Access the option to show gridlines in one of the following ways:

   - **Ribbon:** On the Format tab, in the Features group, open the Grid drop-down menu. On the Grid drop-down menu, point to Vertical Gridlines, and then select *Major Gridlines*.

   - **Right-Click Menu:** Right-click the chart, and select *More Grid Line Options*. The Format Vertical Grid Lines dialog box opens. On the Major Grid Lines tab, select *Show Major Grid Lines*.

   Vertical major gridlines are added to the chart.
**Procedure:** How to Display Vertical Minor Gridlines

1. Create a chart.
2. Access the option to show gridlines in one of the following ways:

   - **Ribbon:** On the Format tab, in the Features group, open the Grid drop-down menu. On the Grid drop-down menu, point to Vertical Gridlines, and then select *Minor Gridlines*.
   
   - **Right-Click Menu:** Right-click the chart, and select *More Grid Line Options*. The Format Vertical Grid Lines dialog box opens. On the Minor Grid Lines tab, select *Show Minor Grid Lines*.

Vertical minor gridlines are added to the chart.
The following image shows a chart with vertical minor gridlines highlighted.

**Procedure**: How to Set the Color, Weight, and Style of a Gridline

1. Open the Format Grid Lines dialog box in one of the following ways:
   - **Ribbon**: On the Format tab, in the Features group, open the Grid drop-down menu, point to the gridline type that you want to format, and select *More Grid Lines Options*.
   - **Right-Click Menu**: Right-click a gridline, and select *More Grid Lines Options*.

   The Format Grid Lines dialog box opens.

2. Click the Line Style icon.

   The Line Style dialog box opens.

3. Set the color, weight, and style of the gridline.

4. Click *OK* to close the Line Style dialog box.

5. Click *OK* again to close the Format Grid Lines dialog box.

   The gridline is formatted accordingly.
The following image shows a chart with the default styling for gridlines.

The following image shows the same chart with the gridlines styled as red, dashed lines, of medium weight.

**Procedure: How to Set Ticks**

Ticks are short lines which are perpendicular to a gridline. They are used to tick off specific increments along the gridline.
1. Create a chart with gridlines.

2. Open the Format Grid Lines dialog box in one of the following ways:
   - **Ribbon:** On the Format tab, in the Features group, open the Grid drop-down menu, point to the gridline type that you want to format, and select *More Grid Lines Options*.
   - **Right-Click Menu:** Right-click a gridline, and select *More Grid Lines Options*.

   The Format Grid Lines dialog box opens.

3. From the Tick Style drop-down menu select a tick style option. The options are:
   - Hidden
   - Inside
   - Outside
   - Spanning

4. Click the **Color** icon to open the Color dialog box, where you can set the color of the tick marks.

5. Click **OK** to close the Color dialog box.

6. Click **OK** again to close the Format Grid Lines dialog box.

   The tick marks are formatted accordingly.

   The following image shows a chart with tick marks spanning the frame of the chart.
Procedure: **How to Set Color Bands**

1. Create a chart with gridlines.
2. Open the Format Grid Lines dialog box in one of the following ways:
   - **Ribbon:** On the Format tab, in the Features group, open the Grid drop-down menu, point to gridlines that you want to format, and select *More Grid Lines Options*.
   - **Right-Click Menu:** Right-click a gridline, and select *More Grid Lines Options*.

The Format Grid Lines dialog box opens.

3. On the Color Bands tab, click the *Color* icon to open the Color dialog box, where you can set the color of the color bands.
4. Use the transparency slider, or the percentage box, to type or select the percentage of the transparency that you want to apply to the color.
5. Click *OK* to close the Color dialog box.
6. Click *OK* again to close the Format Grid Lines dialog box.

The following image shows a chart with Color Band 1 set to a green color with 80 percent transparency.

---

Procedure: **How to Delete a Gridline**

1. Create a chart with gridlines.
2. Select a gridline.
3. Delete the gridline in one of the following ways:

   - **Ribbon:** On the Format tab, in the Features group, open the Grid drop-down menu. From the menu, point to the gridline that you want to format, and select More Grid Lines to open the Format Grid Lines dialog box. On the tab for the gridline that you want to delete, clear the Show Grid Lines option, and click OK.

   - **Right-Click Menu:** Right-click the gridline, and from the menu, select Delete.

   The gridline is deleted from the chart.

**Procedure: How to Display Quadrant Lines**

Use the options on the Quadrant Lines tab to control the placement and style of the quadrant lines in your scatter and bubble chart. **Note:** Quadrant lines are on by default for bubble charts and off by default for scatter charts.

The following image show a scatter chart without quadrant lines.

1. Create a scatter chart.
2. On the Format tab, in the Features group, click Grid.
3. On the drop-down menu, point to either Horizontal Gridlines or Vertical Gridlines, and then click More Grid Lines Options.

   The Format Grid Lines dialog box opens.
4. On the Quadrant Lines tab, select *Show Quadrant Line.* The quadrant line displays on the chart.

5. Click *OK* to close the Format Grid Lines dialog box. The following image shows the same chart with quadrant lines.

---

**Formatting Axis Labels**

**In this section:**
- Format Axis Dialog Box
- Axis Elements Right-Click Menu
- Using Axis Properties

Vertical and horizontal axes are based on the orientation of the graph. For example, in a vertical graph, the horizontal axis refers to the X axis and the vertical axis refers to the Y axis. In a horizontal graph, the horizontal axis refers to the Y axis and the vertical axis refers to the X axis. This is important to consider, since options could change depending on the orientation of the graph.

A chart can contain the following types of axis labels:

- Horizontal axis labels represent the X axis. They do not apply to pie, funnel, or gauge charts.
• Vertical axis labels represent the Y1 axis in a single axis chart. They represent a numeric scale, usually located on the left side of a vertical chart.

• Secondary horizontal and vertical labels can only be used when dual axes charts are selected.

Format Axis Dialog Box

Whether you access axis options from the ribbon, or the right-click menu, you are presented with the Format Axis dialog box of options for formatting for both vertical and horizontal axes. The Format Axis dialog box contains the following tabs:

• Scale
• Title
• Labels
• Advanced
Use the Scale tab to modify scale properties. The Scale tab is shown in the following image.

The Scale tab contains the following options:

- **Automatic Minimum.** Select this option to have the engine automatically supply the minimum value on the Y-axis scale. To use manual scaling, clear this option. You can then set the minimum value by entering a number into the Value text box.

- **Value.** Enter the minimum value in this text box if you have not selected Automatic Minimum.

- **Automatic Maximum.** Select this option to have the engine automatically supply the maximum value on the Y-axis scale. To use manual scaling, clear this option. You can then set the maximum value by entering a number into the Value text box.

- **Value.** Enter the maximum value in this text box if you have not selected Automatic Maximum.

- **Automatic Grid Step.** Select this option to automatically calculate the number of major grid steps. To use manual scaling, clear this option. You can then set the value by entering the number into the Value text box.

- **Value.** Enter the value in this text box if you have not selected Automatic Grid Step.
- **Logarithmic Scale.** Select this option to control whether or not the Y-axis scale progresses logarithmically instead of linearly. This option is disabled by default. When selected, the logarithmic base is set to 10.0, but can be changed by entering another value.

- **Log scale base.** Enter the base value to be shown on the logarithmic scale.

- **Include zero on scale.** Select this option to control whether or not a zero (0) value appears on the scale. This option is enabled by default.

Use the Title tab to create and style the title for the axis. The Title tab is shown in the following image.

The Title tab contains the following options:

- **Text.** Enter a title for the axis.

- **Style.** Click this icon to open the Style dialog box, where you can style the text.
Use the Labels tab to format the layout of the axis labels. The Labels tab is shown in the following image.

The Labels tab contains the following options:

- **Show Labels.** Select this option to display labels next to the axis. This is enabled by default. Clear this option to suppress labels.
  - **Axis side.** Select from this drop-down menu of position options for the labels on the axis. The options are Left (default), Right, or Both.
  - **Style labels.** Click this icon to open the Style dialog box, where you can style text.
  - **Stagger Labels.** Select this option to set the labels to appear staggered.
  - **Format Labels.** Select from this drop-down menu of preset formats that can be applied to the labels.
  - **Custom Format.** Select this option to use a custom format.

The Format Labels drop-down menu provides a list of preset formats that you can apply to labels. When you select a custom format, it must be defined using a custom format pattern. See the following table for a list and description of the characters that you can use in a custom format.
<table>
<thead>
<tr>
<th>Character</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>#</td>
<td>Is a digit.</td>
</tr>
<tr>
<td>0 (zero)</td>
<td>Shows as absent.</td>
</tr>
<tr>
<td>. (period)</td>
<td>Is a placeholder for a decimal separator.</td>
</tr>
<tr>
<td>, (comma)</td>
<td>Is a placeholder for a grouping separator.</td>
</tr>
<tr>
<td>; (semicolon)</td>
<td>Separates formats.</td>
</tr>
<tr>
<td>- (dash)</td>
<td>Is the default negative prefix.</td>
</tr>
<tr>
<td>% (percent)</td>
<td>Divides by 100 and shows as a percentage.</td>
</tr>
<tr>
<td>x</td>
<td>Determines that any other characters can be used in the prefix or suffix.</td>
</tr>
<tr>
<td>‘ (apostrophe)</td>
<td>Is used to quote special characters in a prefix or suffix.</td>
</tr>
</tbody>
</table>
Use the Advanced tab to modify additional axis properties. The Advanced tab is shown in the following image.

![Format Vertical Axis](image)

The Advanced tab contains the following options:

- **Exclude Minimum Label.** Select this option to exclude the label with the lowest axis value from the chart.

- **Exclude Maximum Label.** Select this option to exclude the label with the highest axis value from the chart.

- **Descending Axis.** Select this option to draw the axis in descending order.

- **Show axis line.** Select this axis to control the display of the axis baseline.

- **Line Style.** Click this icon to open the Line Style dialog box, where you can edit the color, weight, and style of the axis line.

- **Show zero line.** Select this option to control the display of the zero line.

- **Line Style.** Click this icon to open the Line Style dialog box, where you can edit the color, weight, and style of the zero line.
Custom Baseline. Select this option to control the display of the custom baseline.

Value. Enter a value for the custom baseline.

Line Style. Click this icon to open the Line Style dialog box, where you can edit the color, weight, and style of the custom baseline.

For instructions on how to open this dialog box, see the procedures in Using Axis Properties on page 293.

Secondary Axes Options

Formatting option are available for secondary axes in dual-axis charts. For example, in a vertical dual-axis chart, the secondary vertical axis refers to the Y2 axis.

The Format Secondary Axis dialog box contains the following tabs for both vertical and horizontal axes:

- General. For more information, see the Scale tab options in Format Axis Dialog Box on page 285.
- Title. For more information, see the equivalent tab in Format Axis Dialog Box on page 285.
- Labels. For more information, see the equivalent tab in Format Axis Dialog Box on page 285.
- Advanced. For more information, see the equivalent tab in Format Axis Dialog Box on page 285.

Axis Elements Right-Click Menu

When you right-click an axis label in a chart in Live Preview, a menu of options opens. The options for the right-click axis label elements are described in the following tables.
<table>
<thead>
<tr>
<th>Element</th>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Horizontal Labels</td>
<td>Delete</td>
<td>Deletes labels from the chart and updates the Live Preview accordingly.</td>
</tr>
<tr>
<td></td>
<td>Stagger</td>
<td>Controls the positioning of the labels. The On value positions the labels in a zigzag pattern. The Off default value positions the labels in a straight row.</td>
</tr>
<tr>
<td></td>
<td>Rotate</td>
<td>Rotates the labels a specified number of degrees.</td>
</tr>
<tr>
<td></td>
<td>Style Labels</td>
<td>Enables you to apply styling to the labels, using the Style dialog box. For more information, see <em>Style Dialog Box</em> on page 252.</td>
</tr>
<tr>
<td></td>
<td>More Axis Options</td>
<td>Opens the Format Axis dialog box. For more information, see <em>Formatting Axis Labels</em> on page 284.</td>
</tr>
<tr>
<td>Vertical Labels</td>
<td>Delete</td>
<td>Deletes labels from the chart and updates the Live Preview accordingly.</td>
</tr>
<tr>
<td></td>
<td>Stagger</td>
<td>Controls the positioning of the labels. The On value positions the labels in a zigzag pattern. The Off default value positions the labels in a straight row.</td>
</tr>
<tr>
<td></td>
<td>Rotate</td>
<td>Rotates the labels a specified number of degrees.</td>
</tr>
<tr>
<td></td>
<td>Format Labels</td>
<td>Formats the labels according to the value that you specify.</td>
</tr>
<tr>
<td></td>
<td>Style Labels</td>
<td>Enables you to apply styling to the labels, using the Style dialog box. For more information, see <em>Style Dialog Box</em> on page 252.</td>
</tr>
<tr>
<td></td>
<td>More Axis Options</td>
<td>Opens the Format Axis dialog box. For more information, see <em>Formatting Axis Labels</em> on page 284.</td>
</tr>
</tbody>
</table>
Using Axis Properties

**How to:**
- Delete Axis Labels
- Stagger Axis Labels
- Rotate Axis Labels
- Format Axis Labels
- Manually Set the Scale of an Axis
- Add an Axis Title
- Set Advanced Axis Properties

The following sections contain procedures for customizing an axis. The procedures are organized by the tab and group in which their associated options appear on the ribbon.

Axis labels appear by default.

**Procedure: How to Delete Axis Labels**

1. Create a chart.
2. You can delete axis labels in one of the following ways:
   - **Ribbon:** On the Format tab, in the Labels group, open the Axes drop-down menu, point to the axis that you are working with, and clear the Show Labels option.
   - **Right-Click Menu:** Right-click an axis label on the chart, select **Delete**.

   The axis labels are deleted from the chart.

**Procedure: How to Stagger Axis Labels**

1. Create a chart with at least one axis label on display.
2. Access the Stagger option in one of the following ways:
   - **Ribbon:** On the Format tab, in the Labels group, open the Axes drop-down menu, point to the axis that you are working with, and select Stagger Labels.
   - **Right-Click Menu:** Right-click an axis label on the chart, point to Stagger and select On.

   The axis labels are staggered.
**Procedure:** How to Rotate Axis Labels

1. Create a chart with axis labels.

2. Access the Rotate option in one of the following ways:
   - **Ribbon:** On the Format tab, in the Labels group, open the Axes drop-down menu, point to the axis that you are working with, point to Rotate Labels, and then select the degree to which you want to rotate the axis labels.
   - **Right-Click Menu:** Right-click an axis label on the chart, point to Rotate, and then select the degree to which you want to rotate the axis labels.

The axis labels are rotated.
The following image shows a chart with the axis labels rotated 45 degrees.

**Procedure: How to Format Axis Labels**

1. Create a chart with an axis label.

2. Access the list of axis label options in one of the following ways:
   
   - **Ribbon:** On the Format tab, in the Labels group, open the Axes drop-down menu, point to the axis that you are working with, and select *More Axis Options* to open the Format Axis dialog box. Open the Labels tab, and from the Labels option drop-down menu, select the formatting option that you want.

   - **Right-Click Menu:** Right-click an axis label, point to Format Labels, and select the formatting option that you want.

The axis labels are formatted accordingly.
Procedure: How to Manually Set the Scale of an Axis

1. Create a chart.
2. Open the Format Axis dialog box in one of the following ways:
   - **Ribbon**: On the Format tab, in the Labels group, open the Axes drop-down menu, point to the axis that you are working with, and select *More Axis Options*.
   - **Right-Click Menu**: Right-click an axis value on the chart, and select *More Axis Options*.

   The Format Axis dialog box opens.

3. On the scale tab, clear the *Automatic Minimum* option and enter your own minimum value in the *Value* text box.
4. Clear the *Automatic Maximum* option, and enter your own maximum value in the *Value* text box.
5. Clear the *Automatic Grid Step* option, and enter your own grid step value in the *Value* text box.
6. Optionally, you can select the *Logarithmic Scale* option and enter the log scale base in the text field of that name. You can also clear the *Include zero on scale* option if you do not want zero to appear on the axis.
7. Click *OK* to close the dialog box.
The axis scale is set accordingly.

Procedure: How to Add an Axis Title

1. Create a chart with an axis label.

2. Open the Format Axis dialog box in one of the following ways:
   - **Ribbon:** On the Format tab, in the Labels group, open the Axes drop-down menu, point to the axis that you are working with, and select *More Axis Options*.
   - **Right-Click Menu:** Right-click an axis label, and select *More Axis Options*.

   The Format Axis dialog box opens.

3. On the Title tab, type the axis title in the *Text* field.

4. Click the *Style text* icon to open the Style dialog box, where you can style the text.

   The axis title is styled accordingly.

   **Note:** Right-click the axis title to delete, change, or style the axis title.

   The following image shows a chart with a title added to the vertical axis.
Procedure: How to Set Advanced Axis Properties

1. Create a chart with an axis label.

2. Open the Format Axis dialog box in one of the following ways:
   - **Ribbon:** On the Format tab, in the Labels group, open the Axes drop-down menu, point to the axis that you are working with, and select *More Axis Options*.
   - **Right-Click Menu:** Right-click an axis label, and select *More Axis Options*.
     
3. On the Advanced tab, set the following options:
   - Exclude Minimum Label
   - Exclude Maximum Label
   - Descending Axis
   - Show axis line
   - Show zero line
   - Custom Baseline (Value)
     
4. Click **OK**.

   The axis advanced options are set accordingly.

Formatting a Frame and a Background

In this section:
- Frame & Background Dialog Box
- Frame and Background Right-Click Menu
- Using Frame and Background Properties

The frame of a chart is the area that contains the plot points. It is also the area in which horizontal and vertical gridlines are drawn.

The background of a chart is the area around the frame.
You can adjust the appearance of the frame and background to achieve different visual effects for your charts. For example, you can change the appearance of the chart frame line, or you can change the color of the background of your chart.

**Frame & Background Dialog Box**

Whether you access frame and background options from the ribbon, or the right-click menu, you are presented with the Frame & Background dialog box of options for formatting the frame and background of a chart. The Frame & Background dialog contains the following tabs:

- **Frame**
- **Frame Edge**
- **Background**

The Frame & Background dialog box and pertinent tabs are discussed in this section for the following types of charts:

- **2D Charts and 2D Charts with 3D Effects (Frame and Frame Edge tabs)**
- **Pie Charts (Frame and Frame Edge tabs)**
- **3D Charts (Left Wall, Right Wall, Floor, and Advanced tabs)**

**Note:** The options in the Frame tab vary based on the chart type selected.
Use the Frame tab for 2D charts and 2D charts with 3D effects to set a frame depth angle and depth radius, select a fill for a frame, and set a shadow for a frame for these types of charts. The Frame tab for 2D charts and 2D charts with 3D effects is shown in the following image.

The Frame tab for 2D charts and 2D charts with 3D effects contains the following options:

- **Depth Angle.** Enter the angle from the front of the chart to the back where the chart risers and frames are drawn. You can set the depth angle from zero to 180 degrees, but it must be used along with Depth Radius.

- **Depth Radius.** Enter how far out the extruded frame will be extended. Small values, such as zero, produce very narrow charts. Large values, the maximum being 100, produce thicker charts.

**Fill**

- **No fill.** (Default). Select this option to keep the legend colorless.

- **Solid fill.** Select this option to display the Color and Transparency options.
- **Color.** Click this icon to open the Color dialog box, where you can select a color for a frame.

- **Transparency.** Move the slider to make the frame opaque (0%) or transparent (100%). The default is 0%.

- **Gradient fill.** Select this option to display the direction of the gradient, the color pattern of the gradient, and the degrees of transparency for the two colors that make up the gradient. A gradient is a smooth color transition or blending of one color to another. The number of colors to use in a gradient is defined by the stop or pin elements.

- **Direction.** Select from this drop-down menu to set the direction of the gradient fill. The options are:
  - Gradient right
  - Gradient left
  - Gradient down
  - Gradient up
  - Gradient down left
  - Gradient up left
  - Gradient down right
  - Gradient up right
  - Radial
  - Radial top left
  - Radial top right
  - Radial bottom left
  - Radial bottom right
  - Radial pie
  - Radial pie inverted

**Gradient style**

- **Color Pattern.** Select the color pattern for the data series. The color pattern option on the left is an AB wash that uses two colors in the pattern color1 - color2, for example, red-green. The color pattern option on the right is an ABA wash that uses two colors in the pattern color1 - color2 - color1, for example, red-green-red.
Formatting a Frame and a Background

- **First Color.** Click this icon to open the Color dialog box, where you can select a color for the first color.

- **Second Color.** Click this icon to open the Color dialog box, where you can select a color for the second color.

**Shadow**

- **Show Shadow.** Select this option to set a shadow.

Use the Frame Edge tab for 2D charts and 2D charts with 3D effects to set a frame depth angle and depth radius, select a fill for a frame, and set a shadow for a frame for these types of charts. The Frame Edge tab is shown in the following image.

The Frame tab for 2D charts and 2D charts with 3D effects contains the following options:
- **Automatically Shade Frame Edge.** Select this option to automatically shade the frame edge. Clear this option to enable the Side Frame and Bottom Frame options.

**Side Frame**

- **Show Color.** Select this option to show the color of the side frame.
- **Color.** Click this icon to open the Color dialog box, where you can select a color for the side frame.
- **Show Border Color.** Select this option to show the color of the border of the side frame.
- **Border Color.** Click this icon to open the Color dialog box, where you can select a color for the border of the side frame.

**Bottom Frame**

- **Show Color.** Select this option to show the color of the bottom frame.
- **Color.** Click this icon to open the Color dialog box, where you can select a color for the bottom frame.
- **Show Border Color.** Select this option to show the color of the bottom frame.
- **Border Color.** Click this icon to open the Color dialog box, where you can select a color for the border of the bottom frame.
Use the Frame tab for pie charts to set pie depth and tilt, select a fill and color for a pie frame, and set a shadow for the frame. The Frame tab is shown in the following image.

The Frame tab for pie charts contains the following options:

- **Pie Depth.** Set the depth of the edge of a pie chart. You can select a value from zero to 100 to set the thickness of an edge.

- **Pie Tilt.** Set the tilt of the pie chart. The smaller the value you add, the flatter the pie chart appears. The larger the value you add, more of the pie edge appears.

**Fill**

- **No fill.** (Default). Results in no color added to the edge of the pie.

- **Solid fill.** Select this option to display the Color and Transparency options.
  
  - **Color.** Click this icon to open the Color dialog box, where you can select a color for the frame.

  - **Transparency.** Move the slider to make the fill opaque (0%) or transparent (100%). The default is 0%.
Gradient fill. Select this option to display the direction of the gradient, the color pattern of the gradient, and the degrees of transparency for the two colors that make up the gradient. A gradient is a smooth color transition or blending of one color to another. The number of colors to use in a gradient is defined by the stop or pin elements.

Direction. Select from this drop-down menu to set the direction of the gradient fill. The options are:
- Gradient right
- Gradient left
- Gradient down
- Gradient up
- Gradient down left
- Gradient up left
- Gradient down right
- Gradient up right
- Radial
- Radial top left
- Radial top right
- Radial bottom left
- Radial bottom right
- Radial pie
- Radial pie inverted

Gradient Style

- Color Pattern. Select the color pattern for the data series. The color pattern option on the left is an AB wash that uses two colors in the pattern color1 - color2, for example, red-green. The color pattern option on the right is an ABA wash that uses two colors in the pattern color1 - color2 - color1, for example, red-green-red.

- First Color. Click this icon to open the Color dialog box, where you can select a color for the first color.

- Second Color. Click this icon to open the Color dialog box, where you can select a color for the second color.

Shadow
Show Shadow. Select this option to set a shadow around the frame.

Use the Frame Edge tab for pie charts to set the edge of a pie frame. The Frame Edge tab is shown in the following image.

The Frame Edge tab for pie charts contains the following options:

- **Automatically Shade Frame Edge.** Select this option to automatically shade the frame edge. Clear this option to enable the Side Frame and Bottom Frame options.

- **Show Color.** Select this option to show the color of the side frame.

- **Color.** Click this icon to open the Color dialog box, where you can select a color for side frame.

- **Show Border Color.** Select this option to show the color of the border of the side frame.
Border Color. Click this icon to open the Color dialog box, where you can select a color for the border of the side frame.

Bottom Frame

- Show Color. Select this option to show the color of the bottom frame.
- Color. Click this icon to open the Color dialog box, where you can select a color for the bottom frame.
- Show Border Color. Select this option to show the color of the bottom frame.
- Border Color. Click this icon to open the Color dialog box, where you can select a color for the border of the bottom frame.

Use Wall and Floor tabs to set the walls and floor of a 3D chart. The Left Wall tab is shown in the following image.

These Wall and Floor tabs contain the following options:

- Show Wall or Show Floor. Select this option to show the wall or floor (depending on the tab) of the 3D chart.
- Wall Thickness. Specify the thickness of the wall or floor.
- Cube Size. Specify the cube size of the wall or floor.
- Color. Click this icon to open the Color dialog box, where you can select a color for the wall or floor.
- **Border Color.** Click this icon to open the Color dialog box, where you can select a color for the border of the wall or floor.

- **Show Wall (Left Wall).** Select this option to show the left wall.

- **Show Wall (Right Wall).** Select this option to show the right wall.

- **Show Floor.** Select this option to show the floor.

Use the Advanced tab for 3D charts to modify additional properties for 3D frames. The Advanced tab for 3D charts is shown in the following image.

The Advanced tab contains the following options:

- **Viewing Angles.** Select from a drop-down menu of viewing angles for three-dimensional charts. The options are:
  - Standard
  - Group View
  - Series View
  - Distorted Value
  - Isometric Standard
- Distorted Standard
- Emphasize Group
- Blast-O-Vision
- Thin Wall
- Isometric Group View
- Isometric Group View #2
- High Backed
- Upward Distorted
- Down Tilt
- Narrow Isometric
- Isometric view by groups
- Custom

- **Isometric Projection.** Select this option to ignore perspective distortion in a project graph cube from an isometric view.

- **Proportional Cube.** Select this option to define the axis size proportional to the number of series or groups.

- **Automatic shading of walls.** Select this option to shade chart walls.

- **Automatically Shade Frame Edge.** Select this option to automatically shade the frame edge.

- **3D Zoom Factor.** Enter a value in the text box to set the global scaling factor for zooming in and out in a 3D chart. Smaller values zoom out and produce a smaller display of the chart within a frame. Larger values zoom in and produce a larger display of the chart within a frame.

- **Pan Horizontally.** Enter a value in the text box to pan a 3D chart in the horizontal direction. Smaller values move the frame of the chart to the left. Larger values move the frame of the chart to the right.

- **Pan Vertically.** Enter a value in the text box to pan a 3D chart in the vertical direction. Smaller values move the frame of the chart upward. Larger values move the frame of the chart downward.
Use the Background tab to set and customize a border for a chart. The Background tab is shown in the following image.

The Background tab contains the following options:

- **Show Border Color.** Select this option to show the color of the border.

- **Border Color.** Click this icon to open the Color dialog box, where you can select a color for the border.

- **Solid fill.** Select this option to display the Color and Transparency options.
  
  - **Color.** Click this icon to open the Color dialog box, where you can select a color for the frame.
  
  - **Transparency.** Move the slider to make the background opaque (0%) or transparent (100%). The default is 0%.

- **Gradient fill.** Select this option to display the direction of the gradient, the color pattern of the gradient, and the degrees of transparency for the two colors that make up the gradient. A gradient is a smooth color transition or blending of one color to another. The number of colors to use in a gradient is defined by the stop or pin elements.

  - **Direction.** Select from this drop-down menu to set the direction of the gradient fill. The options are:
    
    - Gradient right
Gradient left
Gradient left
Gradient down
Gradient up
Gradient down left
Gradient up left
Gradient down right
Gradient up right
Radial
Radial top left
Radial top right
Radial bottom left
Radial bottom right
Radial pie
Radial pie inverted

Gradient Style

- **Color Pattern.** Select the color pattern for the data series. The color pattern option on the left is an AB wash that uses two colors in the pattern color1 - color2, for example, red-green. The color pattern option on the right is an ABA wash that uses two colors in the pattern color1 - color2 - color1, for example, red-green-red.

- **First Color.** Click this icon to open the Color dialog box, where you can select a color for the first color.

- **Second Color.** Click this icon to open the Color dialog box, where you can select a color for the second color.

For instructions on how to open this dialog box, see the procedures in *Using Frame and Background Properties* on page 313.
# Frame and Background Right-Click Menu

When you right-click a chart background, a menu of options opens. The options for the background and frame elements are described in the following table.

<table>
<thead>
<tr>
<th>Element</th>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Background</td>
<td>Background Color</td>
<td>Enables you to specify the color of the background, using the Color dialog box. For instructions, <em>How to Change the Color of the Background</em> on page 315.</td>
</tr>
<tr>
<td>Show legend</td>
<td></td>
<td>Controls the display of the legend on the background. When selected, it displays the legend. When cleared, it suppresses the display of the legend.</td>
</tr>
<tr>
<td>More Frame and Background Options</td>
<td></td>
<td>Opens the Frame &amp; Background dialog box. For more information, see <em>Frame &amp; Background Dialog Box</em> on page 299.</td>
</tr>
<tr>
<td>Frame</td>
<td>Frame Color</td>
<td>Enables you to specify the color of the frame, using the Color dialog box. For more information, see <em>Color Dialog Box</em> on page 46.</td>
</tr>
<tr>
<td>Show 3D</td>
<td></td>
<td>Controls the depth of the frame. The value On renders the frame in 3D depth. The value Off renders the frame in one dimension. For instructions, see <em>How to Set 3D Depth on a Bar Chart</em> on page 345.</td>
</tr>
<tr>
<td>More Frame and Background Options</td>
<td></td>
<td>Opens the Frame &amp; Background dialog box. For more information, see <em>Frame &amp; Background Dialog Box</em> on page 299.</td>
</tr>
</tbody>
</table>
Using Frame and Background Properties

**How to:**
- Change the Color of the Frame
- Change the Color of the Background

The following sections contain procedures for customizing frame and background properties. The options for the following procedures are found in the Features group of the Format tab.

**Procedure:** How to Change the Color of the Frame

The default color of the frame in a chart is determined by the Document Theme selected on the Options window. For more information, see *Changing User Preferences* on page 25. The following image shows a chart with the default frame color.

This procedure describes how to change the color of the frame.

1. Create a chart.
2. Access the Frame & Background dialog box in one of the following ways:
   - **Ribbon:** On the Format tab, in the Features group, click *Frame & Background.*
Right-Click Menu: Right-click the chart, and select More Frame & Background Options. The Frame & Background dialog box opens.

3. On the Frame tab, in the Fill area, click the Color icon. Note: Solid fill must be selected for the Color icon to appear.

The Color dialog box opens. Select a new color for the frame. For more information on the Color dialog box, see Color Dialog Box on page 46. You can also set the depth angle and depth radius for the frame, as well as set a shadow for the frame.

4. Click OK.

The chart displays the new frame color.

The following image shows the same chart with a new frame color.
**Procedure: How to Change the Color of the Background**

The default color of the background of a chart is determined by the Document Theme selected on the Options window. For more information, see *Changing User Preferences* on page 25. The following image shows a chart with the default background color.

![Chart with default background color](image)

1. Create a chart.
2. Open the Frame & Background dialog box in one of the following ways:
   - **Ribbon:** On the Format tab, in the Features group, click *Frame & Background*.
   - **Right-Click Menu:** Right-click the background of the chart, and select *Background Color*.

   The Frame & Background dialog box opens.

3. On the Background tab, in the Fill area, click the *Color* icon.

   The Color dialog box opens. Select a new color for the background. For more information on the Color dialog box, see *Color Dialog Box* on page 46.

4. Click *OK*.

   The chart displays the new background color.
In the following image, the chart now has a background color.
Formatting a Gauge Chart

In this section:
- Format Gauge Dialog Box
- Gauge Elements Right-Click Menu
- Using Gauge Properties

A gauge chart, is a circular chart, that indicates the current position of a single data value within a given spectrum. A gauge chart shown in the following image.

You can change the appearance of a gauge chart by using the gauge chart options found on the Format Gauge dialog box.
Format Gauge Dialog Box

Whether you access gauge options from the ribbon, or the right-click menu, you are presented with the Format Gauge dialog box of options for formatting a gauge chart. Such options include setting and styling a title for the gauge chart, setting tick marks, enabling and styling color bands, as well as setting advanced options, such as the gauge start and stop angle.

The Format Gauge dialog box contains the following tabs:

- General Options
- Axis Scale & Labels
- Tick Marks
- Bands
- Advanced
Use the General Options tab to set general gauge options. The General Options tab is shown in the following image.

The General Options tab contains the following options:

- **Gauges per row.** Enter or select how many gauges appear on each row. The default setting displays two gauge charts. A maximum of 32 gauge charts can appear on each row.
Formatting a Gauge Chart

- **Background Style.** Select from a drop-down menu a style for the background. The options are:
  - Green Bevel (default)
  - Grey Bevel
  - Gold Bevel
  - Grey Bevel 2
  - Gold Bevel 2
  - Thin Black
  - Thin Black 2
  - Grey Bevel 3
  - Grey
  - Blue Bevel
  - Grey Flat
  - Turquoise Bevel

**Gauge Needle**

- **Style.** Select a style from a drop-down menu of options to be applied to the gauge needle. The options are:
  - Thin
  - Thick
  - Normal (default)
  - Screwdriver
  - Pencil

- **Color.** Click this icon to open the Color dialog box, where you can select a color for the gauge needle. **Note:** If you are working with a gauge chart with more than one series, then you use the Format Series dialog box to format the color of the gauge needle and its border.

- **Border Color.** Click this icon to open the Color dialog box, where you can select a color for the gauge needle border. **Note:** If you are working with a gauge chart with more than one series, then you use the Format Series dialog box to format the color of the gauge needle and its border.
Gauge Title

- **Show title.** (Default) Displays a gauge title appear for each gauge. Clear this option to suppress the title.

- **Position.** Select a position for the gauge title. The options are:
  - Above (default)
  - Center
  - Below

- **Style.** Click this icon to open the Style dialog box, where you can style text.

Gauge value

- **Show value.** (Default) Clear this option to suppress the gauge value.

- **Style.** Click this icon to open the Style dialog box, where you can style text.
Use the Axis Scale & Labels tab to set the axis scale and label properties for the gauge needle. The Axis Scale & Labels tab is shown in the following image.

The Axis Scale & Labels tab contains the following options:

**Scale**

- **Automatic Minimum.** (Default) Sets the engine to automatically supply the minimum value on the scale. Clear this option to manually set the minimum value by entering a number into the Value text box.

- **Value.** Enter the minimum value in this text box if you have not selected Automatic Minimum.

- **Automatic Maximum.** (Default) Sets the engine to automatically supply the maximum value on the scale. Clear this option to manually set the maximum value by entering a number into the Value text box.
Value. Enter the maximum value in this text box if you have not selected Automatic Maximum.

Labels

Show Labels. (Default) Displays labels next to the axis. Clear this option to suppress labels.

Style Labels. Click this icon to opens the Style dialog box, where you can style text.

Format Labels. Select from a drop-down menu of present formats that can be applied to the labels. When a custom format is selected, the format must be defined using a custom format pattern. For a list and description of the characters that you can use in a custom format, see the table in Formatting Data Labels on page 242.

Custom Format. Text field to enter the custom format that you want to use.
The Tick Marks tab contains options to format tick marks on a gauge chart. The Tick Marks tab is shown in the following image.

The Tick Marks tab contains the following options:

- **Automatic Grid Step.** (Default) Automatically calculates the number of major grid steps in a gauge chart. Clear this option to manually set the value by entering a number in the Value text box.

- **Value.** Enter the value in this text box if you have not selected Automatic Grid Step.

- **Tick Color.** Click this icon to open the Color dialog box, where you can select a color for the tick marks.

- **Tick Mark Length.** Enter a value for the relative length of major tick marks in a gauge chart. The valid range is from 0.0 to 0.5. If you set the smallest value, major tick marks do not appear.
The Bands tab contains options to format the color of the scale background on a gauge chart. The Bands tab is shown in the following image.

The Bands tab contains the following options:

- **Band 1.** Opens a drop-down menu of available bands.
  - **Add.** Adds the band selected from the drop-down menu of bands to the gauge chart. You can create up to five bands for a gauge chart.
  - **Remove.** Removes the band selected from the drop-down menu of bands to the gauge chart.
- **Minimum Value.** Enter a minimum value to a quality band in the gauge chart.
- **Maximum Value.** Enter a maximum value to a quality band in the gauge chart.
- **Border Color.** Opens the Color dialog box, where you can edit the color of the gauge band border.
Fill

- **No fill.** Removes fill from the quality band.
- **Solid fill.** (Default) Applies a solid color to the quality band.
- **Color.** Click this option to open the Color dialog box, where you can select the color for the quality band.
- **Transparency.** Move the slider to make the band opaque (0%) or transparent (100%). The default is 0%.

The Advanced tab contains options to set additional properties for the gauge needle. It is shown in the following image.

![Format Gauge](image)

The Advanced tab contains the following options:

- **Descending Axis.** Select this option to draw the gauge scale in descending order. When this option is cleared (default), the gauge scale is drawn in ascending order.
- **Show Zero Label.** (Default) Displays the zero label appear on the axis scale. Clear this option to start the gauge at a another value.

- **Gauge Center by Quality.** Select this option to have the center of the gauge needle appear in the same the color as the band it is pointing to.

- **Gauge Start Angle.** Enter a value to rotate the gauge start angle to a specified number of degrees. Values can range from 0 to 359 degrees. The default is 220 degrees.

- **Gauge Stop Angle.** Enter a value to rotate the gauge stop angle to a specified number of degrees. Values can range from 0 to 359 degrees. The default is 320 degrees. Setting a start angle to 0, and a stop angle to 180, creates a semi-circle.

- **Relative Inner Radius.** Enter a value to define the inner radius of the gauge bands and labels relative to the outer background of the gauge. Smaller values, such as 0.0, place the inner radius closer to the center of the gauge. A maximum value of 1.0, places the inner radius close to the gauge outline.

- **Relative Thickness.** Enter a value to define the relative thickness of the gauge bands. Values can range from 0.0 to 1.0.

- **Same Size Gauges.** This option applies to multi-category gauge charts. If you are working with three or more gauges per row, you can select this option to have the gauges display in the same size.

**Gauge Elements Right-Click Menu**

When you right-click a gauge chart, a menu containing the More Gauge Options becomes available. Select this option to open the Format Gauge dialog box.
Using Gauge Properties

**How to:**

- Set the Number of Gauges Per Row
- Set the Minimum and Maximum Axis Scale Values
- Style Axis Labels
- Format Axis Labels
- Rotate Axis Labels
- Set Gauge Tick Marks
- Set Gauge Color Bands
- Match Needle Center Color to Band Color (Gauge Center by Quality)
- Style a Gauge Needle
- Set Gauge Needle Colors in a Multi Series Gauge Chart

The following sections contain procedures for gauge properties. The Gauges option can be found on the Format tab, in the Features group. **Note:** This option is only available when you are working with a gauge chart.
Procedure: How to Set the Number of Gauges Per Row

If you have multiple gauges on a chart, you might want to specify how many gauges appear on each row. In the following example, a maximum of two gauges per row has been set.

1. Create a gauge chart that has multiple values.
2. Open the Format Gauge dialog box in one of the following ways:
   - **Ribbon:** On the Format tab, in the Features group, click Gauges.
   - **Right-Click Menu:** Right-click the gauge chart and select More Gauge Options.

   The Format Gauge dialog box opens.

3. On the General options tab, in the Gauges per row field, enter or select the number of gauges that you want to appear on one row.
4. Click OK.

   The gauges now appear on one row.
After changing the setting from the default of 2 gauges per row to 3 gauges per row, all the charts now appear on one row.

![Gauge Chart Example]

*Formatting a Gauge Chart*
Procedure: How to Set the Minimum and Maximum Axis Scale Values

The following image shows a gauge chart with the scale values automatically supplied by the chart engine.

1. Create a gauge chart. The following image shows a gauge chart with default settings.

2. Open the Format Gauge dialog box in one of the following ways:
   - **Ribbon:** On the Format tab, in the Features group, click Gauges.
   - **Right-Click Menu:** Right-click the gauge chart, and select More Gauge Options.

   The Format Gauge dialog box opens.

3. On the Axis Scale & Labels tab, in the Scale area, either accept the minimum and maximum values for the scale automatically supplied by the chart engine, or enter your own in the Value fields.

4. Click Apply.
The gauge scale reflects the selections that you have made.

The following image shows the changes that were applied to the axis scale of the gauge chart in the preceding image. The automatic minimum value was cleared and a value of 20000 was set. The automatic maximum value was cleared and a value of 60000 was set.

![Gauge Chart Image]

Procedure: How to Style Axis Labels

1. Create a gauge chart.
2. Open the Style dialog box in one of the following ways:
   - **Ribbon:** On the Format tab, in the Features group, click Gauges to open the Format Gauge dialog box. In the Format Gauge dialog box, open the Axis Scale & Labels tab. In the Labels area, click the Style Labels icon.
   - **Right-Click Menu:** Right-click an axis label, and click Style.

The Style dialog box opens.
3. Select your styling options.

4. Click OK.

The scale labels reflect the style selections that you have made.

The following image shows a gauge chart with the axis labels in bold red Courier font.

---

**Procedure: How to Format Axis Labels**

1. Create a gauge chart.

2. Access the menu of available format options for axis labels in one of the following ways:

   - **Ribbon:** On the Format tab, in the Features group, click Gauges to open the Format Gauge dialog box. In the Format Gauge dialog box, open the Axis Scale & Labels tab. In the Labels area, open the Format Labels drop-down menu.

   - **Right-Click Menu:** Right-click an axis label, and point to Format.

The menu of available format options opens.
3. Select your format option.

**Note:** If you select a custom format (for example, User Pattern, or Use Pattern /100), from the Format Labels menu on the Format Gauge dialog box, the Custom Format menu becomes available. When you select a custom format, it must be defined using a custom format pattern. For a list and description of the characters that you can use in a custom format, see the table in *Formatting Data Labels* on page 242.

4. Click **OK**.
   The scale labels reflect the format selection that you have made.

**Procedure:**  **How to Rotate Axis Labels**

1. Create a gauge chart.

2. Right-click an axis label.

3. On the right-click menu, point to Rotate, then select the degree to which you want the labels rotated.

   The following image shows a gauge chart with the axis labels rotated 45 degrees.
**Procedure:** How to Set Gauge Tick Marks

This procedure describes how to set the grid step, tick color, and tick length for the major and minor tick marks.

The following image shows a gauge chart with default tick marks.

1. Create a gauge chart.
2. Open the Format Gauge dialog box in one of the following ways:
   - **Ribbon:** On the Format tab, in the Features group, click Gauges.
   - **Right-Click Menu:** Right-click the gauge chart and select More Gauge Options.

   The Format Gauge dialog box opens.

3. On the Tick Marks tab, for the Automatic Grid Step, either accept the value automatically supplied by the chart engine, or enter your own, in the Value fields.
4. Click the Tick Color icon, to open the Color dialog box, where you can select a color for the tick mark.
5. For the Tick Mark Length, either accept the value automatically supplied by the chart engine, or enter your own, in the Value fields.
The following image shows the same gauge chart. The major ticks marks have been changed to red from black. They are now .30 in length, double their original size of .15. The minor tick marks are now blue instead of black. Their size has also been increased. They are now .10 in length, instead of .05.
Procedure: How to Set Gauge Color Bands

The following image shows the gauge chart without color bands.

1. Create a gauge chart.
2. Open the Format Gauge dialog box in one of the following ways:
   - **Ribbon:** On the Format tab, in the Features group, click Gauges.
   - **Right-Click Menu:** Right-click the gauge chart, and select More Gauge Options.

   The Format Gauge dialog box opens.

3. Set the minimum and maximum value for each band that you want to appear on the gauge chart.
4. Set the color of the fill and border for each color band.

   **Note:** The gradient fill option is not available for color bands.
5. Click OK to close the Format Gauge dialog box.

   The bands are formatted accordingly.
The following images shows a gauge chart with color bands.

**Procedure:** *How to Match Needle Center Color to Band Color (Gauge Center by Quality)*

This option matches the needle center color to the color of the band that the needle is pointing to.

1. Create a gauge chart.
2. Open the Format Gauge dialog box in one of the following ways:
   - **Ribbon:** On the Format tab, in the Features group, click Gauges.
   - **Right-Click Menu:** Right-click the gauge chart and select More Gauge Options.

   The Format Gauge dialog box opens.
3. On the Bands tab, set the minimum and maximum value for each band that you want to appear on the gauge chart.
4. Set the color of the fill and border for each color band.
Note: The gradient fill and transparency options are not available for gauge needles.

5. On the Advanced tab, select Gauge Center by Quality.

6. Click OK to close the Format Gauge dialog box.

The color of the center of the gauge needle now matches the color of the band.

The following image shows a gauge chart with the center of the gauge needle in the same color as the band it is pointing to.

Procedure: How to Style a Gauge Needle

This procedure explains how to change the gauge needle from the Normal style to the Pencil style.

1. Create a gauge chart.

2. Open the Format Gauge dialog box in one of the following ways:

   Ribbon: On the Format tab, in the Features group, click Gauges.
Right-Click Menu: Right-click the gauge chart, and select More Gauge Options.

3. The Format Gauges dialog box opens.

4. In the General Options tab, in the Gauge Needle section, from the Style drop-down menu, select Pencil.

5. Click OK.

The gauge needle changes to a pencil.

The following image shows a gauge chart styled with a pencil.

![Gauge Chart Styled with Pencil](image)

**Procedure:** How to Set Gauge Needle Colors in a Multi Series Gauge Chart

You cannot change the fill color and border color of the needles in a multi-series gauge chart through the General Options tab of the Format Gauge dialog box. You can do so through the Format Series dialog box. However, you can still use the General Options tab to change the style of the needle.
The following image shows gauge charts with two series of data.

1. Create a gauge chart with more than one measure.
2. On the Series tab, from the Series drop-down menu, select the series that you want to style.
3. In the Properties group, click Style.
   The Format Series dialog box opens.
4. On the Fill tab, select the fill and color options for the gauge needle for the selected series.
5. On the Border tab, select the Show Border Color option, if you want the gauge needle to have a border. You can select the color for the border, as well.
6. Click Apply.
7. Repeat steps 2 through 5 for each series gauge needle that you want to style.
8. When you are finished, click OK to close the Format Series dialog box.
   The color of the gauge needles and their borders changes accordingly.
The following image shows the same gauge chart with the needles with new colors. The *Show Border Color* option has been enabled with the default color of black for the border color.

### Formatting Page Headings and Page Footings

**How to:**

Add a Page Heading and Page Footing to a Chart

Control the Rendering of a Page Heading and Page Footing

Page headings and page footings supply context and key information about a chart, such as its purpose, audience, and author. Page headings and page footings also enhance visual appeal.

**Procedure:** How to Add a Page Heading and Page Footing to a Chart

The procedure uses sample values, but you can supply values that apply to your own charts. This feature is available in Query Design view, Live Preview, and Document view.

1. Create a chart.
2. With your chart open, on the Home tab, in the Report group, click *Header & Footer.*
   
   The Header & Footer dialog box opens.
Tip: Another way to access the Heading & Footing dialog box is to click the arrow next to the Header & Footer button. Doing so opens a drop-down menu from which you can select the heading or footing that you want to work with. After you make your selection, the Header & Footer dialog box opens, and the heading or footing that you selected is active.

3. Click the tab for the page heading or page footing, depending on which you want to add.

   By default, the Page Heading tab is selected. In this procedure, accept the default to add a page heading first.

4. Click inside the design area of the dialog box, and type the text for the page heading.

   For example, the text for a sample page heading might be Customers By Occupation.

5. Using the styling options, apply styling to the page heading text.

   In this example, the heading is styled in 14 pt. bold Helvetica with center alignment.

6. Click Apply to save the changes that you have made, without closing the dialog box.

7. To add a page footing, click the Page Footer tab.

   For this procedure, you are going to add one of the supplied quick text options, followed by some text of your own.

8. Click the down arrow next to the preformatted text button, and click Created by from the drop-down list, as shown in the following image.

9. Complete the text by typing the applicable value within the supplied text, for example, Sales Manager.

10. Change the styling as you want.

11. Click OK to save the page heading and page footing and close the Header & Footer dialog box.

   The chart contains the page heading and page footing that you added and styled.
To make changes to either the page heading or page footing, return to Design view. Right-click the header or footer, and click Edit from the drop-down menu.

**Procedure:** How to Control the Rendering of a Page Heading and Page Footing

You can control the way in which a page heading and page footing are rendered on a chart at run time.

1. Create a chart.
2. Open the Header & Footer dialog box, as described in How to Add a Page Heading and Page Footing to a Chart on page 342.
3. Click the Text options for chart button.

A drop-down menu, with two options for rendering the page heading and page footing, opens.

**Tip:** Your selection for a page heading also applies to a page footing, and vice versa.

- Create Header and Footer as text, renders the heading and footing as text elements that are separate from the chart image. This is the default value.
Embed Header and Footer in the chart, renders the heading and footing text as part of the chart image.

4. Select *Embed Header and Footer in the chart*.
   
The heading and footing text are rendered as part of the chart image.

5. Click **OK** to save your selection and close the Heading & Footing dialog box.

### Using Additional Formatting Features

**How to:**
- Set 3D Depth on a Bar Chart
- Rotate a Chart
- Display Reference Lines
- Display Annotations

**Procedure:**  **How to Set 3D Depth on a Bar Chart**

You can apply a 3D-effect to a 2D-chart. **Note:** If you find that the depth of the 3D effect makes it difficult to distinguish the values on the Y-axis scale, then you can turn this option off. This procedure explains how to set the 3D effect for a default vertical bar chart.
The following image shows a bar chart before the 3D effect is applied.

1. Create a 2D chart.

2. In Live Preview, apply the 3D effect in one of the following ways:
   - **Ribbon:** On the Format tab, in the Features group, click *3D Effect*. 
Right-Click Menu: Right-click the frame of the chart, point to Show 3D, and select On, as shown in the following image.

The 3D effect is applied to the chart, as shown in the following image.
Procedure: How to Rotate a Chart

You can rotate bar, line, and area charts to change the orientation of the data.

The following image shows a vertical chart before it is rotated.

1. Create a chart.
2. On the Format tab, in the Features group, click Rotate.
The chart is rotated 90 degrees clockwise. The following is an example of the same chart above, now rotated.

**Procedure:** How to Display Reference Lines

Reference lines draw attention to specific data locations on a chart. You can add up to three horizontal (X axis) and three vertical (Y axis) reference lines to a chart.

1. Create a chart.
2. On the Format tab, in the Features group, click Reference.
3. In the drop-down menu that opens, select one of the following:
   - Add Reference Line to Y axis
   - Add Reference Line to X axis
The Reference Line dialog box opens, as shown in the following image.

4. Create the reference line using either a static value that you set or a dynamic field that you select from your data source.

To create a reference line by value:

a. Select the Value option.

b. In the Value text field, type the value that you want to distinguish with the reference line.

c. Go to step 5.

To create a reference line by field:

a. Select the Field option.

b. From the Field drop-down menu, select the field that you want to distinguish with the reference line.

a. Go to step 5.

5. In the Text field, type the text for the reference line.

6. In the Position drop-down menu, select the position for the reference line on the chart.

The options are:

- Above Center (default)
- Above Left
- Above Right
- Below Center
7. Click the **Style** button to set the style for the reference line. The options are:
   - **Solid** (default)
   - **Dots**
   - **Many Dots**
   - **Dashed**
   - **Dashed Dots**
   - **Long Dash**
   - **Mixed Dashes**

8. Click the **Color** button to open the Color dialog box, where you can select a color for the reference line and the text.

9. Click the **Weight** button to select the weight of the reference line. The options are:
   - **1px** - Light (default)
   - **2px** - Medium
   - **3px** - Heavy

10. Click **OK** to save the options that you have selected, and close the Reference Line dialog box.
    
    The reference line is added to the chart.
Procedure: How to Display Annotations

Annotations are explanatory notes or comments. You can add up to eight annotations on a chart.

1. Create a chart.
2. On the Format tab, in the Features group, click Annotate.
3. In the drop-down menu that opens, click Add an annotation.
The Annotation dialog box opens, as shown in the following image.

![Annotation dialog box](image)

4. In the text input field, type the text for the annotation.

5. In the Position drop-down menu, select the position for the annotation on the chart. The options are:
   - Top Left
   - Top Middle
   - Top Right
   - Middle Left
   - Middle Right
   - Bottom Left
   - Bottom Middle
   - Bottom Right

6. Click OK to save the options that you selected, and close the Annotation dialog box. The annotation is added to the chart.

7. Click Run to generate the report.
The following image shows a chart with an annotation in the middle right position.
Designing documents in Document view allows you to add text, images, active form controls, reports, and charts to create documents that can be used to generate presentation-ready reports based on your data.

Document view combines the features of report building with the ability to style and present customized documents.

Topics:
- Accessing Document View
- Building a Document
Accessing Document View

**How to:**

Access Document View to Build a New Document
Access Document View by Opening an Item From the Splash Screen
Access Document View by Opening a Report From the Quick Access Toolbar
Access Document View From the Document Button on the Home and View Tabs

In Document view, you can:

- Build a new document.
- Open an existing document.
- Generate a new document from an existing single report.

A blank InfoAssist canvas in Document view is shown in the following image.
**Procedure: How to Access Document View to Build a New Document**

You can access Document view from the InfoAssist splash screen to create a new document.

**Note:** The splash screen must be set to display when you start InfoAssist in order to run this procedure. You use the Options window to set the splash screen to display. For more information, see *Changing User Preferences* on page 25.

If InfoAssist is configured to start in Document mode, rather than with the splash screen, then you can begin this procedure at step 3.

1. Open InfoAssist, as described in *Accessing InfoAssist* on page 22.
   
   The splash screen appears, as shown in the following image.

   ![InfoAssist Splash Screen](image)

2. Select *Build a Document*.
   
   An Open dialog box opens.

3. Select a data source to begin building your document.
   
   **Note:** Documents can be built using more than one data source. The source you select here is the one you will begin with, but you can add more at any time. For more information on adding additional data sources, see *Data Tab* on page 62.

4. Click OK.
   
   InfoAssist opens a new canvas in Document view.
**Procedure:** How to Access Document View by Opening an Item From the Splash Screen

You can access existing documents in Document view from the InfoAssist splash screen.

**Note:** The splash screen must be set to display when you start InfoAssist in order to run this procedure. You use the Options window to set the splash screen to display. For more information, see *Changing User Preferences* on page 25.

1. Open InfoAssist, as described in *Accessing InfoAssist* on page 22.
   The splash screen appears.

2. Click *Open Existing Item*, as shown in the following image.

   ![InfoAssist Splash Screen](image)

   An Open dialog box opens.

3. Select one of the documents. Documents are represented by the Document icon.

4. Click *OK*.

   InfoAssist opens the document in Document view.

**Note:** If you select a single report in step 3, InfoAssist opens the report in either Query Design view or Live Preview. To view a copy of the report in Document view, see *How to Access Document View From the Document Button on the Home and View Tabs* on page 359.
**Procedure: How to Access Document View by Opening a Report From the Quick Access Toolbar**

You can access documents in Document view from the InfoAssist Quick Access Toolbar.

1. With InfoAssist open, click *Open existing item* from the Quick Access Toolbar.
   An Open dialog box appears.

2. Select one of the documents, which are represented by the Document icon.

3. Click *OK*.
   InfoAssist opens the document in Document view.

   **Note:** If you select a single report in step 2, InfoAssist opens the report, in either Query Design view, or Live Preview. To view a copy of the report in Document view, see *How to Access Document View From the Document Button on the Home and View Tabs* on page 359.

**Procedure: How to Access Document View From the Document Button on the Home and View Tabs**

With InfoAssist open in Live Preview or Query Design view, you can access Document view by clicking the *Document* button in the Design group. The Design group appears on both the Home and View tabs.

Accessing Document view by clicking the Document button creates a copy of the current single report as a document. You can use this method to promote My Content to Document view.

You can also access Document view in Reporting Objects by following this procedure.

**Note:** When a Reporting Object is promoted to Document view, any reports and charts that the Reporting Object has are added to the canvas.

1. With an InfoAssist report open, click either the *Home* tab, or the *View* tab.

2. In the Design group, click *Document*.
   InfoAssist enters Document view.
The Document icon is highlighted in the Design group and in the left corner of the Navigation taskbar. The following image shows the highlighted Document icon.

**Note:** The single report you started with still exists in the original view. Selecting Document view while a single report is open does not convert the report to a document. It makes a copy of the report, with the copy becoming a document and the original remaining unchanged.

You can switch between the new document and the original report using the Switch Report button. The Switch button is found on the View tab, in the Report group and on the Status bar. You can also switch between the document and the report using the reports button on the status bar. For more information on switching between reports, see View Tab on page 78.
Building a Document

In this section:
- Inserting Reports From Multiple Data Sources
- Inserting a New Report
- Inserting a New Chart
- Inserting an Existing Report
- Creating a Document From a Single Report
- Inserting Text and Images
- Editing Components in a Document

Document view allows you to build multiple reports and charts on the same canvas. The styling, design, and report building functionality of Live Preview and Query Design view is available in Document view.

In addition, there are many other features that simplify building documents. You can build and insert multiple reports in the form of reports and charts into documents. You can also insert images and text for presentation and organizational purposes.

Inserting Reports From Multiple Data Sources

How to:

Insert Two Reports From Two Different Data Sources

With InfoAssist opened in Document view, you can insert multiple charts and reports onto the canvas. These reports can be from different data sources. With documents, you have the option to add additional data sources to the document.

In order to insert reports from different data sources, the document must have multiple data sources loaded. For more information on adding and switching between data sources, see Data Tab on page 62.

Note: You cannot use multiple data sources when working with a Reporting Object.

Procedure: How to Insert Two Reports From Two Different Data Sources

A document can display multiple reports from multiple data sources in the same document.

1. With InfoAssist open in Document view, insert a chart or report.
2. If your document has only one data source, insert additional data sources.
For more detailed instructions on inserting multiple data sources, see Data Tab on page 62.

3. Switch to a data source different than the one used in step 1.
For more detailed instructions on switching to a different data source, see *Data Tab* on page 62.

4. Insert a chart or report using this new data source, following the instructions given in *Inserting a New Report* on page 363.

Your document is now populated with reports that have data from different data sources. You can add as many data sources as you need.

**Inserting a New Report**

- **How to:**
  - Insert a Report With the Insert Tab
  - Insert a Report With Drag and Drop
  - Insert a Report With Double-Click
  - Insert a Report With Right-Click

With InfoAssist opened in Document view, you can insert multiple charts and reports onto the canvas. The procedures in the following sections detail how to insert reports into documents.

In Document view, you can insert a report in the following ways.
Use the Insert tab.

Double-click a data source field.

Right-click a data source field.

Drag and drop a data source field onto the canvas.

**Note:** When you use the Insert tab, double-click a data source field, or right-click a data source field, a report placeholder is inserted in the upper-left corner of the canvas. Dragging and dropping a data source field onto the canvas inserts the placeholder at the location you dropped it.

The following procedures describe how to insert new reports. For more information on how to edit existing reports, see *How to Style and Customize a Report* on page 382.

**Procedure:** **How to Insert a Report With the Insert Tab**

The Insert tab is only available to insert reports in Document view. For more information on the Insert tab, see *Insert Tab* on page 47.

1. With InfoAssist open in Document view, click the Insert tab.
2. In the Reports group, click Report.

A report placeholder appears in the upper-left corner of the canvas.

You can now add fields to the report using the canvas and the Resources panel. For more information on how to use the Resources panel to add additional fields to the report, see *Understanding the Resources Panel* on page 99.

**Procedure:** **How to Insert a Report With Drag and Drop**

You can insert a report by dragging data source fields from the Resources panel onto the canvas in Document view. To insert a report, make sure that Report is selected on the Format tab, in the Destination group. This option is also on the Home tab, in the Format group.

1. With InfoAssist open in Document view, click the Format tab.
2. In the Destination group, click Report.

**Note:** You can also click Report from the Home tab, in the Format group.

3. Select a data source field from the Data pane in the Resources panel and drag it onto the canvas. Make sure that you drop the data source field onto an open area of the canvas and not on top of another chart or report.
A report with the selected data source appears in the Results panel, as shown in the following image.

4. You can now add fields to the report using the canvas and the Resources panel. For more information on how to use the Resources panel to add additional fields to the report, see Understanding the Resources Panel on page 99.

**Procedure: How to Insert a Report With Double-Click**

You can double-click a data source field in the Resources panel in Document view. To insert a report, make sure that no report is actively selected on the canvas and Report is selected on the Format tab, in the Destination group. This option is also on the Home tab, in the Format group.

**Note:** You cannot insert a new report by a double-click if a report is actively selected. If a report is selected, click the canvas to deselect the report and make the canvas the active object.

1. With InfoAssist open in Document view, click the Format tab.
2. In the Destination group, click Report.

   **Note:** You can also click Report on the Home tab, in the Format group.

3. Double-click a data source field in the Data pane of the Resources Panel.
A report with the selected data source appears in the Results panel, as shown in the following image.

4. You can now add fields to the report using the canvas and the Resources panel. For more information on how to use the Resources panel to add additional fields to the report, see *Understanding the Resources Panel* on page 99.

**Procedure: How to Insert a Report With Right-Click**

You can insert reports by right-clicking a data source field in the Resources panel in Document view. To insert a report, make sure that no report is actively selected on the canvas and Report is selected on the Format tab, in the Destination group. This option is also on the Home tab, in the Format group.

**Note:** You cannot insert a new report by a right-click if a report is actively selected. If a report is selected, click the canvas to deselect the report and make the canvas the active object.

1. With InfoAssist open in Document view, click the *Format* tab.
2. In the Destination group, click *Report*.
   **Note:** You can also click *Chart* on the Home tab, in the Format group.
3. Right-click a data source field in the Data panel.
   A menu opens.
4. Select from the following menu options:
With InfoAssist opened in Document view, you can bring multiple charts and reports onto the canvas. The procedures in the following sections describe how to insert charts into documents.

In Document view, you can insert a chart in the following ways:

- Use the Insert tab.
- Double-click a data source field.
- Right-click a data source field.
- Drag and drop a data source field from the Resources panel onto the canvas.

**Note:** When you use the Insert tab, double-click a data source field, or right-click a data source field, a chart placeholder is inserted in the upper-left visible portion of the canvas. Dragging and dropping a data source field onto the canvas inserts the place holder at the location you dropped it.

The following procedures describe how to insert new charts. For more information on how to edit existing charts, see *How to Style and Customize a Chart* on page 384.
Procedure: **How to Insert a Chart With the Insert Tab**

The Insert tab is only available to insert charts in Document view. For more information on the Insert tab, see *Insert Tab* on page 47.

1. With InfoAssist open in Document view, click the *Insert* tab.

2. In the Reports group, click *Chart*.

   A chart placeholder appears in the upper-left corner of the canvas.

   You can now add fields to the chart using the canvas and the Resources panel. For more information on how to use the Resources panel to add additional fields to the report, see *Understanding the Resources Panel* on page 99.

Procedure: **How to Insert a Chart With Drag and Drop**

You can insert a chart by dragging data source fields from the Resources panel and dropping them onto the canvas in Document view. To insert a chart, make sure that *Chart* is selected on the Format tab, in the Destination group. This option is also on the Home tab, in the Format group.

1. With InfoAssist open in Document view, click the *Format* tab.

2. In the Destination group, click *Chart*.

   **Note:** You can also click Chart on the Home tab, in the Format group.

3. Select a data source field from the Data pane in the Resources panel and drag it onto the canvas. Make sure that you drop the data source field onto an open area of the canvas and not on top of another chart or report.
A chart placeholder with the selected data source appears in the Results panel, as shown in the following image.

4. You can now add fields to the chart using the canvas and the Resources Panel. For more information on how to use the Resources panel to add additional fields to the report, see *Understanding the Resources Panel* on page 99.

**Procedure: How to Insert a Chart With Double-Click**

You can double-click a data source field in the Resources panel in Document view. To insert a chart, make sure that no report is actively selected on the canvas and Chart is selected on the Format tab, in the Destination. This option is also on the Home tab, in the Format group.

**Note:** You cannot insert a new chart by a double-click if a report is actively selected. If a report is selected, click the canvas to deselect the report and make the canvas the active object.

1. With InfoAssist open in Document view, click the *Format* tab.
2. In the Destination group, click *Chart*.
**Note:** You can also click Chart on the Home tab, in the Format group.

3. Double-click a data source field in the Data pane of the Resources Panel. A chart placeholder with the selected data source appears in the Results panel, as shown in the following image.

![Diagram of chart placeholder]

4. You can now add fields to the chart using the canvas and the Resources panel. For more information on how to use the Resources panel to add additional fields to the report, see *Understanding the Resources Panel* on page 99.

**Procedure:** How to Insert a Chart With Right-Click

You can insert charts by right-clicking a data source field in the Resources panel in Document view. To insert a chart, make sure no report is actively selected on the canvas and Chart is selected on the Format tab, in the Destination group. This option is also on the Home tab, in the Format group.

**Note:** You cannot insert a new chart by a right-click if a report is actively selected. If a report is selected, click the canvas to deselect the report and make the canvas the active object.

1. With InfoAssist open in Document view, click the Format tab.
2. In the Destination group, click Chart.

   **Note:** You can also click Chart on the Home tab, in the Format group.

3. Right-click a data source field in the Data panel.

   A menu appears.

4. Select from the following menu options:
   - **Include as Category Axis.** For dimension (non-numeric or date) fields.
   - **Include as Legend Series.** For dimension (non-numeric or date) fields.
   - **Filter.** For all types of fields.
   - **Slicers.** For all fields.
   - **Coordinated.** The Coordinated field container contains a common sort field for creating multiple reports and charts that are burst into separate page layouts. Each value for a coordinated sort field appears on a separate page.

   A chart placeholder, with the selected data source, appears in the Results panel. The chart placeholder turns into a live preview of the chart once the X-axis and Y-axis data fields are selected.

### Inserting an Existing Report

**How to:**

Insert an Existing Report With the Insert Tab

With InfoAssist opened in Document view, you can insert existing charts and reports onto the canvas from the Insert tab. The following procedure describes how you can insert reports into new documents and documents that are already populated with reports, text, and images.

**Procedure:** How to Insert an Existing Report With the Insert Tab

You can create a document in the Custom Reports section of the domain and use Standard Reports items as Existing Report components. You cannot use other Custom Report items as components.

1. With InfoAssist open in Document view, click the **Insert** tab.

2. In the Reports group, click **Existing Report**.

   An Open dialog box appears.
3. Browse to the report that you want to insert and click OK.
The report appears in the upper-left corner of the canvas.
Hovering the mouse over an existing report displays the report title as a tooltip.
**Note:** You cannot edit an existing report that is inserted into a document.

**Creating a Document From a Single Report**

You can take a single report created in Live Preview or Query Design view and convert it into a document, displaying it in Document view.

When you convert a single report into a document, the original report is preserved and a copy of that report is opened as a document in Document view. You can then add additional reports, charts, images, and text.

**Inserting Text and Images**

<table>
<thead>
<tr>
<th>How to:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert Text</td>
</tr>
<tr>
<td>Insert an Image</td>
</tr>
</tbody>
</table>

With InfoAssist opened in Document view, you can bring text and images onto the canvas. The following procedures describe how you can insert text and images into new documents and documents that are already populated with reports, text, and images.

**Note:** You can only do this in Document view.

The following procedures detail how to insert text and images. For more information on how to edit existing text and images, see *Editing Components in a Document* on page 374.

**Procedure:** **How to Insert Text**

1. With InfoAssist open in Document view, click the *Insert* tab.
2. In the Objects group, click *Text Box*. 
A text component appears in the upper-left corner of the canvas with default text, as shown in the following image.

3. Double-click, or right-click, the text component to edit the text.
   
   For more information on editing and styling the text, see How to Edit Text on page 386.

**Procedure: How to Insert an Image**

1. With InfoAssist open in Document view, click the Insert tab.
2. In the Objects group, click Image.
   
   An Open dialog box appears.
3. Browse to the desired image and click OK.
   
   The selected image appears in the upper-left corner of the canvas.
Editing Components in a Document

**How to:**
- Resize a Component
- Move a Component
- Align Components
- Style and Customize a Report
- Style and Customize a Chart
- Edit Text
- Delete a Component

The reports, controls, and text in a document can be edited, moved, resized, and deleted. Each of these components has a context menu which can be accessed by right-clicking the component.

Images can be moved, resized, and deleted, but they have no context menu and cannot be edited. Right-clicking a image brings up the option to delete it.

**Procedure: How to Resize a Component**

You can resize a component in the following ways:

- Using the component sizing handles.
- Changing the height and width on the Layout tab, in the Size & Arrange group.
- Accessing the options on the Size tab in the Size and Position dialog box.

The resize feature is available for all components that can be added to a document.

1. Open or create a document with at least one report, text component, control, or image.
2. Resize the component in one of the following ways:

- **Sizing Handles:** Select the component and drag the sizing handles that appear around it, as shown in the following image. As you manually increase the height and width of the component, the new values appear in the corresponding text boxes in the Size & Arrange group of the Layout tab.

- **Ribbon:** You can use the ribbon in one of the following ways:
  - Select the component in the document. On the Layout tab, in the Size & Arrange group, enter values in the Height and Width fields.
  - On the Layout tab, in the Size & Arrange group, click the dialog box launcher on the lower-left side of the group, to open the Size and Position dialog box.
Right-Click Menu: Right-click the component and select Size and Position. The Size and Position dialog box opens.

From the Size and Position dialog box, open the Size tab, as shown in the following image.

Use the Height and Width options to change the position of the selected component. You can adjust the pixel size of the object with the Size options or the scale percentage of the object with the Scale options.

You can lock the aspect ratio using the Aspect Ratio button, which is available when working with charts, images, and text boxes while working in Document view. With the aspect ratio locked, changing the width automatically changes the height to keep the component to scale, and changing the height automatically changes the width.

Note: The Auto Overflow option is only available while working with reports in Document view through the Size & Arrange group. With Auto Overflow set, you cannot manually set the height and width of a report. The area of the report expands automatically to show all data.

The AutoFit option is only available for charts through the Size & Arrange group. With AutoFit set, the chart size becomes dynamic. This means that other applications can override the size of the chart when the chart is embedded.
When two objects are selected, the *Relative Position* button sets the bottom-left corner of the component that is higher on the page to the upper-left corner of the one that is lower. Once a relationship is created, arrows appear to show that relationship while both items are still selected.

**Procedure: How to Move a Component**

You can move a component by clicking it, or by accessing the Position section of the Size and Position dialog box. This feature is available for all components that can be added to a document.

You can also align components with each other so that their horizontal or vertical position matches. For more information, see *How to Align Components* on page 378.

1. Open or create a document with at least one report, text component, control, or image.
2. Select the component and move it by using one of the following methods:
   - Use the mouse to drag the component anywhere on the canvas.
   or
   - Right-click the component and click Size and Position.
     - On the Size and Position dialog box, click the Position tab, as shown in the
       following image.

     - Use the Horizontal and Vertical options to change the position of the selected
       component.

**Procedure:** How to Align Components

You can align components with each other so that their horizontal or vertical positions match. You must have multiple components selected to use the align options.

The alignment is anchored by the component that is in the farthest position of the selected alignment. For example, if you select two components and click Align Left, the components align horizontally with the component farthest to the left.

1. Open or create a document with at least two components.
2. Select a component.
3. Select a second component by holding the Ctrl key and clicking a component.

**Note:** You can select multiple components simultaneously by holding the Ctrl key and with the left mouse dragging a selection box around the components. When you release the mouse, sizing handles appear around each component that you selected.

Sizing handles appear around the components, as shown in the following image.
4. Align the components using one of the following methods:
   - Right-click one of the selected components and select an alignment option from the Align drop-down menu, as shown in the following image.

   ![Image showing alignment options](image)

   or

   - Access the alignment options from the Align drop-down menu. The menu is available on the Layout tab, in the Size & Arrange group, as shown in the following image.

   ![Image showing alignment options](image)
6. Creating and Customizing Documents
The selected components align, as shown in the following image.

5. Click anywhere in the canvas to deselect the components.

Procedure: How to Style and Customize a Report

When you select a component, you can perform various functions on the component, such as moving and resizing it, as explained in How to Move a Component on page 377. After clicking a component, you can use the ribbon to affect all settings of the selected component, except for fields. You can double-click or right-click a component to select individual fields to edit through the context menu or Field tab.

In addition to reports, you can style and customize charts and text. For more information on charts, see How to Style and Customize a Chart on page 384. For more information on text, see How to Edit Text on page 386.

Note: Images cannot be edited.

1. Open or create a document with at least one report.

2. Select the report.

Sizing handles appear around the border.
3. Right-click the report, and click *Edit Report*, as shown in the following image.

![Edit Report Image]

**Note:** You can also activate the report by double-clicking it. This action provides the same functionality as right-clicking and then clicking *Edit Report*.

4. You can now select fields within the report. Select a field by clicking it in the canvas.
**Note:** The groups on the Field tab are now available, as shown in the following image.

![Field Tab](image)

**Note:** You can also select a field within the report by clicking the field in the Query pane of the Resources panel. Make sure that the report that contains the field you would like to edit is selected on the canvas.

You can now edit the selected report using commands available through the context menu or the ribbon.

For more information on styling and customizing reports, see [Creating and Customizing Reports](#) on page 135.

**Procedure:** **How to Style and Customize a Chart**

When you select a component, you can perform various functions on the component, such as moving and resizing it, as explained in [How to Move a Component](#) on page 377. After clicking a component, you can use the ribbon to affect all settings of the selected component, except for fields. You can double-click or right-click a component to select individual fields to edit through the context menu or Field tab.

In addition to charts, you can style and customize reports and text. For more information on reports, see [How to Style and Customize a Report](#) on page 382. For more information on text, see [How to Edit Text](#) on page 386.

**Note:** Images cannot be edited.

1. Open or create a document with at least one chart.
2. Select the chart.
Sizing handles appear around the border, as shown in the following image.

**Note:** The groups of the Field tab are unavailable.

3. Right-click the chart, and click *Edit Chart*, as shown in the following image.

**Note:** You can also activate the chart by double-clicking it. This action provides the same functionality as right-clicking, and then clicking *Edit Report*.
4. You can now select fields within the chart. Select a field by clicking it in the canvas. 

**Note:** The groups on the Field tab are now available, as shown in the following image.

![Chart with Field Tab](image)

**Note:** You can also select a field within the chart by clicking the field in the Query pane of the Resources panel. Make sure that the chart that contains the field you would like to edit is selected on the canvas.

You can now edit the selected chart using commands available through the context menu or the ribbon.

For more information on styling and customizing charts, see *Creating and Customizing Charts* on page 181.

**Procedure:** How to Edit Text

When you select a component, you can perform various functions on the component, such as moving and resizing it, as explained in *How to Move a Component* on page 377. After clicking a component, you can use the ribbon to affect all settings of the selected component, except for fields. You can double-click or right-click a component to select individual fields to edit through the context menu or Field tab.

In addition to editing text, you can style and customize reports and charts. For more information on reports, see *How to Style and Customize a Report* on page 382. For more information on charts, see *How to Style and Customize a Chart* on page 384.

**Note:** Images cannot be edited.

1. Open or create a document with at least one text component.
2. Select the text.
Sizing handles appear around the border, as shown in the following image.

3. Right-click the text, and click *Edit Text*, as shown in the following image.

**Note:** You can also activate the context menus by double-clicking the text. This action provides the same functionality as right-clicking, and then clicking *Edit Text*.

A cursor appears over the text.
4. Click anywhere in the text box and begin entering text.

5. Highlight the text you would like to edit, and right-click it. A menu of options appears.

6. Using the menu options, you can style the text and insert quick text.
The text component menu options are as follows:

- **Font.** Opens a list of available fonts for the selected text.
- **Size.** Opens a list of available text sizes for the selected text.
- **Bold.** Formats the selected text in bold.
- **Italic.** Formats the selected text in italics.
- **Underline.** Underlines the selected text.
- **Text color.** Opens the Color dialog box where you can select a color for the selected text.
- **Cut.** Cuts the selected text.
- **Copy.** Copies the selected text to the clipboard.
- **Paste.** Pastes the selected text from the clipboard.
- **Date.** Opens a list of date quick text in various formats.
- **Time.** Opens a list of time quick text in various formats.
- **page #.** Opens a list of page number quick text in various formats.

**Procedure: How to Delete a Component**

The following procedure applies to all components in Document view.

1. Open or create a document with at least one component.
2. Right-click the component and click **Delete**.
   The component is deleted from the canvas.

**Note:** You can also delete a component by clicking it and pressing the Delete key.
Creating Active Technologies Reports, Charts, and Dashboards With InfoAssist

This topic describes how to create a report, chart, or dashboard that is enabled for Active Technologies using InfoAssist.

These reports, charts, and dashboards use the full capabilities of Active Technologies. They are also referred to as active reports, charts, and dashboards.

Topics:
- Creating an Active Technologies Report
- Creating an Active Technologies Chart
- Creating an Active Technologies Dashboard
Creating an Active Technologies Report

An active report is a self-contained report that is designed for offline analysis, meaning it contains all the data and JavaScript within the output file. Using an active report, you can:

- Interact with the data, using analysis options similar to those found in an Excel workbook, without any connection to a server. Analysis options include filtering, sorting, charting, and much more.
- Work offline without any additional plug-ins or programs. An active report is a self-contained report, meaning it contains all of the data and JavaScript within the HTML output file. Packaging the data and the interactive functions in the HTML file also makes the output highly compressible for email and transparent to security systems.
- Save the report on a local machine with active report functionality. Since no connection to a server is required to view the data or use the analysis options, a user can save and use the report anywhere.

An active report using Adobe® Flex® includes most of the capabilities available in the HTML version of active reports in a user-friendly report format. An active report delivered as a self-contained Adobe Flash file (.SWF files that are Adobe® Flash® Player compatible) allows for faster analysis of large data sets and interaction with the active report.

**Procedure: How to Create an Active Technologies Report**

1. With InfoAssist open in Report view, on the Format tab, in the Output Types group, click *active report*.
2. Create a report.
3. Run the report.
The following image shows an active report with the available menu options for the Product Category column.

**Active Technologies Report Menu Options**

Menu options for an active report are described in the following table.

<table>
<thead>
<tr>
<th>Option</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sort Ascending</td>
<td>Sorts the column in ascending order.</td>
</tr>
<tr>
<td>Sort Descending</td>
<td>Sorts the column in descending order.</td>
</tr>
<tr>
<td>Option</td>
<td>Definition</td>
</tr>
<tr>
<td>----------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Filter</td>
<td>Filters the data. Options are:&lt;br&gt;☑ Equals&lt;br&gt;☑ Not equal&lt;br&gt;☑ Greater than&lt;br&gt;☑ Greater than or equal to&lt;br&gt;☑ Less than&lt;br&gt;☑ Less than or equal to&lt;br&gt;☑ Between&lt;br&gt;☑ Contains&lt;br&gt;☑ Contains (match case)&lt;br&gt;☑ Omits&lt;br&gt;☑ Omits (match case)</td>
</tr>
<tr>
<td>Calculate</td>
<td>Calculation types that you can apply to the column:&lt;br&gt;☑ Clear&lt;br&gt;☑ Clear all&lt;br&gt;☑ Count&lt;br&gt;☑ Count distinct, which counts the number of distinct values within a field.&lt;br&gt;For numeric fields you can also apply:&lt;br&gt;☑ Sum&lt;br&gt;☑ Avg&lt;br&gt;☑ Min&lt;br&gt;☑ Max&lt;br&gt;☑ % of Total</td>
</tr>
<tr>
<td><strong>Option</strong></td>
<td><strong>Definition</strong></td>
</tr>
<tr>
<td>-----------------</td>
<td>-------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Chart</td>
<td>Creates a chart from the report. Options are Pie, Line, Bar, and Scatter.</td>
</tr>
<tr>
<td>Rollup</td>
<td>Lists the fields available to create a Rollup table.</td>
</tr>
<tr>
<td>Pivot (Cross Tab)</td>
<td>Lists the fields available to create a Pivot table.</td>
</tr>
<tr>
<td>Visualize</td>
<td>Adds or removes visualization bars to the selected column. The Visualize option is available for numeric data columns.</td>
</tr>
<tr>
<td>Hide Column</td>
<td>Suppresses the display of the selected column in the report.</td>
</tr>
<tr>
<td>Show Columns</td>
<td>Lists the names of the columns that are hidden in the report, allowing you to individually restore a column. Select the name of a specific column in the hidden columns list to restore that column to the report.</td>
</tr>
<tr>
<td>Freeze Column</td>
<td>Freezes the report at a particular point so that columns to the left of the freeze point remain in view while the user scrolls through the other report columns. <strong>Note:</strong> If the report can be fully viewed in the browser window, freeze is not applied. The Freeze column option is not available for expandable report (Accordion) views.</td>
</tr>
<tr>
<td>Unfreeze All</td>
<td>Unfreezes the columns.</td>
</tr>
<tr>
<td>Grid Tool</td>
<td>Opens the Grid tool which you can use to change the column order, select multiple columns to sort ascending or descending, hide and show columns, add a calculation result to a column, and add subtotals in the active report.</td>
</tr>
<tr>
<td>Chart/Rollup Tool</td>
<td>Opens the Chart/Rollup Tool which you can use to select multiple group fields to generate the chart or rollup table. The Chart/Rollup Tool contains a list of columns available in the active report to add to Group By and Measure fields. Click and drag the columns into the field that you want.</td>
</tr>
<tr>
<td><strong>Option</strong></td>
<td><strong>Definition</strong></td>
</tr>
<tr>
<td>-------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Pivot Tool</td>
<td>Opens the Pivot Tool which you can use to select multiple group fields to generate the chart or pivot table. The Pivot Tool contains a list of columns available in the active report to add to Group By, Across, and Measure fields. Click and drag the columns into the field that you want.</td>
</tr>
<tr>
<td>Show Records</td>
<td>Opens the Show Records menu option to list the number of records available for display per page in the report. Select a number (for example, 10) to display, per page. Default displays the number of records (lines) per page that is specified in the WebFOCUS report procedure.</td>
</tr>
<tr>
<td>Comments</td>
<td>Options to display comments under cells or hide indicators for comments in the active report output.</td>
</tr>
<tr>
<td>Send as E-mail</td>
<td>Sends report as email.</td>
</tr>
<tr>
<td><strong>Note:</strong></td>
<td>To use this feature you must have ActiveX enabled in your browser security settings.</td>
</tr>
<tr>
<td></td>
<td>This feature is only supported in Internet Explorer.</td>
</tr>
<tr>
<td>Save Changes</td>
<td>Saves changes.</td>
</tr>
<tr>
<td><strong>Note:</strong></td>
<td>To use this feature you must have ActiveX enabled in your browser security settings.</td>
</tr>
<tr>
<td></td>
<td>This feature is only supported in Internet Explorer.</td>
</tr>
<tr>
<td>Export</td>
<td>Exports all records or filtered only records to HTML, CSV, XML.</td>
</tr>
<tr>
<td><strong>Note:</strong></td>
<td>To use this feature you must have ActiveX enabled in your browser security settings.</td>
</tr>
<tr>
<td>Print</td>
<td>Prints all records or filtered only records.</td>
</tr>
<tr>
<td>Window</td>
<td>Displays reports in a cascade or separate tabs.</td>
</tr>
<tr>
<td>Restore Original</td>
<td>Restores the active report to its default state specified in the report procedure.</td>
</tr>
</tbody>
</table>
Configuring Active Technologies Report Options

You can configure active report options, including menu options, based on user role through the active report options dialog box.

You access the dialog box on the Format tab, in the Features group, by clicking the active report options button. The button is available when active report, active Flash, or active PDF is selected as the output type.

The active report options dialog box contains the following tabs:

- General
- Menu Options
- Colors
- Advanced
**General Tab**

Use the General tab to set common properties specific to active reports. The General tab is shown in the following image.

The General tab contains the following options:

- **Display.** This area contains options to set the window to cascade or tabs, and options to freeze columns.
  - **Window.** Select the window setting. The options are Cascade and Tabs.
  - **Freeze Columns.** Select the columns you would like to freeze. You can also select None.
**Page Options.** This area contains options to set the number of records per page, enable the display of page information, edit the alignment, and set the location of the page information.

- **Records Per Page.** Select the number of records that you would like to display per page. The options are:
  - All
  - 10
  - 20
  - 30
  - 40
  - 50

- **Display Page Information.** Select this option to display page information. Clear this option to disable the display of page information.

- **Alignment.** Click the appropriate button to set the alignment of the page information. Options are Left, Center, and Right.

- **Location.** Select the location for the page information. The options are Top Row and Bottom Row.

**Chart Options.** This area contains options that pertain to charts.

- **Chart Engine.** Select the chart engine to determine the set of charts that you can create. The options are:
  - **Standard.** Uses the Active Technologies default chart engine. This option is available for output format types AHTML, FLEX, and APDF.
  - **Dynamic.** This setting is the default for the output format types AHTML and FLEX. For AHTML, this uses the current Flash charts by default on browsers with Flash Player that may not support the functionality in the new JavaScript charts, such as older releases of Internet Explorer. These charts will automatically switch to the new JavaScript charts on browsers that do not support Flash, such as Safari® on the iPad.
  - **HTML5.** Uses the new JavaScript charts for the output format type AHTML. These charts will work in both connected and disconnected mode. The current AHTML default four JavaScript charts will not be available at run time.
  - **Flash.** Uses the default four Adobe Flex charts when output format is FLEX or APDF. These are the existing charts that work in both connected and disconnected mode. No additional chart types will be available at run time.
Creating an Active Technologies Report

- **Legend (check box).** Select this option to collapse the legend if necessary. Clear this option if you do not want the legend to collapse. This is for active Flash and active PDF only.

- **Legend (menu).** Select the location for the legend. This is for active Flash and active PDF only. The options are:
  - Bottom Left
  - Bottom Center
  - Bottom Right
Menu Options Tab

Use the Menu Options tab to select a user type and select which options to display in the menu. The Menu Options tab is shown in the following image.

The Menu Options tab contains the following options:

- **User Type.** The options are Power, Analyst, Basic, and Custom.
  - **Power.** This is the default user type and enables all functionality.
  - **Analyst.** This user type has the following functionality: Show Records, Freeze, Hide/Unhide, Export, Sorting, Pivot, Filter, Calculations, Chart, Visualize, Restore Original, Save Changes, and Accordion.
Basic. This user type has the following functionality: Show Records, Freeze, Hide/Unhide, Sorting, Filter, Calculations, Visualize, and Restore Original.

Custom. If you select a combination of options that does not match one of the existing user types (Power, Analyst, Basic), the User level name that appears in the User Type field is Custom. This is not a default user type or a selectable user type. It is used to show that options for this user do not match any of the existing user types.

Show Records. Can show all records or specific numbers of records.

Freeze. Can freeze and unfreeze columns.

Hide/Unhide. Can hide and show columns.

Export. Can export data as HTML, .CSV, or Excel (XML) formats.

Sorting. Can sort data in ascending and descending order.

Pivot. Can pivot data.

Window Type. Can show window as cascade or tabs.

Send as Email. Can send report as email.

Print. Can print all records or filtered-only records.

Advanced Tools. Can access the Chart/Rollup, Pivot, and Grid tools.

Filter. Can open the Filter Selection dialog box.

Calculations. Can perform the following calculations Sum, Avg, Min, Max, Count, Distinct, % of Total.

Chart. Can convert report to pie, line, bar, or scatter chart.

Visualize. Can add data visualization bars to report.

Rollup. Can perform rollup on data.

Comments. Can add comments.

Restore Original. Can restore original data.

Save Changes. Can save changes.

Accordion. Can produce accordion report.

Grid Tool. Can open Grid Tool dialog box.
**Colors Tab**

Use the Colors tab to select colors for various objects on the report. The Colors tab is shown in the following image.

The Colors tab contains the following options:

- **Page.** This area contains options to set the colors for the font and background for the page text.
  - **Font.** Opens the Color dialog box, where you can select the font color.
  - **Background.** Opens the Color dialog box, where you can select the background color for the page text.
Row Selection. This area contains options to set the colors that appear when you hover over or select a row on the report.

- **Hover.** Opens the Color dialog box, where you can select the color that the row becomes when you hover the mouse over the row.

- **Selected.** Opens the Color dialog box, where you can select the highlight color that the row becomes when you use the highlight option.

Visualization. This area contains options to set the colors for the data visualization bars.

- **Positive.** Opens the Color dialog box, where you can select the color for a positive data visualization bar.

- **Negative.** Opens the Color dialog box, where you can select the color for a negative data visualization bar.

Calculations. This area contains options to set the colors for values in a calculation.

- **Font.** Opens the Color dialog box, where you can select the font color for the calculation.

- **Background.** Opens the Color dialog box, where you can select the background color for the calculation.

Menu. This area contains options to change the color of the menu.

- **Normal**
  
  - **Font.** Opens the Color dialog box, where you can select the color for the text of the options on the column menus.

  - **Background.** Opens the Color dialog box, where you can select the background color for the column menus.

  - **Border.** Opens the Color dialog box, where you can select the color for the border of the column menus.

- **Hover**

  - **Font.** Opens the Color dialog box, where you can select the color for the text of the options on the column menus when you point to them.

  - **Background.** Opens the Color dialog box, where you can select the background color that appears behind options on the column menus when you point to them.
Advanced Tab

Use the Advanced tab to control active cache, password protection, and report expiration settings. The Advanced tab is shown in the following image.

The Advanced tab contains the following options:

**active cache.** Enables reports to cache the data in a binary file and return the data to the output window in pre-set increments.

- **Rows Received.** Select the number of rows retrieved in the output. The options are:
  - 100 (default)
  - 500
  - 1000
  - 2000
  - 3000
  - 4000
  - 5000

**Security.** This area allows you to set a password to access the report and enable expiration by date or by days.
Creating an Active Technologies Chart

An active report is a report that is designed for offline analysis. For more information, see Creating an Active Technologies Report on page 392.

Procedure: How to Create an Active Technologies Chart

1. Create a chart.
2. On the Format tab, in the Output Types group, click active report, active Flash, or active PDF.
3. Generate the chart.

The following image shows an HTML5 pie chart that shows the sum of the values in the Quantity Sold field by Region.
**Active Technologies Options for Charts**

Options for an active chart are described in the following table.

<table>
<thead>
<tr>
<th><strong>Option</strong></th>
<th><strong>Definition</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Group By (X)</td>
<td>Changes groups by the horizontal sort field.</td>
</tr>
<tr>
<td>Add (Y)</td>
<td>Adds vertical sort field.</td>
</tr>
<tr>
<td>Export to</td>
<td>Exports to Excel, Word, and PowerPoint.</td>
</tr>
<tr>
<td>Top</td>
<td>Displays the top values. Options are Top 3, Top 5, Top 10, and Clear Top.</td>
</tr>
<tr>
<td>Chart/Rollup Tool</td>
<td>Opens the Chart/Rollup Tool which you can use to select multiple group fields in the chart or rollup table generated. The Chart/Rollup Tool contains a list of columns available in the active report and Group By and Measure sort fields. Click and drag the columns into the desired sort field.</td>
</tr>
<tr>
<td>Pie</td>
<td>Views data as a pie chart.</td>
</tr>
<tr>
<td>Bar</td>
<td>Views data as a bar chart.</td>
</tr>
<tr>
<td>Line</td>
<td>Views data as a line chart.</td>
</tr>
<tr>
<td>Scatter</td>
<td>Views data as scatter chart.</td>
</tr>
<tr>
<td>Advanced Chart</td>
<td>Opens the Chart/Rollup Tool.</td>
</tr>
<tr>
<td>Original Chart</td>
<td>Restores the active chart to the chart type specified in the report procedure.</td>
</tr>
<tr>
<td>Sum</td>
<td>Applies the following options to the Measure field: Sum, Avg, Min, Max, Count, and Distinct.</td>
</tr>
</tbody>
</table>
Creating an Active Technologies Dashboard

In this section:
- Active Technologies Dashboard Prompts
- Target Reports
- Using Multiple Reports as Targets and Sources

How to:
- Add an Active Technologies Dashboard Prompt to a Dashboard
- Change the Filter Condition
- Add Multiple Prompts to a Dashboard
- Cascade Prompts

You can create an active dashboard by inserting active dashboard prompts into a document to act as filters on the reports of the dashboard. You can also cascade (chain) prompts to populate based on the selections of the previous prompts. The output format of the active dashboard must be active report, active Flash, or active PDF in order to add active dashboard prompts.

Active Technologies Dashboard Prompts

The active dashboard prompts group contains buttons to click to insert active dashboard prompts into your dashboard. This group is only visible when the output format of the dashboard is set to active report, active PDF, or active Flash. You access the active dashboard prompts on the Format tab, in the Output Types group. The active dashboards prompts group is shown in the following image.

The following are the types of active dashboard prompts that you can use to apply filters to an active dashboard:

- **Drop Down.** Inserts a drop down prompt placeholder in the upper-left corner of the canvas.
List. Inserts a list prompt placeholder in the upper-left corner of the canvas.

Checkbox. Inserts a check box prompt placeholder in the upper-left corner of the canvas.

Radio Button. Inserts a radio button prompt placeholder in the upper-left corner of the canvas.

Text. Inserts a text area prompt placeholder in the upper-left corner of the canvas.

Target Reports

When you bind a field to an active dashboard prompt the default target report is the report from which you dragged the field. You can add or remove target reports from an active dashboard prompt through the active dashboard properties dialog box. For more information on using the active dashboard properties dialog box, see Using Multiple Reports as Targets and Sources on page 411.

A report must meet one of the following requirements to be a target report:

- The report contains a field with the same name as the source field (actual field name or AS name).
- The Master File of the report has a field with the same name as the source field.

If a report is eligible to be a target report because the field has the same user-entered title and the title is changed, the report is automatically removed as a target.

Procedure: How to Add an Active Technologies Dashboard Prompt to a Dashboard

This procedure describes how to begin to create a dashboard by creating one report and binding a single prompt to one of the fields of the report.


2. On the Format tab, in the Output Types group, select an active output type (active report, active Flash, active PDF).


   A placeholder appears on the canvas.

4. Drag and drop fields onto the canvas, or into the Query pane, to create the report and start building the dashboard.

5. On the Insert tab, in the active dashboard prompts group, select a dashboard prompt to insert into the document.

   For example, the following image shows a radio button prompt added to the dashboard.
An active dashboard prompt appears in the upper-left corner of the canvas. If you have left the report in the upper-left corner of the canvas, then you will have to drag the prompt off the report, as shown in the following image.

6. Select the report and bind one of its data source fields to the prompt in one of the following ways:

- **Query pane:** Select the report. From the Query pane, drag the field that you want to bind to the prompt onto the prompt.

- **Report on the canvas:** Right-click the report and click *Edit Report*. The report becomes editable. Highlight the column that contains the data that you want and drag and drop it on the prompt.

Once you have bound the field to the prompt, the values of the field appear in the prompt.

**Note:** Once an active dashboard prompt is added to the canvas, the document is locked in an active output format. You cannot change out of active report, active Flash, or active PDF format if there are prompts present on the canvas. To switch to a non-active output format, all prompts must be removed.
The following image shows an active dashboard in which the Product Category field of the report has been bound to a radio button prompt.

The following image shows an example of a dashboard at run time. The active report has a radio button prompt bound to the Product Category field. Since it is a radio button, and Televisions is selected, only Regions that have sold televisions appear on the report.

Using Multiple Reports as Targets and Sources

**How to:**

Build a Dashboard With Multiple Reports as Targets and Sources
Change the Field

You can add multiple reports and charts to a dashboard. Each report can have multiple prompts associated with it.
**Procedure: How to Build a Dashboard With Multiple Reports as Targets and Sources**

The following procedure describes how to set up active dashboard prompts for two reports on a dashboard. In the example that is used, the first report contains information about the categories of electronics products sold in various regions. The Region field will be bound to a group of radio buttons. Each radio button will represent a particular region in which the electronics are sold. When you select a radio button for a region, for example, NorthEast, the report will be filtered by your selection.

The second report contains information about the gender and age group of electronics consumers. The Gender field will be bound to a drop-down list. The list will display the values, male and female. When you select a gender from the drop-down list, the report will be filtered by your selection.

1. With InfoAssist open in Document view, and at least two reports on the canvas, add two active dashboard prompts, as described in *How to Add an Active Technologies Dashboard Prompt to a Dashboard* on page 409.
The following image shows a dashboard with the region report and the gender report described in the introduction. Next to the region report is a radio box. Next to the gender report is a drop-down list prompt. The prompts are not yet bound to any report fields.

2. Right-click the active dashboard prompt to which you want to bind a field and click Properties.
For example, in the following image, the right-click menu for the radio button prompt is open.

![Image showing right-click menu]

The active dashboard properties dialog box opens, as shown in the following image. The Prompts list displays the two prompts (radiobuttons_1 and combobox_1) that were added to the dashboard in step 1. The prompt titled radiobuttons_1 is highlighted because it was selected in step 2.

![Image showing active dashboard properties]

3. From the Report drop-down menu, select the report that contains the field to which you want to bind an active dashboard prompt.
In this example, shown in the following image, the radio buttons list (radiobuttons_1) has been selected as the prompt for the region report (table_1).

The next step describes how to bind the Region field from the region report to the radio buttons list to filter that report.

4. From the Field drop-down menu, select the field to which you want to bind the active dashboard prompt.
In this example, the Region field has been selected for the radio buttons list (radiobuttons_1), as shown in the following image.

The following image shows Region as the selected field for the radio buttons list. The region report (table_1) is a target report because it is the one from which you selected the field. In addition, table_2, the gender report, now appears in the Candidate Reports list.

5. Click OK.
The prompt is now bound to the field on the dashboard.

In the following image, the radio buttons list is bound to the Region field. It displays all regions by which a user can filter the report.
The following steps describe how to bind the Gender field in the gender report (table_2) to the drop-down list prompt.

6. Right-click the next active dashboard prompt to which you want to bind a field and click Properties.
For example, in the following image, the drop-down list prompt on the gender report is selected.
The active dashboard properties dialog box opens again, as shown in the following image.

![Active Dashboard Properties Dialog Box](image)

Notice that combobox_1, the prompt selected on the dashboard, is selected in the Prompts list.

7. From the Report drop-down menu, select the report that contains the field to which you want to bind an active dashboard prompt.
In this example, shown in the following image, the drop down list (combobox_1) has been selected as the prompt for the gender report (table_2).

![Active Dashboard Properties](image)

The next step describes how to bind the Gender field from the gender report to the drop down list to filter that report.

8. From the Field drop-down menu, select the field to which you want to bind the active dashboard prompt.
In this example, the Gender field has been selected for the drop-down list (combobox_1), as shown in the following image.

![Image of Active Dashboard Properties with Gender field selected]

Once the Gender field has been selected, table_2 (gender report) appears in the Target list and table_1 (region report) appears in the Candidate Reports list.

![Image of Active Dashboard Properties with Target and Candidate Reports listed]
**Note:** To move a report from the Candidate Reports list box to the Targets list box, select it and click the *Add to List* arrow. To remove a report from the Targets list box, select it and click the *Remove from List* arrow. You can select multiple reports by holding down the Ctrl key and clicking each one.

9. Click OK.

The prompt is now bound to the field on the dashboard.

In this example, the drop-down list is bound to the Gender field. A user could filter the gender report by male or female.

The following image shows the final dashboard with two reports and two prompts.
In this example, the region report has been filtered by the NorthEast region and the gender report has been filtered by Female.

**Procedure: How to Change the Field**

You can change the field to which the active prompt is bound.

1. With InfoAssist open in Document view, bind an active prompt to a field, as described in *Using Multiple Reports as Targets and Sources* on page 411.

2. Right-click the active dashboard prompt that you want to configure, and click *Properties*. The active dashboard properties dialog box opens.
3. From the Field menu, select a different field, as shown in the following image.

A warning message alerts you that changing the source field for the prompt will remove the existing prompt and any children prompts from the cascades. The warning message is shown in the following image.

4. Click OK to close the warning.

5. Click OK to close the active dashboard properties dialog box.

The active dashboard prompt is updated with the new source field.
In the following example, the check box prompt is updated with electronics products, as shown in the following image.

![Check box prompt updated with electronics products](image)

**Procedure: How to Change the Filter Condition**

1. With InfoAssist open in Document view, bind an active dashboard prompt to a field, as described in *How to Add an Active Technologies Dashboard Prompt to a Dashboard* on page 409.

2. Right-click the active dashboard prompt that you want to work with, and from the right-click menu, select *Properties.*

   The active dashboard properties dialog box opens.

3. From the Condition drop-down menu, select the filter condition for the active dashboard prompt. The options are Equal to, Not equal to, Less than, Less than or equal to, Greater than, and Greater than or equal to.

4. Click *OK.*

   The filter condition is applied to the active dashboard prompt.

**Procedure: How to Add Multiple Prompts to a Dashboard**

1. With InfoAssist open in Document view, and at least one report on the canvas, add at least two active dashboard prompts, as described in *How to Add an Active Technologies Dashboard Prompt to a Dashboard* on page 409.
The following image shows a dashboard with a list prompt and a radio button prompt.

2. Bind the fields to prompts that you have added, as described in *How to Add an Active Technologies Dashboard Prompt to a Dashboard* on page 409.
In the following image, the list prompt has been bound to the Product Category field and the radio button prompt has been bound to the Region field. The two prompts work independently of each other to filter the dashboard in different ways.
The following image shows the dashboard indicating the quantity of stereo systems sold for all regions.

![Dashboard indicating the quantity of stereo systems sold for all regions.](image)

The following image shows the dashboard indicating the electronics products sold in the NorthEast region.

![Dashboard indicating the electronics products sold in the NorthEast region.](image)

**Procedure: How to Cascade Prompts**

When you have more than one prompt on the canvas, you can cascade prompts to populate based on the selections of the previous prompts. Cascading prompts have a parent-child relationship, in which the parent filters the available options of the child.

An active prompt can be the parent of more than one other prompt, but cannot be a child of more than one prompt.

1. With InfoAssist open in Document view, bind at least two active prompts to fields, as described in *Using Multiple Reports as Targets and Sources* on page 411.
In the following image, a report has been created to show the quantity of electronics sold by states within a region. Two prompts, a radio button to select the region, and a check box to select the state, have been added to the report. The objective is to be able to select a region, and then cascade down to the state level.

2. Right-click the active dashboard prompt that you want to configure, and click Properties. The active dashboard properties dialog box opens.

3. Click Cascades.
By default, a cascade named Cascade1 appears in the Cascades section of the active dashboard Properties dialog box.

- You can click the Create a new cascade button to create a new cascade.
- You can click the Delete selected cascade button to delete the selected cascade.

The following image shows that the Region field is associated with the radio button prompt and the State Code field is associated with the check box in the Available Prompts list.

4. Select the cascade to which you want to add prompts.
5. From the Available Prompts list box, select the prompt that you want to add.
6. Click the Add to List arrow to move the selected prompt to the Selected Prompts list box, as shown in the following image.

![Active Dashboard Properties](image)

**Note:** You can remove prompts from the Selected Prompts list box by selecting them and clicking the Remove from List arrow.

7. Add any additional prompts you want to be part of the cascade by repeating steps 5 and 6.

By default, the hierarchy of the prompts is determined by the order in which they are added to the Selected Prompts list. The cascade of the prompts is from top to bottom. The prompts that come first in the Selected Prompts list are the parents of the lower prompts.
8. You can change the hierarchy of the prompts by selecting a prompt in the Selected Prompt list box and clicking the Move Up and Move Down arrows, as shown in the following image.

![Active Dashboard Properties]

9. Click OK.
   The cascade is created.

10. Run the report.
The following image shows the report with the region radio box and the state check box.

<table>
<thead>
<tr>
<th>Product Category</th>
<th>Region</th>
<th>State Code</th>
<th>Quantity</th>
</tr>
</thead>
<tbody>
<tr>
<td>Stereo Systems</td>
<td>NorthEast</td>
<td>CT</td>
<td>717</td>
</tr>
<tr>
<td></td>
<td></td>
<td>MA</td>
<td>1,073</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ME</td>
<td>1,009</td>
</tr>
<tr>
<td></td>
<td></td>
<td>NH</td>
<td>355</td>
</tr>
<tr>
<td></td>
<td></td>
<td>NJ</td>
<td>1,307</td>
</tr>
<tr>
<td></td>
<td></td>
<td>NY</td>
<td>3,443</td>
</tr>
<tr>
<td></td>
<td></td>
<td>RI</td>
<td>116</td>
</tr>
<tr>
<td></td>
<td></td>
<td>VT</td>
<td>715</td>
</tr>
<tr>
<td></td>
<td>SouthEast</td>
<td>AL</td>
<td>1,131</td>
</tr>
<tr>
<td></td>
<td></td>
<td>FL</td>
<td>1,651</td>
</tr>
<tr>
<td></td>
<td></td>
<td>GA</td>
<td>1,660</td>
</tr>
<tr>
<td></td>
<td></td>
<td>LA</td>
<td>748</td>
</tr>
<tr>
<td></td>
<td></td>
<td>MS</td>
<td>704</td>
</tr>
<tr>
<td></td>
<td></td>
<td>NM</td>
<td>430</td>
</tr>
<tr>
<td></td>
<td></td>
<td>SC</td>
<td>1,107</td>
</tr>
<tr>
<td>Televisions</td>
<td>NorthEast</td>
<td>CT</td>
<td>475</td>
</tr>
<tr>
<td></td>
<td></td>
<td>MA</td>
<td>649</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ME</td>
<td>575</td>
</tr>
</tbody>
</table>
The following image shows the dashboard output with the region prompt cascading down to the state level.

![Dashboard Output]

**Note:** If you set up more than one cascade, the cascade that you interact with last is the one that filters the report.
You can use InfoAssist to create slicers, dynamic filters that you can use with reports, charts, dashboards, and documents.

Topics:
- Creating Slicers
- Filtering With Slicers
- Edit Slicers Dialog Box
Creating Slicers

How to:
Create a Slicer
Add a Field to an Existing Slicer Group
Add a Hierarchy as a Slicer Group

You can create slicers by dragging fields to the Slicers tab or through the context menu of a field. When you create a slicer group, it appears on the Slicers tab, as shown in the following image.

![Slicers Tab Image]

You can use slicers to dynamically filter reports at design time in InfoAssist. You can dynamically filter reports at run time when they are included in an InfoMini application. For more information on InfoMini, see Building InfoMini Applications on page 455.

Procedure: How to Create a Slicer

1. Click the Slicers tab.

2. Create a new slicer by using one of the following methods:
   - Click the New Group button to create a new slicer group.
     Select a field from the Data pane and drag it onto the Drag Fields Here to Create Slicers text on the Slicers tab.
     Note: You cannot drag and drop parent-child hierarchies onto the Slicers tab.
The field is added to the new group.

or

- Right-click a field in the Data pane, point to Slicers, and then click **New Group**, as shown in the following image.

The field is added to the new group, as shown in the following image.
Procedure: How to Add a Field to an Existing Slicer Group

1. Click the Slicers tab.

2. Add a field to an existing slicer group using one of the following methods:
   - Select a field from the Data pane and drag it onto an existing slicer group.
   - Right-click a field in the Data pane, point to Slicers, and then click Existing Group, as shown in the following image.

Select an existing group from the menu, as shown in the following image, and then click OK.

The field is added to the existing group.

Procedure: How to Add a Hierarchy as a Slicer Group
Note: You cannot drag and drop parent-child hierarchies onto the Slicers tab.

1. Click the Slicers tab.

2. Add a hierarchy as a slicer group using one of the following methods:

   - Select a hierarchy from the Data pane and drag it onto an existing slicer group.
     The hierarchy is added as a new group, not as a slicer in the existing group. The new group is given the same name as the hierarchy.

   or

   - Click the New Group button to create a new slicer group.
     Select a hierarchy from the Data pane and drag it onto the Drag Fields Here to Create Slicers text of the Slicers tab.
     The hierarchy is added to the new group, as shown in the following image. The name of the new group changes to the name of the hierarchy automatically.

Note: Hierarchies cannot be added to existing slicer groups. If a hierarchy is dragged onto an existing slicer group, a new group is created automatically.

There is no right-click context menu for hierarchies. To add a hierarchy as a slicer group, you must drag and drop it into a new slicer group.

Filtering With Slicers

In this section:

How Slicers Cascade Together

How to:

Change the Relationship Operator in a Slicer

Once you add slicers to an InfoAssist report, you can use them to filter the report. You can select values from the slicers menus, change the number of records that appear, create new slicer groups, clear existing slicer groups, and update the report preview.
Slicers that are not selected have their values filtered by the selected slicers. Only values that meet the criteria for previously selected slicers will appear in the menu for the next slicer. Slicers are not filtered in the order they appear in the slicer group, but by the order they are selected. Cascading of slicers is only valid for hierarchies.

**Procedure:**  **How to Change the Relationship Operator in a Slicer**

For alpha fields, the available operators are:
- equal to
- not equal to

For numeric and date fields, the available operators are:
- equal to
- not equal to
- in range
- not in range
- greater than
- less than
- greater than or equal to
- less than or equal to

1. With at least one slicer added to the report, click the Slicers tab.
2. Click the operators button on the slicer for the operation you want to change.

A list of operators (numeric) appears in the menu, as shown in the following image.

**Note:** Alpha fields just flip between equal and not equal.
3. Select the operator that you want from the menu. You can rest the mouse on an operator to display a tooltip describing the operation.

How Slicers Cascade Together

**How to:**

Cascade Slicers

Slicers cascade within a hierarchy (cube or dimension builder-based), rather than in the order of user interaction, eliminating potential performance issues.
The following image illustrates a dimension builder-based hierarchy.
**Procedure: How to Cascade Slicers**

Controls with fields from the same hierarchy are cascaded together. In the following example, a report has been created that shows the quantity of products, by category, sold each year.

<table>
<thead>
<tr>
<th>Product Category</th>
<th>Year (Sales)</th>
<th>Quantity Sold</th>
</tr>
</thead>
<tbody>
<tr>
<td>Stereo Systems</td>
<td>2007</td>
<td>1</td>
</tr>
<tr>
<td></td>
<td></td>
<td>2</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4</td>
</tr>
<tr>
<td></td>
<td>2008</td>
<td>1</td>
</tr>
<tr>
<td></td>
<td></td>
<td>2</td>
</tr>
<tr>
<td></td>
<td></td>
<td>3</td>
</tr>
<tr>
<td></td>
<td>2009</td>
<td>1</td>
</tr>
<tr>
<td></td>
<td></td>
<td>2</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4</td>
</tr>
<tr>
<td></td>
<td>2010</td>
<td>1</td>
</tr>
<tr>
<td></td>
<td></td>
<td>2</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4</td>
</tr>
<tr>
<td>Televsions</td>
<td>2007</td>
<td>1</td>
</tr>
<tr>
<td></td>
<td></td>
<td>2</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4</td>
</tr>
<tr>
<td></td>
<td>2008</td>
<td>1</td>
</tr>
<tr>
<td></td>
<td>2009</td>
<td>1</td>
</tr>
<tr>
<td></td>
<td></td>
<td>2</td>
</tr>
<tr>
<td></td>
<td></td>
<td>3</td>
</tr>
<tr>
<td></td>
<td>2010</td>
<td>1</td>
</tr>
<tr>
<td></td>
<td></td>
<td>2</td>
</tr>
<tr>
<td></td>
<td></td>
<td>2</td>
</tr>
<tr>
<td>Video Players</td>
<td>2007</td>
<td>1</td>
</tr>
<tr>
<td></td>
<td></td>
<td>2</td>
</tr>
</tbody>
</table>

1. Create a report.
2. Create multiple slicer groups, as described in *How to Create a Slicer* on page 438.
In the following example, two groups have created for this report. They are Product and Time (Sales). Both are from hierarchies, so they will cascade.

In the next example, Televisions is selected as the first control for the Product group.
Once you click OK, the new control appears in the drop-down menu, as shown in the following image.

The 1 prior to the decimal point indicates that this is the first cascade you have interacted with. The 1 after the decimal point indicates that it is the first control in that cascade.

In the next example, Flat Panel TV is selected as the second control for the Product group, as shown in the following image. This is filtered to only show subcategories for Televisions.
Flat Panel TV appears in the Product Subcategory drop-down menu, as shown in the following image.

The number 1.2 indicates that this is the second control for the first cascade. Now, a second group, Time (Sales) is created. It has two controls, the first is Year (Sales), the second is Quarter (Sales), as shown in the following image.

3. Filter the report using the controls in the slicer groups that you created.

In the following example, the report has been filtered to show the number of flat panel televisions that were sold in the first quarter of 2007.

Note: The order of a cascade is dynamic. For example, if you selected Camcorder from Product Subcategory first, then the Product Category control would have a value of Video Production.
Edit Slicers Dialog Box

In this section:
- General Tab
- Record Limit Tab
- Group Tab

You can access the Edit Slicers dialog box by clicking the edit button next to the group labels on the Slicers tab, as shown in the following image.

The Edit Slicers dialog box contains the following tabs:
- General
- Record Limit
- Group # (tab for each slicer group)
**General Tab**

Use the General tab to show or hide the Options group and to automatically update the Interactive preview. You can also reorder or delete existing groups on this tab. The General tab is shown in the following image.

![General Tab Image](image.png)

The General tab contains the following options:

- **Show Options group.** Select this option to display the Options group on the Slicers tab. The Options group is shown in the following image.

![Options Group Image](image.png)

The Options group contains the following options:

- **New Group.** Adds a new slicers group to the Slicers tab.
- **Clear Slicers.** Clears all selected values from existing slicers.
- **Update Preview.** Updates the design time canvas with any changes that have been made.

- **Auto Update Preview.** Enables auto updating of the canvas.

- **Edit Group Order.** Select a group, then use the up and down arrows to change its position.

- **Hide & Exclude.** Select a group, then select this option to delete the group.

**Record Limit Tab**

Use the Record Limit tab to show or hide the Record Limit group, the Preview control, and the Run Time control, as shown in the following image. You can also use this tab to select the number of preview and run-time records that will be shown.

The Record Limit tab contains the following options:

![Record Limit Tab Image](image-url)
Show Record Limit group. Select this option to display the Record Limit group on the Slicers tab. The Record Limit group is shown in the following image.

The Record Limit group contains the following menus:

- **Preview.** Use this menu to control how many records are displayed in the design-time preview.

- **Run Time.** Use this menu to control how many records are displayed at run time.

- **Show Preview control.** Select this option to display the Preview menu in the Show Record Limit group on the Slicers tab. You can set the default number of records to be shown at design time with the Records menu in the Preview section.

- **Show Run Time control.** Select this option to display the Run Time menu in the Show Record Limit group on the Slicers tab. You can set the default number of records to be shown at run time with the Records menu in the Run Time section.
Group Tab

Use the Group tab, shown in the following image, to change the name of the group, change the order of the slicers in the group, and set a required option for slicers. Selecting a slicer and clicking the Remove from List button deletes the slicer.

The Group tab contains the following options:

- **Group Name.** Use this field to enter or edit the name of a Slicer group.
- **Edit Slicer Order.** Select a slicer, then use the up and down arrows to change its position.
- **Required.** Select this option to set a slicer to be required. A slicer that is set to required must have a value selected before the report can run. A required slicer is indicated by an asterisk (*), as shown in the following image.
Building InfoMini Applications

InfoMini applications are built from an InfoAssist report and contain a subset of InfoAssist functionality available at runtime.

You can build an InfoMini application and provide the run-time user with the option to interact with and edit the report.

Topics:
- Understanding InfoMini Applications
- Creating an InfoMini Application
Understanding InfoMini Applications

When you create a report in InfoAssist, you have the option to activate InfoMini. You can run a report with InfoMini activated, which creates an InfoMini application. An InfoMini application contains a subset of the functionality available in a full InfoAssist report. You can limit or expand the functionality that is available to the user at run time when you build the report in InfoAssist.

An InfoMini application opens in its own browser window when it is run from within InfoAssist to test. An InfoMini application does not open in its own browser window in the Business Intelligence (BI) Portal or in any other application that you build yourself.

An InfoMini application has many of the components an InfoAssist report has, with the following exceptions:

- The main menu is not accessible.
- The New, Open, and View code buttons on the Quick Access Toolbar are not available.
- Certain tabs and groups are unavailable or limited. For more information, see Interactive Mode on page 458 and Edit Mode on page 459.
- The status bar is not accessible.
- The navigation taskbar is not accessible.
- InfoMini does not support referencing existing procedures and Reporting Objects.

There are two items on the Quick Access Toolbar that are exclusive to an InfoMini application. They are:

- Interactive button
- Edit button

For more information on the available components and their functionality, see InfoAssist Application Window on page 30.
Using the InfoMini Button

The InfoMini button can be found on the Format tab, in the Destination group. You can click the *InfoMini* button to activate the InfoMini option. With the InfoMini button active, you can run a report to open the InfoMini application.

To deactivate the InfoMini option, click the *InfoMini* button again. There must be at least one option selected from the InfoMini button menu for InfoMini to be activated.

You can set the options available to the user at run time from the menu on the InfoMini button. If you select an option from the menu when the InfoMini button is inactive, the InfoMini option is activated. The options are:

- Home tab
- Format tab
- Slicers tab
- Insert tab
- Data tab
- Slicer tab (Edit)
- Layout tab
- Series tab
- Resources/Field tab
- Run Immediately.
- Save

When you select an option from the menu, a check mark appears next to the option. The check mark indicates the option is available for the user at run time within the InfoMini application. If you select a checked option to clear it, the check mark disappears, and the option is no longer available through the InfoMini application. If you clear all of the options from the menu, InfoMini is deactivated.

The menu of the InfoMini button is divided into three sections:

- A section for options available in Interactive mode.
A section for options available in Edit mode.

A section with the option to make the Run Immediately button and the Save button available.

The Run Immediately option is set by default. It enables reports to run immediately when InfoMini first launches. You might want to clear this option so that the user can choose a format and pick slicers before running a report.

When the Save option is selected you can pick up your analysis in InfoMini at the same point. For more information on the options you can make available in Interactive mode, see Interactive Mode on page 458. For more information on the options you can make available in the Edit mode, see Edit Mode on page 459.

Interactive Mode

Interactive mode is the default mode when an InfoMini application runs. You can access Interactive mode from the Quick Access Toolbar of an InfoMini application. The Resources panel is not available in Interactive mode. If no options are selected from the InfoMini button when the application runs, the tool still opens in Interactive mode with no ribbon options available.

The following options can be activated in Interactive mode:

- Home tab
- Format tab
- Slicers tab

From the Home tab, you can access the Format, Filter, and Report groups, with the following exceptions:

- The Report and Chart buttons, which are on the Home tab, in the Format group in InfoAssist, are not available in an InfoMini application.

- The Design group, which is on the Home tab in InfoAssist, is not available in an InfoMini application.

For more information on the functionality of the available groups on the Home tab, see Home Tab on page 39.

From the Format tab, you can access the Output Types group, with the following exceptions:

- The Destination, Navigation, and Features groups, which are on the Format tab in InfoAssist, are not available in an InfoMini application.

- The Other button, which is on the Format tab, in the Chart Types group in InfoAssist, is not available in an InfoMini application.
The InfoMini button, which is on the Format tab, in the Destination group in InfoAssist, is not available in an InfoMini application.

For more information on the functionality of the available groups on the Format tab, see *Format Tab* on page 50.

From the Slicers tab, you can access the Options, Record Limit, and Slicer Group groups, with the following exceptions:

- The New Group option, which is on the Slicers tab, in the Options group in InfoAssist, is not available in the Interactive mode of an InfoMini application.

  **Note:** The New Group option is available on the Slicers tab, in the Options group in an InfoMini application in Edit mode.

- The Update Preview option, which is on Slicers tab, in the Options group in InfoAssist, is not available in an InfoMini application.

- The Preview list, which is on the Slicers tab, in the Record Limit group in InfoAssist, is not available in an InfoMini application. It only appears in Edit mode in a document.

For more information on the functionality of the available groups on the Slicers tab, see *Using Slicers* on page 437.

**Edit Mode**

You can access the Edit mode from the Quick Access Toolbar of an InfoMini application. The Resources panel is available in Edit mode.

In addition to the tabs that are available in Interactive mode, the following options can be activated in Edit mode:

- Insert tab (documents only)
- Data tab
- Slicer tab (Edit)
- Layout tab
- Series tab
- Resources/Field tab

From the Insert tab, you can access the Reports, Objects, and active dashboard Prompts (for active HTML, active PDF, and active reports only) groups. The Existing Reports button, which is available in the Reports group, is not available in an InfoMini application. For more information on the functionality of the available groups on the Insert tab, see *Insert Tab* on page 47.
From the Data tab you can access the Calculation, Filter, and Data Source groups, with the following exceptions:

- The Join group, which is on the Data tab in InfoAssist, is not available in an InfoMini application.

- The Add option, which is on the Data tab in the Data Source group in InfoAssist, is not available in an InfoMini application.

For more information on the functionality of the available groups on the Data tab, see Data Tab on page 62.

From the Slicers tab, you can access the Options, Record Limit, and Slicer Group groups, with the following exceptions:

- The Update Preview option, which is on the Slicers tab, in the Options group in InfoAssist, is not available in an InfoMini application.

- The Preview list, which is on the Slicers tab, in the Record Limit group in InfoAssist, is only available in Document view.

For more information on the functionality of the available groups on the Slicers tab, see Using Slicers on page 437.

From the Layout tab, you can access the Page Setup and Report groups. For more information on the functionality of the available groups on the Layout tab, see Layout Tab on page 76.

From the Series tab, you can access the Select, Properties, Line, and Pie groups. For more information on the functionality of the available groups on the Series tab, see Series Tab on page 95.

From the Resources/Field tab, you can access the Filter, Sort, Break, Style, Format, Specific, Visibility, and Links groups. For more information on the functionality of the available groups on the Field tab, see Field Tab on page 85.
Creating an InfoMini Application

**How to:**
- Activate InfoMini
- Enable and Disable InfoMini Application Options
- Test an InfoMini Application
- Interact With an InfoMini Application

To create an InfoMini application in InfoAssist, build a report as you normally would, then activate InfoMini and add the functionality you want the user to have available to them at run time. For more information on what functionality is available to InfoMini applications, see *Understanding InfoMini Applications* on page 456.

**Procedure: How to Activate InfoMini**

1. With an InfoAssist report open, click the *Format* tab.
2. To activate InfoMini, do one of the following:
   - In the Destination group, click *InfoMini*, as shown in the following image.

   ![InfoMini Menu](image)

   **Note:** At least one option from the InfoMini menu must be selected in order to activate InfoMini. By default, the Format tab, Slicers tab, and Save option are selected on the menu when you activate InfoMini in a new report. For more information on enabling InfoMini options, see *How to Enable and Disable InfoMini Application Options* on page 462.
   - In the Destination group, on the InfoMini menu, click one of the following options:
     - Home tab
     - Format tab
     - Slicers tab
     - Data tab
     - Slicer tab (Edit)
Creating an InfoMini Application

- Layout tab
- Resources/Field tab
- Save

The InfoMini button is highlighted and the InfoMini mode is activated. For more information about running an InfoMini application, see *How to Test an InfoMini Application* on page 462.

**Procedure: How to Enable and Disable InfoMini Application Options**

You can choose which options will be available at run time in an InfoMini application. By default, the Format tab, Slicers tab, and Save option are selected on the menu when you activate InfoMini in a new report. For more information about the functionality of each option, see *Understanding InfoMini Applications* on page 456.

1. With an InfoAssist report open, click the **Format** tab.
2. Click the **InfoMini** button and select the options you want available from the menu.

   InfoMini does not have to be active for you to access the menu. When you select an option from the menu, InfoMini is activated.

**Procedure: How to Test an InfoMini Application**

1. With an InfoAssist report open, activate InfoMini as described in *How to Activate InfoMini* on page 461.
2. Enable the options that you want, as described in *How to Enable and Disable InfoMini Application Options* on page 462.
3. Run the report.

   An InfoMini application opens in a new window.

**Procedure: How to Interact With an InfoMini Application**

With an InfoMini application open, you can edit the application using the functionality that was enabled in InfoAssist. You have access to Interactive and Edit mode options, depending on which options were enabled. For more information on the options in Interactive mode, see *Interactive Mode* on page 458. For more information on the options in Edit mode, see *Edit Mode* on page 459.

You have the ability to alter the InfoMini application at run time using the Interactive and Edit modes. Changes to the application are not reflected on the canvas dynamically and you must run the report to see the updates.
1. Run a report with InfoMini activated, as described in *How to Test an InfoMini Application* on page 462.

An InfoMini application opens in a new window.

2. By default, the ribbon is hidden in an InfoMini application. To display the ribbon, do one of the following:

   - Click one of the tabs, as shown in the following image.

   ![Tab Example](image1)

   - Click the *Show Ribbon* button, as shown in the following image.

   ![Ribbon Button Example](image2)
3. To use the InfoMini application in Interactive mode, click Interactive, as shown in the following image.

![Interactive mode in InfoMini](image)

The tabs that are enabled appear on the ribbon. For example, in the preceding image, the Home, Format, and Slicers tab were enabled in InfoMini and appear on the ribbon. The available options on these tabs provide the same functionality as they do in InfoAssist. You can use this embedded functionality to change the report at run time. For more information on the tabs and options that can be enabled in Interactive mode, see Interactive Mode on page 458.

For example, in the following image, active report has been selected as the output format for the report.
The following image shows the active report at run time.
4. To use the InfoMini application in Edit mode, click *Edit*, as shown in the following image.
The tabs that are enabled appear on the ribbon, as shown in the following image. The available options on these tabs provide the same functionality as they do in InfoAssist. You can use this embedded functionality to change the report at run time. For more information on the tabs and options that can be enabled in Edit mode, see *Edit Mode* on page 459.
For example, the following image shows a slicer group that has been created for this report in the InfoMini application.

5. After making your changes, click Run to see an updated version of the report.

For example, the following image shows the report run with Region as the slicer in the InfoMini application.
6. Click Save to save the application.
   You can reopen a saved InfoMini application in InfoMini or, if you have access, open
   the report in InfoAssist.
Creating an InfoMini Application
Glossary

This is a glossary of key concepts in this manual.

Topics:
- Key Concepts
Key Concepts

**accordion report**
Report output that is expandable for each vertical sort field.

**active dashboard prompts**
Controls from Active Technologies that act as filters on the reports of the document, such as text box, image, drop down, list, check box, radio button, and text field.

**active dashboard properties dialog**
A dialog box of options to add active form controls to reports in a document.

**active report**
A report that is designed for offline analysis.

**aggregation value**
A value assigned to a numeric measure field in a report.

**annotation**
Explanatory note or comment.

**axis**
A reference line drawn on a chart.

**axis labels**
Labels generated automatically based upon the scale of the axis. They appear along the axis.

**axis title**
Descriptive text that provides meaningful information about the data measured by an axis.

**background**
The area that appears behind the frame of a chart.

**cascade controls**
Controls that have a parent-child relationship, in which the parent filters the available options of the child. An active form control can be the parent of more than one other control, but cannot be a child of more than one control.
**color bands**

Basic design elements of a chart. Color bands come in a pair, with each band uniquely colored. They appear in a continually repeating pattern behind a series on a chart. The contrast of colors is designed to make a chart easier to read.

**color mode**

The mode that controls how color is applied to a series (measure field) on a chart. The possible settings are By Series (default) and By Group.

**data labels**

Descriptive names that identify specific data points within a series.

**dimension filtering**

An option to display dimension filters at the top of a report.

**feeler line**

A line that connects the data label to a chart.

**Format Grid Lines dialog box**

A dialog box of options to format horizontal and vertical gridlines, color bands, and frames on a chart.

**Format Axis dialog box**

A dialog box of options for formatting for both vertical and horizontal axes.

**Format Gauge dialog box**

A dialog box of options for formatting a gauge chart. Such options include setting and styling a title for the gauge chart, setting tick marks, and color bands, as well as advanced settings, such as setting the gauge start and stop angle.

**Format Labels dialog box**

A dialog box that contains options for editing data labels.

**Format Series dialog box**

A dialog box that contains options to format the fill and border of each series on a chart.

**frame**

The area of a chart that contains all of the basic chart elements, such as the plot points, gridlines, legend, and chart title. The frame appears as a rectangle.

**gridlines**

Lines that run horizontally and vertically to enhance the readability of a chart. Gridlines can be major or minor.
Key Concepts

**legend**
A chart element that displays each series that appears on a chart.

**markers**
Visual elements found on line charts that represent data points on a chart.

**quadrant lines**
Horizontal and vertical lines that cross to divide a chart into four sections.

**reference line**
A line designed to draw attention to specific data locations on a chart. A maximum of three horizontal (X axis) and three vertical (Y axis) reference lines can be added to a chart.

**ring label**
Descriptive name for a concentric ring found on a ring chart.

**series**
A group of data points that are plotted on a chart.

**stack measures**
An option to stack all measures on a report.

**trendline**
A line drawn between any two points on a data series that shows the direction that the values of the data series are going in.
Index

3D chart types 195
3D charts 195
3D depth
  removing from a bar chart 345

A
accessing document view
  from document button 359
  opening an existing item 358
accordion reports 177
active dashboard 408
active dashboard prompts group 49
active report options dialog box
  Advanced tab 405
active report Options dialog box 397, 401, 403
  Colors tab 403
  Menu Options tab 401
active reports Options dialog box
  General tab 398
Active Technologies
  for charts 406
adding to reports 145
Advanced Filter dialog box 68
aggregation options in reports 166
aggregation values 233
annotations
  displaying 352
application button 30
application main menu 31
application window 30
area chart types 190
area charts 189
axis
  manually setting 296
  right-click menu 291
  setting advanced properties 298
  using properties 293
axis labels
  custom format characters 288
  deleting 293
  formatting 284, 295
  horizontal axis labels 284
  rotating 294
  secondary axis labels 285
  staggering 293
  vertical axis labels 285
axis titles
  adding 297
B
bar chart types 185
bar charts 183
Break group 90
bubble charts 194
C
Calculation group 62
cell padding in reports 152
chart
  adding a page heading and a page footing 342
chart (continued)
controlling the rendering of a page heading and
page footing 344
frame and background 299
pyramid 197
rotating 348
chart frame and background
formatting 298
Chart Types group 60
charts
3D 195
area 189
bar 183
bubble 194
chart elements 204
chart formatting tools 204
chart outputs 203
combination 198
creating a basic chart 199
creating a combination chart 202
creating a dual-axis chart 202
creating a multi-axis chart 203
creating an advanced chart 200
creating and customizing 181
displaying annotations 352
funnel 197
gauge 197
gauge thermometer 197
horizontal bar charts 185
horizontal box plot 197
library of advanced charts 199
line charts 188
Live Preview 205
multi-axis 191
pareto 197
pie 186
polar 193
reference lines 349
removing 3D depth 345
right-click menu 206
selecting 183
special 197
spectral map 197
charts (continued)
stock 196
using Active Technologies 406
vertical bar charts 184
vertical box plot 197
visualizing data with 182
XY plot 191
color bands
setting 282
Color dialog box 46
color mode
by group 241
by series 241
Color Mode
By Group setting 216
By Series setting 216
color-banded rows of data in reports 148
column totals in reports 163
combination charts 198
creating a new procedure 23

D
data labels
associated dialog boxes 243
changing the position 255
custom format characters 249
formatting 242
right-click menu 253
showing 254
using properties 254
Data pane
adding fields to a report 104
Data Panel group 79
Data Source group 72
Data tab 62, 64, 68, 72
Calculation group 62
Data Source group 72
Display group 72
Filter group 68
Data tab (continued)
  Join group 64
Design group 41
Destination group 54
Detail (DEFINE) dialog box 63
Display group 92, 99
Document view
  accessing 356
documents
  accessing Document view 356
  aligning components 378
  associate a field with a prompt from the active technologies dashboard properties dialog box 412
  building 361
  building a new 357
  building in document view 355
  cascading prompts 429
  changing the filter condition 424
  creating from a single report 372
  deleting a component 389
  editing component 374
  editing text 386
  insert a chart with right-click 370
  inserting a chart 367
  inserting a chart with double-click 369
  inserting a chart with drag and drop 368
  inserting a chart with the Insert tab 368
  inserting a report 363
  inserting a report with double-click 365
  inserting a report with drag and drop 364
  inserting a report with right-click 366
  inserting a report with the Insert Tab 364
  inserting an existing report 371
  inserting an existing report into a document with the Insert tab 371
  inserting an image 373
  inserting reports from multiple data sources 361
  inserting text 372
  inserting text and images 372
documents (continued)
  inserting two reports from two different data sources 361
  moving a component 377
  resizing a component 374
  set target reports 409
  styling and customizing a chart 384
  styling and customizing a report 382

E
Edit Slicers dialog box 449
Edit Title dialog box 211
Excel output for reports 138

F
Features group (charts) 58
Features group (reports) 57
field formats
  alphanumeric 154
  changing in reports 154
  date 155
  date-time 156
  numeric 155
  percent sign 156
field images 101
Field tab 85, 86, 89, 90, 91, 92, 93
  Break group 90
  Display group 92
  Filter group 86
  Format group 91
  Links group 93
  Sort group 89
  Style group 91
Filter group 42, 68, 86
filtering with slicers 441
Format Axis dialog box 285, 286, 287, 288, 290
  Advanced tab 290
Format Axis dialog box (continued)
  Labels tab 288
  Scale tab 286
  Title tab 287
Format Gauge dialog box 318, 319, 322, 324, 325, 326
  Advanced tab 326
  Axis Scale & Labels tab 322
  Bands tab 325
  General Options tab 319
  Tick Marks tab 324
Format Grid Lines dialog box 268, 269, 271, 272, 273
  Color Bands tab 271
  Frames tab 273
  Major Grid Lines tab 268
  Minor Grid Lines tab 269
  Quadrant Lines tab 272
Format group 39, 41, 91
  Home tab 41
Format Labels dialog box 243, 244, 246, 247, 248, 250, 251
  Advanced tab 246
  Funnel Labels tab 251
  General Options tab 244
  General Options tab (stack chart) 247
  Pie Labels tab 248
  Pie Title tab 250
Format Legend dialog box 256, 257, 259, 260
  Advanced tab 260
  Legend Options tab 257
  Markers & Labels tab 259
Format Series dialog box 209, 211
  Border tab 211
  Fill tab 209
Format tab 50, 51, 54, 56, 57, 58, 60, 61
  Chart Types group 60
  Destination group 54
  Features group (charts) 58
  Features group (reports) 57
  Labels group (charts) 61
  Navigation group (reports 56
  Output Types group 51

Frame & Background dialog box 299, 300, 302, 304, 306, 307, 308, 310, 312
  Advanced tab for 3D charts 308
  Background tab 310
  Frame Edge tab for 2D charts and 2D charts with 3D effects 302
  Frame Edge tab for pie charts 306
  Frame tab for 2D charts and 2D charts with 3D effect 300
  Frame tab for pie charts 304
  right-click menu 312
  Wall and Floor tabs 307
frame and background
  using properties 313
freezing column titles in reports 175
funnel charts 197

G
gauge
  using properties 328
gauge chart
  right-click menu 327
gauge charts 197, 318
  Format Gauge dialog box 318
gauge thermometer 197
gridlines 267, 274, 276, 277, 278, 279, 282
  deleting 282
  displaying horizontal minor 276
  displaying vertical major 277
  displaying vertical minor 278
  formatting 267
  major 267
  minor 267
  right-click menu 274
  setting the color, weight, and style 279
  using properties 274
H
headings and footings 145, 148
styling in a report 148
Help 25, 30
Home tab 39, 41, 42
  Design group 41
  Filter group 42
  Format group 39, 41
  Report group 42
horizontal box plot charts 197
horizontal major gridlines displaying 275
HTML5 53
I
InfoAssist
  accessing 22
  introducing 15
InfoAssist Basic 17, 23
  accessing 23
InfoAssist interface
  application button 30
  application window 30
  Help 30
  Layout canvas 31
  main components 30
  navigating 29
  Navigation taskbar 31
  Output window 31
  Query Design pane 31
  Quick Access Toolbar 30
  Resources panel 30
  Results panel 30
  ribbon 30
  status bar 31
InfoAssist Options dialog box 24
InfoMini 18, 23
  accessing 23
Insert tab 47, 48, 49
  active dashboard prompts group 49
  Objects group 48
  Report group 48
inserting a chart 367
J
Join dialog box 65
Join group 64
L
Labels group (charts) 61
layout canvas 31
Layout canvas 119
Layout tab 76, 77
  Page Setup group 76, 77
  Report group 77
  Size & Arrange group 77
legend
  right-click menu 261
legends
  controlling the orientation 264
  formatting 256
  hiding 262
  positioning 262
  specifying background color 265
  specifying border color 266
  using properties 262
limiting column variables in reports 159
line chart types 189
line charts 188, 220
  applying a smooth effect 220
Line group 97
Line Style dialog box 253
Links group 93
List view 80
Logical view 79

M
major gridlines 267
marker
  changing the appearance of 222
markers
  connecting or hiding a series line 221
mathematical equations 219
minor gridlines 267
multi-axis charts 191

N
Navigation group (reports) 56
Navigation taskbar 31, 131

O
Objects group 48
Options group 74
Options window 26
Output Types group 51
Output window 31, 121, 123, 124, 125
cascade 123
output format options 125
output target options 121
output view options 123
switch output 125
tile horizontally 124
tile vertically 125
Output Window group 83

P
page and line breaks in reports 159
page footing
  adding to a chart 342
page heading
  adding to a chart 342
page headings and page footings
  formatting 342
Page Setup group 76, 77
pareto charts 197
Personal InfoAssist 16, 22
  accessing 22
pie chart types 187
pie charts 186
Pie group 98
pie slices
  expanding 225
  hiding 226
polar charts 193
pop-up titles in reports 165
Properties group 95
pyramid charts 197

Q
Query Design pane 31, 81, 103, 108, 207
  1x4 81
  areas 2x2 81
  filter area 103
  right-click options 108
  right-click options for charts 207
  tree 81
Query Panel group 81
Quick Access Toolbar 30, 35
Reports

-ranking fields in reports 158
-recalculating compute results in a report 170
-reference lines 349
-repeated sort values in reports 168
-Report group 42, 77, 84
-Report Style dialog box 45
-reports
-accordion reports 177
-aggregation options for measure data 166
-cell padding 152
-color-banded rows of data 148
-column totals 163
-creating an active technologies report 392
-custom features 157
-customized output 170
-Excel output 138
-freezing column titles 175
-headings and footings 145
-limiting column variables 159
-OLAP reports 171
-page and line breaks 159
-pages on demand 176
-pop-up titles 165
-ranking fields 158
-recalculating compute results 170
-repeated sort values 168
-report-level styling 139
-row totals 164
-stacked measures 178
-Style group 143
-styling 135, 139
-styling column titles 142
-styling data 142
-styling headings and footings 148
-styling rows with alternate colors 148
-subheadings and subfootings 164
-subtotals 160
-table of contents 173

reports (continued)
-traffic light conditional styling by constant 149
-traffic light conditional styling by field 151
-visualization bars 165

Reports
-Live Preview 205
-Resources panel 30, 99, 101, 105
-field images 101
-using Query Design pane in 105
-Results panel 30, 115, 116
-using Query Design pane in 116
-ribbon 30
-row totals in reports 164

Scatter charts 192
-secondary axes options
-Format Secondary Axis dialog box 291
-Section 508 accessibility 19
-Select a data source dialog box 73
-Select group 95
-selecting a data source 23
-series 208, 214, 217, 218, 227, 229, 231, 239, 241, 242
-changing the title 239
-changing the type 218
-color mode 241
-deleting 242
-dialog boxes 208
-filtering values in 229
-formatting 208
-formatting the fill and border 218
-hiding fields 231
-reversing the order of 227
-right-click menu 214
-selecting 217
-using properties 217
-Series tab 95, 97, 98, 99
-Display group 99
Series tab (continued)
  Line group 97
  Pie group 98
  Properties group 95
  Select group 95
Show/Hide group 78
Size & Arrange group 77
Size and Position dialog box 376, 378
slicers
  Edit Slicers dialog box 449
  filtering with 441
  using 437
Slicers tab 74, 75
  Group Number group 75
  Options group 74
  Record Limit group 74
Sort group 89
sorting fields 229
special charts 197
spectral map charts 197
stacked measures in reports 178
status bar 31, 133
stock chart types 197
stock charts 196
Structured view 80
Style dialog box 252
Style group 91
subheadings and subfootings in reports 164
subtotals in reports 160
Summary Field (COMPUTE) dialog box 63

T

ticks
  setting 280

Traffic Light Condition dialog box 211
traffic light conditional styling by constant in reports 149
traffic light conditional styling by field in reports 151
traffic light conditions
  applying with drill-down to numeric measure field (by constant) 235
  applying with drill-down to numeric measure field (by field) 238
trendlines
  adding 219

U

user preferences
  changing 25
  environment and styling 27
  format 27
  layout 26
  start up options 26
  view 27

V

vertical box plots charts 197
View tab 78, 79, 81, 83, 84
  Data Panel group 79
  Output Window group 83
  Query Panel group 81
  Report group 84
  Show/Hide group 78
visualization bars in reports 165

X

XY plot chart types 194
XY plot charts 191
In an ongoing effort to produce effective documentation, the Documentation Services staff at Information Builders welcomes any opinion you can offer regarding this manual.

Please use this form to relay suggestions for improving this publication or to alert us to corrections. Identify specific pages where applicable. You can contact us through the following methods:

**Mail:** Documentation Services - Customer Support
Information Builders, Inc.
Two Penn Plaza
New York, NY 10121-2898

**Fax:** (212) 967-0460

**Email:** books_info@ibi.com

**Web form:** [http://www.informationbuilders.com/bookstore/derf.html](http://www.informationbuilders.com/bookstore/derf.html)

Name:__________________________________________________________

Company:________________________________________________________________________

Address:______________________________________________________________________________

Telephone:_________________________Date:____________________________

Email:__________________________________________________________

Comments:
